Error while initializing repository

Hello forum,
I would be glad if someone could help me for when I start the YaST tool in order to install/delete software an error message pops up during the initializing process, saying “Fehler bei der Initialisierung des Repositorys” (error while initializing the repository). Yet the program continues to run but when the software repository is displayed by group every single program is ticked as if installed on my computer (which it isn’t). How can this be remedied?

My system has the following specifications:
OS: Linux 2.6.31.12-0.2-desktop i686
System: openSUSE 11.2 (i586)
KDE: 4.3.5 (KDE 4.3.5) “release 0”

Many thanks in advance!
Euklidion

Open a terminal and post result of

zypper lr -d

| Alias | Name | Aktiviert | Aktualisieren | Priorität | Typ | URI | Dienst

–±----------------±----------------------±----------±--------------±----------±---------±-------------------------------------------------------------------------------------------------±------
1 | Repository | Repository | Ja | Ja | 99 | plaindir | hd:///?device=/dev/disk/by%2did/usb%2dINTENSO_USB_AA04013000008984%2d0:0%2dpart1&filesystem=auto |
2 | kile-2.1b3 | kile-2.1b3 | Ja | Ja | 99 | plaindir | dir:///home/mark/Programme/kile/kile-2.1b3 |
3 | kile-2.1b3_1 | kile-2.1b3 | Ja | Ja | 99 | plaindir | dir:///home/mark/Programme/kile/kile-2.1b3 |
4 | openSUSE 11.2-0 | openSUSE 11.2-0 | Ja | Nein | 99 | yast2 | cd:/// |
5 | repo-debug | openSUSE-11.2-Debug | Nein | Ja | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
6 | repo-non-oss | openSUSE-11.2-Non-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
7 | repo-oss | openSUSE-11.2-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/oss |
8 | repo-source | openSUSE-11.2-Source | Nein | Ja | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
9 | repo-update | openSUSE-11.2-Update | Ja | Ja | 99 | rpm-md | Index of /update/11.2

I hope this helps

Remove repos 1-4 and try again
Repository Management - openSUSE Forums

Excellent! It works again! If it does not mean to steal your time I would like to ask if you could you explain what I did wrong and how I could avoid the same blunder in future.

Many thanks again!

I don’t know what you did to add 1-3
But 4 was the cd/dvd install media

All you probably need is to follow this
Multi-media and Restricted Format Installation Guide - openSUSE Forums
Which will give you multi-media functionality and then access to the Packman repo which is packed full of good stuff.