Error While Deleting - File Doesn't Exist

Appeared in my home folder an file with the name “??=?%??!??h?^???h?}???m???S??H??O”. I simply can’t delete because “this file doesn’t exist”. I have tried different ways, including rm in terminal.

How can I delete this file?

Many thanks.

I’d say try using the terminal to delete said file or mc if you’re not a text mode user

Wonderful, mc worked like a charm. Thanks.

And for some next problem next time, remind that we love to analyze problems were computer generated information is provided. Does please do not say (only)

including rm in terminal.

but copy past from your terminal, the line with the command (the complete line including the prompt), the output up to and including the next prompt. Then we will see exactly what you saw and not much explanation (let alone interpretation) from your side is required.

In my experience, if you first elevate to root permissions, and then “rm” the file, it has always worked for me.
If for some strange reason it still didn’t work, then I might start looking at things like file system integrity.


My remarks was NOT about how to analyze this already solved problem, but how to report "what you did and got back "in a post in the forums.

This is bad:

I tried to remove the file, but it did not work.

This is much better:

henk@boven:~> rm aap
rm: kan ‘aap’ niet verwijderen: Bestand of map bestaat niet

And this is still better here on the English language part of the forums:

henk@boven:~> LANG=C rm aap
rm: cannot remove 'aap': No such file or directory

Now I get it. Thanks everyone.