Error while booting: "Dependency failed. Aborted start of /srv/www/htdocs/owncloud"

While booting I got following error:
“Dependency failed. Aborted start of /srv/www/htdocs/owncloud”
then it shows me “emergency mode” prompt.

*I’ve installed owncloud (on apache2). Then I changed some configs, and after that it started to show “Job failed. See system logs and ‘systemctl status’ for details.”, while apache’s error log was clean. I tried to restore configs from backups, but it didn’t help. I decided to reinstall apache and owncloud (with renaming configs). Next boot time I got this error.

*Attempts to fix.
*I tried to reinstall apache and owncloud one more time. Apache’s logs are still clean and I still can’t start apache. Failsafe mode doesn’t help.

Sorry for mistakes in my post, I’m not native speaker.

Which version of openSUSE?

The last: 12.1 with all updates (+ several additional repos, but IMHO only OBS owncloud can be connected with this situation).

It was my fault.
I understood that then I tried to use sysvinit for boot. It shown me, that one disk is missing. That’s because when I used owncloud I mounted owncloud data folder to external usb drive (my internal hdd is to small) with fstab. Then I removed usb drive from my pc, so I got this error. Now I’m writing from this PC, all is OK.
Sorry for stupid question. It was impossible to answer it because of lack of information.
Thread is closed.

It is not a “stupid question” at all. In your case it may even be that writing the post makes you mind overthink yoor situation again and thus made you seeing what went wrong. This works even if nobody (yet) answered the thread.

And when this does not happen by itself, allways someone will come and ask things that may your brain make a jump for the best.

That is all very human, often we need some trigger to step outside of the path of thinking we repeat all over. :wink:

And of course it is very satisfying and good for your self esteem, that you found it yoursekf. :wink: