Error when running virt-install


I am trying now to setup a virtual machine using xen. Whenever I run virt-install I get the following error:

EN61121-suse:/usr/src # virt-install
ERROR Failed to connect socket to ‘/var/run/libvirt/libvirt-sock’: No such file or directory

From what I was able to find, this is because libvirtd is not running. However trying to run libvirtd returns this:

EN61121-suse:/usr/src # libvirtd
2014-06-25 10:46:22.982+0000: 7188: info : libvirt version: 1.2.5
2014-06-25 10:46:22.982+0000: 7188: warning : virGetHostname:654 : getaddrinfo failed for ‘EN61121-suse’: Name or service not known
2014-06-25 10:46:23.082+0000: 7199: info : libvirt version: 1.2.5
2014-06-25 10:46:23.082+0000: 7199: error : libxlDriverConfigNew:1160 : Unable to configure libxl’s memory management parameters
2014-06-25 10:46:23.082+0000: 7199: error : virStateInitialize:749 : Initialization of LIBXL state driver failed: Unknown problem
2014-06-25 10:46:23.082+0000: 7199: error : daemonRunStateInit:922 : Driver state initialization failed
EN61121-suse:/usr/src #

I tried searching for more info on this but there isn’t much I can find other than the fact that the root user is supposed to be part of a group called libvirtd which I cannot find.

Has anybody run into this before?

Hello and welcome to the openSUSE forums.
Whenever you post in these forums, you need to provide basic information about your system as follows…

Need to know

  • What is your HostOS
    One way you can display the result of the following
uname -a
  • What is your Desktop (if you are running one)
  • How did you install Xen and libvirt (from where)
    If you don’t know and you are running on a recent version of openSUSE, you can obtain the information from “zypper info” eg the following
zypper info xen
zypper info libvirt

Assuming you are running on x64 hardware.


Sorry for the lack of details the first time:). I am running OpenSuSE 13.1 on an HP Compaq 8300. i5@3.2 Ghz with onboard graphic chipset. The kernel is the default xen kernel from the repos and xen was also installed from there. I am running KDE 4.13.2

EN61121-suse:/home/gavram # zypper info libvirt
Retrieving repository ‘Plasma next frameworks’ metadata …[done]
Building repository ‘Plasma next frameworks’ cache …[done]
Retrieving repository ‘openSUSE BuildService - Virtualization (VirtualBox)’ metadata …[done]
Building repository ‘openSUSE BuildService - Virtualization (VirtualBox)’ cache …[done]
Loading repository data…
Reading installed packages…

Information for package libvirt:

Repository: openSUSE BuildService - Virtualization (VirtualBox)
Name: libvirt
Version: 1.2.5-408.1
Arch: x86_64
Vendor: obs://
Installed: Yes
Status: out-of-date (version 1.2.5-404.6 installed)
Installed Size: 106 B
Summary: Library providing a simple virtualization API
Libvirt is a C toolkit to interact with the virtualization
capabilities of Linux. Virtualization of the Linux Operating System means
the ability to run multiple instances of Operating Systems concurrently
on a single hardware system where the basic resources are driven by a
Linux instance. The library aims to provide long term stable C API
to interact with Linux virtualization technologies.
EN61121-suse:/home/gavram #

N61121-suse:/home/gavram # zypper info xen
Loading repository data…
Reading installed packages…

Information for package xen:

Repository: openSUSE BuildService - Virtualization (VirtualBox)
Name: xen
Version: 4.4.0_22-322.3
Arch: x86_64
Vendor: obs://
Installed: Yes
Status: up-to-date
Installed Size: 32.9 MiB
Summary: Xen Virtualization: Hypervisor (aka VMM aka Microkernel)
Xen is a virtual machine monitor for x86 that supports execution of
multiple guest operating systems with unprecedented levels of
performance and resource isolation.

This package contains the Xen Hypervisor. ™

EN61121-suse:/home/gavram # uname -a
Linux EN61121-suse 3.11.10-17-xen #1 SMP Mon Jun 16 15:28:13 UTC 2014 (fba7c1f) x86_64 x86_64 x86_64 GNU/Linux

If there is any other info I can provide please let me know.

Kind Regards,