Error when mounting remote cifs/samba Compact Flash

Am in the process of upgrading from an ancient OpenSuSE release (7.2) to 11.2. One thing I have been unable to do that worked fine under 7.2 is remotely mounting a compact flash drive from an XP machine. Worked fine for many moons on 7.2:

mount -t cifs -o rw //xpbox/‘cf (H)’ /cf0

I get:

mount error(12): Cannot allocate memory

Other cifs mounts of hard disks work fine.

I found a posting that says this means the memory allocation error is from the XP side. It says to fiddle with the XP registry, specifically IRPStackSize. I was not confident this fix would work since there should not be anything significantly more consuming with 11.2 compared to 7.2, and indeed, I got the same error after changing the parameter to 18 and rebooting the XP machine.

Any ideas? I have some suspicion that the space and parenthesis in the share name might be fouling up someone. XP forces the share name to this for some reason.

Help is appreciated.

  • Chuck

OP here with more data.

The mount works when a compact flash is in the reader, fails with the memory allocation complaint if there is no CF present. The old 7.2 system did not care if the CF was present, the mount works.

So I’m convinced this is an issue on the Linux side, not Windows.

Any ideas?

OK, I know. Stop hitting yourself with the hammer, right? Only do the mount when there is a CF in the slot. But if that’s the solution, there is no way to have a setup where the CF is mounted on reboot.

  • Chuck