Error when emptying trash

–Running KDE 4.1 in 11.1, on a X_86_64 machine–

Whenever I try to empty the trash through the GUI I get the following error :

“The file or folder /home/user/.local/share/Trash/files/file.xx does not exist.”

This is an old file I had deleted before upgrading to 11.1, and is obviously nowhere to be found in the filesystem (as the error implies).

Usually it deletes the rest of the (existing) trash content, but once in a while there’ll be files left that must be deleted through removing the command line. I’m guessing their name comes later alphabetically or something. Now this is more an annoyance than a big problem, but we all know how annoying these can be… :slight_smile:

Any ideas on how to get rid of this fantom file?

Thx guys.

Could be a rights issue or other?

Have you tried opening a console, elevating to root (using ‘su -’ )and deleting it that way?


Try deleting ~/.local/share/trash. It will any way be restored when you put something in trash.

Seems to have worked. Thx man.