ERROR - URGEND. Cannot run programs!

Here we have it: A small disaster. :stuck_out_tongue:

Everyone has programs on their desktop. So do I. But one thing about my current configuration seems to be unique: When starting a program like FileZilla or lets say… TextEditor the icon appears as mouse pointer and starts to wobble (normal activity).

And then… vanishes. Just like that. No notification, no nothing. Help to fix the issue is appreciated.
**

ARgH!**

are you running out of disk space? Thats what kept me from being able to launch any desktop check your /tmp directory

There are MASSES of Gigabytes left. Don´t think so. Thanks anyway.
Any other solutions?

TheMask

Do the same programs run OK from a terminal? Run from a terminal and look for error messages.

try running from konsole. this way you can paste some errors to us. :slight_smile:

Well… may I paste the icon into the console? i´m not at my computer right now. Just collecting advices.

TheMask.

Well… may I paste the icon into the console? i´m not at my computer right now. Just collecting advices.

TheMask.

No, you will need to type the command to launch the program in the console. For example, to launch Firefox, just type ‘firefox’ (without the quotes) and firefox should launch. If not, then error messages should be displayed in the console.

Hi
Right click on the icon and select properties and then check the
command that is being run, run that command in the konsole/console and
see what happens :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 3 days 7:34, 2 users, load average: 0.00, 0.07, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Ok. Here it is:


TheMask@System:~> /usr/bin/vmware
Logging to /tmp/vmware-TheMask/setup-3674.log

(vmware-modconfig:3674): Gtk-WARNING **: Im Modulpfad »qtcurve« konnte keine Themen-Engine gefunden werden,
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:72: error: unexpected identifier `colorize_scrollbar', expected character `}'
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
modinfo: could not find module vmmon
modinfo: could not find module vmnet
modinfo: could not find module vmblock
modinfo: could not find module vmci
modinfo: could not find module vsock
/usr/bin/vmware: line 31:  3674 Speicherzugriffsfehler  "$BINDIR"/vmware-modconfig --appname="VMware Workstation" --icon="vmware-workstation"

TheMask@System:~> filezilla
filezilla: error while loading shared libraries: libwx_gtk2u_richtext-2.8.so.0: cannot open shared object file: No such file or directory

Any suggestions?*

Hi
Have you restarted the vmware service and is the service set to on at
boot?


sudo /sbin/chkconfig vmware
sudo /etc/init.d/vmware status


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 3 days 8:53, 1 user, load average: 0.02, 0.10, 0.08
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Yeah. First of all: I know these three rules since ages. :wink:
Outputs are:

vmware on

…and…

Module vmmon not loaded
Module vmnet not loaded

Hi
Your service isn’t started then, try running;


sudo /etc/init.d/vmware restart


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 3 days 9:08, 2 users, load average: 0.21, 0.07, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Whoa strange, dude:


root's password: bla
Stopping VMware services:
   Virtual machine communication interface                             done
   Virtual machine monitor                                             done
   Blocking file system                                                done
Starting VMware services:
   Virtual machine monitor                                            failed
   Virtual machine communication interface                            failed
   Blocking file system                                               failed
   Virtual ethernet                                                   failed

wtf…

Mh… what to do now?


TheMask***

Hi
Have a look at the vmware installer log in /var/log for anything?
Re-install vmware? I’m assuming you have a valid license or are you
using a temp one and it’s run out?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 3 days 10:02, 3 users, load average: 0.23, 0.30, 0.27
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Yeah, I have a valid license with a key. it doesn’t say how to activate the key though… maybe that’s the problem? Log comes in a sec.
//edit: Which log to refer to?

TheMask.

Here is the log of vmware-installer:


Using UI type null
Opening database file /etc/vmware/database
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
Aufruf:

Hilfeoptionen
-?, --help                                     Hilfeoptionen anzeigen
--help-all                                     Alle Hilfeoptionen anzeigen
--help-install                                 Optionen der Installation anzeigen

Anwendungsoptionen
-v, --version                                  Die Version ausgeben

gconfd-2: Kein Prozess abgebrochen
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'fonts/package'
Unknown media type in type 'interface/x-winamp-skin'

Configuring Bridged network vmnet0
Configuring hostonly network vmnet1, probing for unused subnet ...
Configuring NAT network vmnet8, probing for unused subnet ...
Configured default networks - Bridged, Hostonly, NAT
Shutting down cupsd..done
Starting cupsd..done
Unable to install kernel modules
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'fonts/package'
Unknown media type in type 'interface/x-winamp-skin'

TheMask.*

Here is the log of vmware-installer:


Using UI type null
Opening database file /etc/vmware/database
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
destination /tmp/tmpMcSMSn/.installer/__init__.py already exists, overwriting.
Aufruf:

Hilfeoptionen
-?, --help                                     Hilfeoptionen anzeigen
--help-all                                     Alle Hilfeoptionen anzeigen
--help-install                                 Optionen der Installation anzeigen

Anwendungsoptionen
-v, --version                                  Die Version ausgeben

gconfd-2: Kein Prozess abgebrochen
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'fonts/package'
Unknown media type in type 'interface/x-winamp-skin'

Configuring Bridged network vmnet0
Configuring hostonly network vmnet1, probing for unused subnet ...
Configuring NAT network vmnet8, probing for unused subnet ...
Configured default networks - Bridged, Hostonly, NAT
Shutting down cupsd..done
Starting cupsd..done
Unable to install kernel modules
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'fonts/package'
Unknown media type in type 'interface/x-winamp-skin'

TheMask.*

Hi
You need to add it from the GUI.

Have a browse of the /var/log/vmware-installer file


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 3 days 10:25, 3 users, load average: 0.27, 0.24, 0.18
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22