ERROR: Unable to query GPU information for Nvidia GTX970M Graphics Card

I recently downloaded my Nvidia drivers and suse-prime in YaST. Every time I try to switch over to my Nvidia graphics card I get this error message. My laptop is an Alienware 17R3. Any suggestions?

ERROR: Unable to query GPU information

Reconfiguration failed
Restoring previous configuration: intel


Hi
Are you using suse-prime, other? If on the intel device can you provide the output from;


xrandr --listproviders

I am using suse-prime. I currently have it set to intel and below is what I get when I run xrandr --listproviders.

Providers: number : 1
Provider 0: id: 0x47; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offloa
d); crtcs: 3; outputs: 5; associated providers: 0; name: modesetting
    output eDP-1
    output DP-1
    output HDMI-1
    output DP-2
    output HDMI-2


Hi
So the nvidia drivers are the rpm’s? Latest kernel (5.3.18-lp152.72-default)?

The packages I currently have installed are:

nvidia-computeG05 (460.73.01-lp152.37.1)
nvidia-gfxG05-kmp-default (460.73.01_k5.3.18_lp152.19-lp152.37.1)
nvidia-glG05 (460.73.01-lp152.37.1)
x11-video-nvidiaG05 (460.73.01-lp152.37.1)

Hi
OK, does the following show your card?


/sbin/lscpi -nnk | egrep -A3 "VGA|Display|3D"
nvidia-smi

If you boot to the previous kernel and force the reinstall on the Nvidia rpms, then reboot does it start working?

The first line of code gives me this

bash: /sbin/lscpi: No such file or directory

The nvidia-smi shows

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure
 that the latest NVIDIA driver is installed and running.


I deleted all of the previous drivers installed and reinstalled them and I still get the same error message when trying sudo prime-select nvidia.

Just realized I did not do this right. I deleted the current drivers and reinstalled them. I am now deleting the current drivers and will install the G04 drivers.

Same thing is happening when I deleted the new ones and installed the old ones. Should I try not authorizing the MOK after installation and reboot?

Hi
Can you disable secure boot and try again…

FWIW I have a Leap 15.2 here but it’s a desktop with GT710’s and using the intel card and offload, but at present after the latest update it’s not working for me, I see nvidia-smi and clinfo, but no offload some something is funky somewhere…

https://forums.opensuse.org/showthread.php/553290-ERROR-Unable-to-query-GPU-information-for-Nvidia-GTX970M-Graphics-Card?p=3025242#post3025242

/sbin/lscpi -nnk | egrep -A3 “VGA|Display|3D”

lspci, not lcspi.

Needs


/sbin/**lspci** -nnk | egrep -A3 "VGA|Display|3D"

When I do it this way I get

00:02.0 **VGA** compatible controller [0300]: Intel Corporation HD Graphics 530 [8086:191b]
 (rev 06)
        Subsystem: Dell Device [1028:0708]
        Kernel driver in use: i915
        Kernel modules: i915
--
01:00.0 **3D** controller [0302]: NVIDIA Corporation GM204M [GeForce GTX 970M] [10de:13d8] 
(rev a1)
        Subsystem: Dell Device [1028:0708]
        Kernel modules: nouveau
3b:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E2400 Gigabit Ethernet Cont
roller [1969:e0a1] (rev 10)


However, nvidia-smi still gives me

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure
 that the latest NVIDIA driver is installed and running.


Uninstall nouveau, blacklist nouveau, install Nvidia drivers.

I tried it with secureboot disabled and it still does the same thing. It’s not like it is a huge deal or anything. I’m not doing anything graphically intense. I would just prefer to run on my awesome built in graphics card as opposed to the intel GPU. I’m sure there is some information somewhere out there that states my card doesn’t work with it or something lol.

I don’t know if it makes a difference that I am dual booting with Windows 10 on an HDD that was previously installed and OpenSUSE on an SSD that I recently installed via one of my PCIe slots or not. My card obviously works in my native Windows installation. However, I am planning on ridding myself of windows entirely after I graduate at the end of this year. However, I may end up cloning this HDD onto another SSD in my second PCIe slot and use that for work. Who knows.

1st, I uninstalled the following:

Mesa-dri-nouveau
libdrm_nouveau2
libvdpau_nouveau
xf86-video-nouveau

Basically, if it had the word Nouveau in it I uninstalled it. However, after uninstalling those and reinstalling the Nvidia drivers, upon reboot, I had no GUI. I ended up reinstalling them so I could get my system back to normal. Am I only supposed to delete the xf86 driver?

Second, I have looked up how to blacklist nouveau, but I can’t seem to find a thread or anything with clear instructions. I tried the nomodeset method in grub and that just left me without a GUI again. The instructions here: https://en.opensuse.org/SDB:NVIDIA_the_hard_way aren’t really even that clear, unless I am reading them wrong.

Hi
Leave libdrm_nouveau2 and libvdpau_nouveau installed (I have them). So more testing if I remove the nvidia driver (and /etc/modprobe.d/50-nvidia.conf), run mkinitrd to get back to nouveau offload re-appears with the nouveau driver.

The strange thing is, with the nvidia driver, clinfo and nvidia-smi function… there is some underlying issue for sure…

Hi
OK, this looks like the issue;
https://forums.developer.nvidia.com/t/official-driver-384-59-with-geforce-1050m-doesnt-work-on-opensuse-tumbleweed-kde/52620#5203910

Whilst Tumbleweed, I think there is some sort of regression in the intel driver on Leap 15.2…

Without the Nvidia driver installed, I see 4 devices (1x intel and i915, 3 x GT710 and nouveau)

OK, have a fix…


cat /etc/X11/xorg.conf.d/49-device.conf

Section "ServerLayout"
        Identifier "layout"
        Option "AllowNVIDIAGPUScreens"
EndSection


xrandr --listproviders

Providers: number : 4
Provider 0: id: 0x769; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 3; outputs: 7; associated providers: 0; name: modesetting
    output VGA-1
    output HDMI-1
    output DP-1
    output HDMI-2
    output HDMI-3
    output DP-2
    output DP-3
Provider 1: id: 0x738; cap: 0x0 (); crtcs: 4; outputs: 3; associated providers: 0; name: NVIDIA-G2
    output 0x73d
    output 0x73e
    output 0x73f
Provider 2: id: 0x4d8; cap: 0x0 (); crtcs: 4; outputs: 3; associated providers: 0; name: NVIDIA-G1
    output 0x4dd
    output 0x4de
    output 0x4df
Provider 3: id: 0x278; cap: 0x0 (); crtcs: 4; outputs: 3; associated providers: 0; name: NVIDIA-G0
    output 0x27d
    output 0x27e
    output 0x27f

Now if above works for you, and shows one device, does the following work?


 __NV_PRIME_RENDER_OFFLOAD=1 __NV_PRIME_RENDER_OFFLOAD_PROVIDER=NVIDIA-G0 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo|egrep "OpenGL vendor|OpenGL renderer"

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce GT 710/PCIe/SSE2 

You can do all this quite easily with YaST. No need for “the hard way” IMHO. If you have lost you GUI, just start YaST in the terminal as root:

**~ #** yast

Go to software management, search for “nouveau”. Move to the package and type “b” for “taboo” to blacklist it.

Same here, at least for libdrm_nouveau2. YaST will complain about missing dependencies. Blacklisting mesa-dri-nouveau and the xf86-video-nouveau should be ok.

Then go on search for “G04” and look for nvidia-computeG04. (I suggest to try G04 as I have had the same prime-select problem with G05). YaST should pull the other packages. Otherwise search for “G05” and try this again. After all, you didn’t have the G05 properly running. Make sure to get the correct kmp-package for your kernel. BTW, you have added the nvidia repo, haven’t you?

If all dependencies are fine then hit OK, leave YaST and reboot. Then again try

prime-select nvidia

If it still doesn’t work, Malcolm has more knowledge than I do and already suggested the fix for further troubleshooting.:shame:

Thank you for this. I will have to try all of this out this weekend or even later. I am in the last two weeks of my semester and absolutely swamped as of late. This returning to college as an adult thing and trying to help run a business, all while trying to get my back into linux after not using it for nearly 10 years is exhausting lol!