error ; SLE-15-SP2:GA

Muy buenas de nuevo, no se si va aquí este error que me da zypper al actualizar paquetes. Os lo pongo por si me podéis ayudar.

Merci.

PD : No pongo foto porque soy incapaz de incrustarla aquí.

Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository ‘SUSE:SLE-15-SP1:Update’ because of the above error.
Repository ‘packman’ is up to date.
Repository ‘Update repository of openSUSE Backports’ is up to date.
Repository ‘Non-OSS Repository’ is up to date.
Repository ‘Main Repository’ is up to date.
Repository ‘Update repository with updates from SUSE Linux Enterprise 15’ is up to date.
Repository ‘Main Update Repository’ is up to date.
Repository ‘Update Repository (Non-Oss)’ is up to date.
Some of the repositories have not been refreshed because of an error.

Hola:

La url no es correcta ( URIs) , comenta por favor que la compruebes y de paso la salta para seguir refrescando los otros repositorios .

¿Sabes si aparece en la lista de repositorios de yast, cuando le das a añadir ? .

Deberías poner el nombre del distro o versión de S.O. linux , Ejemplo :


HP-OMEN:~ # inxi -S 
System: 
  Host: HP-OMEN Kernel: 5.14.21-150400.24.28-default arch: x86_64 bits: 64 
    Console: pty pts/1 Distro: openSUSE Leap 15.4


**
****Distro: openSUSE Leap 15.4

**
****Si es de Leap o de tumbleweed , suele haber una lista de los repositorios, en la wiki de openSUSE .(Repositorios oficiales) .
Y si es de SUSE, suelo ver la documentación que aparece en la web.

Lo que hago a veces es ir a yast —> Repositorios de software y de ahí borro los que están mal (en el caso que borre otro, vuelve de nuevo a la lista, si le doy añadir , aparece ahí de nuevo y lo añado) .

Saludos cordiales .

Hola:

Leap suele tener algún repositorio de SUSE Linux Enterprise uno de actualización y otro de depuración (update y debug) , pero si tu distro es : SLE-15-SP2:GA , puede que se haga de otra forma; lo digo por que busque por la web y lo que encuentro son documentaciones de SUSE (en español) , pero de actualización ,en cambio para repositorios o lista no he visto mucho . (solo de packman, porque están todos juntos openSUSE y SUSE ) , Lo que no me acuerdo , si las preguntas para SUSE se hacen en otro sitio .

Los datos de la distro, suele estar en un fichero en /etc/os-release , como es de tipo texto , se puede ver desde la consola ejecutando
[FONT=monospace]cat /etc/os-release , o bien con kate en el archivo [/FONT][FONT=monospace][FONT=monospace]os-release .

Saludos cordiales .

[/FONT][/FONT]

Hola.

Podrías hacer lo siguiente:

  1. Ve a YaST->Software y en “Ver” selecciona “repositorios”. En la pestaña “repositorios” selecciona SUSE:SLE-15-SP1
  2. Comprueba que el sofware que está en ese repositorio tiene instaladas versiones que no vengan de ese repositorio con la pestaña de información “Versiones” (abajo).
  3. Ve a “Configuración->Reposltorios” y deshabilita o elimina ese repositorio de la lista.
  4. Como el título del hilo es error ; SLE-15-SP2:GA, haz lo mismo para este repositorio y para SLE-15-SP3:GA si lo hubiera. Te recomiendo participar aquí: https://forums.opensuse.org/showthread.php/567064-Comprobar-idoneidad-de-los-repositorios

En realidad podrías ir a 4 y luego usar sudo zypper dup, pero bueno, es mejor familiarizarse con el sistema de repositorios antes de hacer este tipo de cosas. Y no, no deberías de tener esos repositorios, que pueden venir de haber usado herramientas como 1-click que son muy cómodas pero para Leap 15.3 y siguientes funcionan un poco mal.

notas:

https://es.opensuse.org/One_Click_Install
https://es.opensuse.org/SDB:Instalaci%C3%B3n_de_aplicacioneshttps://paste.opensuse.org/

Salud!!

Salud!!

Muy buenas karlggest, mikrios, he probado las dos cosas que comentáis y no sé si por ignorancia, o por no saber hacer las cosas bien, pero no me han funcionado. Ando mal de tiempo y necesito el portátil con urgencia, así que he formateado, reinstalado opensuse y veremos si ahora ando con mas cuidado.

Gracias a los dos.

PD : De todas maneras, la información que aportáis la considero muy valiosa, de hecho me la he guardado para posibles problemas posteriores.