error Output errori: No valid EFI partition installing 15.3

Hi, on my laptop asus N552V I’m trying to install leap 15.3 on the new disk, everything go well but at the end result this error:

Esecuzione del comando “”/usr/sbin/shim-install", “–config-file=/boot/grub2/grub.cfg”, “–suse-enable-tpm”]]" non riuscita.Codice di uscita: 1
Output errori: No valid EFI partition

that translated is:

Command execution “”/usr/sbin/shim-install", “–config-file=/boot/grub2/grub.cfg”, “–suse-enable-tpm”]]" not succeeded.exit code: 1
Output errori: No valid EFI partition

I tried to boot the just installed 15.3 from systemrescuecd and it works, tried to install the boot loader by yast from the just booted 15.3 but the same error appeared.
how can I have a working leap 15.3 on my laptop?

Start your installed system (using systemrescuecd), open a console, become “root” (using su -) and post (enclosed in separate code tags) the complete output of the following commands

lsblk -f
cat /etc/mtab | grep boot
cat /etc/fstab
ls -la /boot/efi/EFI
zypper se grub

Regards

susejunky

manythanks susejunky,

the sda disk is the old disc where there was the old installation of windows and leap 15.3 that I want to save data and eliminate.
the sdb disk is where I tried to install leap 15.3 and get the error
the sdc disk is systemrescuecd usb pen
the sdd disk is an usb pen that I used to transfere these outputs
here are the outputs:

eros@archlinux:~> su -
Password: 
archlinux:~ # lsblk -f
NAME FSTYPE FSVER LABEL   UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                           
├─sda1
│    vfat   FAT32 SYSTEM  3631-0770                                           
├─sda2
│                                                                             
├─sda5
│    ext4   1.0   Volume  52e3721f-39ab-4502-a380-44802adabe22                
├─sda6
│    ntfs         RECOVERY
│                         B2F43175F4313CC3                                    
└─sda7
     ext4   1.0   DATA    65fcd4ae-a99f-4f7a-8b11-2f9b1b872fe2                
sdb                                                                           
├─sdb1
│    vfat   FAT32 EFI     5D55-0518                                           
├─sdb2
│                                                                             
├─sdb3
│    ext4   1.0   suse1   e1227e94-836a-49cb-8389-2858617fc822   48.8G    10% /
├─sdb4
│    ext4   1.0   home1   8eef8db1-f6ce-4e78-8ec8-1ad46542cc0b   27.2G     0% /home
├─sdb5
│    swap   1     swap    4f8c1ff5-7d8d-42eb-8a7d-766ae385f8bb                [SWAP]
├─sdb6
│    ntfs         dati    30406B9F0A0A4436                      248.8G     0% /dati
└─sdb7
     ntfs         win     415D2BA95B04FEAB                                    
sdc  iso966       RESCUE806
│                         2021-11-20-10-27-46-00                              
├─sdc1
│    iso966       RESCUE806
│                         2021-11-20-10-27-46-00                              
└─sdc2
     vfat   FAT12 RESCUE806
                          69C3-EABA                                           
sdd                                                                           
└─sdd1
     ntfs         STEEL   3EC0A3A2C0A35F41                       35.3G    38% /run/media
sr0                                                                           
archlinux:~ # 

archlinux:~ # cat /etc/mtab | grep boot
archlinux:~ # 

archlinux:~ # cat /etc/fstabUUID=e1227e94-836a-49cb-8389-2858617fc822  /      ext4  defaults             0  1
UUID=8eef8db1-f6ce-4e78-8ec8-1ad46542cc0b  /home  ext4  data=ordered         0  2
UUID=30406B9F0A0A4436                      /dati  ntfs  fmask=133,dmask=022  0  0
UUID=4f8c1ff5-7d8d-42eb-8a7d-766ae385f8bb  swap   swap  defaults             0  0
archlinux:~ # 

archlinux:~ # ls -la /boot/efi/EFIls: cannot access '/boot/efi/EFI': No such file or directory
archlinux:~ # 

archlinux:~ # zypper se grubLoading repository data...
Reading installed packages...


S  | Name                          | Summary                                | Type
---+-------------------------------+----------------------------------------+-----------
i  | grub2                         | Bootloader with support for Linux, M-> | package
   | grub2                         | Bootloader with support for Linux, M-> | srcpackage
   | grub2-arm64-efi               | Bootloader with support for Linux, M-> | package
   | grub2-arm64-efi-debug         | Debug symbols for arm64-efi            | package
i  | grub2-branding-openSUSE       | openSUSE Leap 15.3 branding for GRUB2  | package
   | grub2-branding-upstream       | Upstream branding for GRUB2's graphi-> | package
   | grub2-i386-efi                | Bootloader with support for Linux, M-> | package
   | grub2-i386-efi-debug          | Debug symbols for i386-efi             | package
i  | grub2-i386-pc                 | Bootloader with support for Linux, M-> | package
   | grub2-i386-pc-debug           | Debug symbols for i386-pc              | package
   | grub2-i386-xen                | Bootloader with support for Linux, M-> | package
   | grub2-powerpc-ieee1275        | Bootloader with support for Linux, M-> | package
   | grub2-powerpc-ieee1275-debug  | Debug symbols for powerpc-ieee1275     | package
   | grub2-snapper-plugin          | Grub2's snapper plugin                 | package
i  | grub2-systemd-sleep-plugin    | Grub2's systemd-sleep plugin           | package
i+ | grub2-x86_64-efi              | Bootloader with support for Linux, M-> | package
   | grub2-x86_64-efi-debug        | Debug symbols for x86_64-efi           | package
   | grub2-x86_64-xen              | Bootloader with support for Linux, M-> | package
   | grubby                        | Command line tool for updating bootl-> | package
   | libostree-grub2               | GRUB2 integration for OSTree           | package
   | live-grub-stick               | Create multiboot live usb stick usin-> | package
i  | ruby2.5-rubygem-cfa_grub2     | Models for GRUB2 configuration files   | package
   | ruby2.5-rubygem-cfa_grub2-doc | RDoc documentation for cfa_grub2       | package
   | trustedgrub2                  | Bootloader with TCG (TPM) support      | package
   | trustedgrub2-i386-pc          | Bootloader with TCG (TPM) support      | package
archlinux:~ # 

Looks like you have not mounted any EFI System partition (ESP).

However the necessary GRUB packages are installed.

Assuming that in the future you want to use your current /dev/sdb-device you need to mount /dev/sdb1 under /boot/efi.

Just add an entry to your /etc/fstab-file

UUID=5D55-0518            /boot/efi               vfat  umask=0002,utf8=true    0  0

After that do

mount -a

then install GRUB using the YaST -> Bootloader option and reboot your system.

Regards

susejunky

manythanks susejunky, I used yast partitioner to add and mount /dev/sdb1 under /boot/efi, reinstalled bootloader and everything worked