Error on SSD drive

Hi,

I’m trying to mount my secound disk (its a SSD disk) and get this error:
An error occurred while accessing ‘SSD’, the system responded: The requested operation has failed: Error mounting /dev/sdb1 at /run/media/muramatsu/SSD: Command-line `mount -t “ntfs” -o “uhelper=udisks2,nodev,nosuid,uid=1000,gid=100,dmask=0077,fmask=0177” “/dev/sdb1” “/run/media/muramatsu/SSD”’ exited with non-zero exit status 21: fuse: mount failed: Device or resource busy

This disk its a internal disk (32Gb) SSD and for a long time I’ve disabled the Intel Rapid Storage in Bios, so, I have 1 sata disk 700Gb and 1 SSD disk 32Gb.

linux-qzcn:/home/muramatsu # fdisk -l |grep sdb
Disk /dev/sdb: 32.0 GB, 32017047552 bytes
/dev/sdb1 2048 62529535 31263744 7 HPFS/NTFS/exFAT
linux-qzcn:/home/muramatsu #

Tks for your help and sorry about my bad english.

Ricardo

And what does

mount

say
Please post the output between CODE tags, the # in the editor

Don’t use a folder location like “/run/media/muramatsu” for any mounts you make from your fstab file. Auto mount locations should not be used at all for your personnel mounting. For instance, I use the folder /Windows for Windows, /Software for general software and media and specific locations like /VirtualBox for VM’s and I stay away from all auto mounting locations used by openSUSE.

Thank You,

Sure,

devtmpfs on /dev type devtmpfs (rw,relatime,size=4016200k,nr_inodes=1004050,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sda7 on / type ext4 (rw,relatime,data=ordered)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=27,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
/dev/sda8 on /home type ext4 (rw,relatime,data=ordered)
/dev/sda5 on /boot type ext4 (rw,relatime,stripe=4,data=ordered)
vmware-vmblock on /var/run/vmblock-fuse type fuse.vmware-vmblock (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other)
vmware-vmblock on /run/vmblock-fuse type fuse.vmware-vmblock (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
gvfsd-fuse on /var/run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)

Tks.

That looks OK.

Please take James’ points into consideration.

Another thing: could this be related to Windows not having shut down properly? To solve this, boot in Windows.

Tks James, so, can you send me a link how to change this automount?

I have lost my windows boot (mbr) after install Opensuse. I’m trying to recover it:
https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/490787-windows-8-no-option-boot.html

Tks.
Ricardo

First, we don’t change the automount function in openSUSE. You will simply be swimming upstream in such an attempt. Use similar folder names as I suggest and you can setup mount points in your /home/username are if you wish. As for installing openSUSE, that is a whole different subject. When installed properly, openSUSE will give you an option to run Windows from the Grub 2 menu. If you need to reinstall Grub 2, have a look here:

https://forums.opensuse.org/content/128-re-install-grub2-dvd-rescue.html

Before you install openSUSE, you should always research what you are trying to do first before you have to undo it later:

Creating Partitions During Install for MBR and GPT Hard Disks - Blogs - openSUSE Forums

I actually found a Windows 8 utility for $5 called MBR that can reinstall it if you don’t know how to do it yourself. The name is so generic though, it may be hard to find the program right away without doing a lot of searching around.

Thank You,

Oh, ok, but I don’t undestand how can I change the mount point of my /dev/sdb1.
This “/run/media/muramatsu” is an automatic display when I try to click in Delphin on my SSD disk.

Thanks for your links I’ll get read this.

*Again, sorry about my bad english.

Tks.
Ricardo

Let see your fstab file. Open up a terminal session and type in the command:

cat /etc/fstab

Then copy the results from terminal and post them into a forum message here using code # tags as I did for the cat command above. openSUSE creates on-the-fly mounts for USB drives, but manual intervention is required for everything else. That means, create a usable mount point that is not in /run, that you could place (edit into) your fstab file.

Tell us what you want to do and what you have already done. For user edits of the fstab file, check out my SYSEdit bash script:

SYSEdit - System File Editor - Version 1.50 - Blogs - openSUSE Forums

Thank You,

On 2013-10-01 22:56, jdmcdaniel3 wrote:
>
> RickMura;2588872 Wrote:
>> Oh, ok, but I don’t undestand how can I change the mount point of my
>> /dev/sdb1.
>> This “/run/media/muramatsu” is an automatic display when I try to click
>> in Delphin on my SSD disk.

> Let see your fstab file. Open up a terminal session and type in the
> command:

Er… you are both getting confused with one another, IMHO :slight_smile:

James, I think that RickMura is simply using the automount feature of
the desktop to mount the SSD on “/run/media/muramatsu/SSD”,
automatically. He is not manually mounting anything or editing fstab, it
is just that he doesn’t explain well in English.

The reference to the command line is just the error message that prints
that.

If this is true, we should start the problem digging from the begining :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

i am not sure when an internal SSD drive, not in an external USB enclosure, gets automounted.

Thank You,

On 2013-10-02 14:16, jdmcdaniel3 wrote:

> i am not sure when an internal SSD drive, not in an external USB
> enclosure, gets automounted.

If it is NTFS, there is no reason to mount it at boot automatically.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Use Yast - System - Partitioner. You’ll see the partition on the SSD, edit it and give it a mountpoint, f.e. /windows/C .
Next, check /etc/filesystems, it should have a line “ntfs”.

On 2013-10-02 15:46, Knurpht wrote:
>
> Use Yast - System - Partitioner. You’ll see the partition on the SSD,
> edit it and give it a mountpoint, f.e. /windows/C .
> Next, check /etc/filesystems, it should have a line “ntfs”.

But then, as the filesystem in question errors out at mount attempts,
the machine would not boot and the situation would be worse.

My guess is that the OP needs to do an fsck on the Windows side. Linux
will refuse to mount an NTFS “drive” if it was not properly umounted
(ejected) or powered off, or somehow corrupted.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Thanks for all.
I solved SSD removing one unit (I think its a raid tipe).

Now SSD working fine.

About the Windows boot, I’ve solved, delete the pertition and recreated as Raisefs. Hehe.

Tks.
Ricardo

Well happy to hear of your success though it does not seem we were told of your exact hardware setup at first.

Thank You,