Error On Application Launch

I have just installed opensuse tumbleweed migrating from opensuse leap. So, anytime I launch a graphical application through the terminal, an error shows up saying

No Protocol Specified

. Which is completely fine but I have had to remove a shell plugin as it spammed my terminal with No protocol specified error messages. I had this issue both on leap and now on a fresh install of opensuse tumbleweed. I am reusing my home partition but to test if it was some specific configuration from my user that was causing this, I created a new user to test this on and the error still does exist. Any help on fixing this issue would be immense as I would love to have that shell plugin back.

I am not seeing that at present.

What desktop environment are you using (I use KDE).
What display manager are you using for the login screen (I am using GDM).

I have seen this in the past. I’m thinking it happened when using “lightdm”. And I seem to recall that:


rm .Xauthority

followed by logout and login fixed the problem.

I am using xfce 4.16. And I am using lightdm. I have tried removing the Xauthority file and login logout but that did not fix it. And I don’t think this is a display manager issue as I have tried removing lightdm and using this default display manager shipped with opensuse. The issue still persists. And this is now not only about a shell plugin but I am noticing different bugs like pasting into vim using the register doesn’t paste whats in the clipboard but instead it pastes “No protocol specified”.

Thanks.