Error Occurred while Installing ELILO

Hi :slight_smile:

I am a basic user of opensuse and am having the following issue with a fresh install of opensuse 12.1 (64bit) and hope someone can assist. :\

I was running 11.2 (which installed with ease!) but decided to try and install 12.1.

I am installing on a RAID 1 (Mirror) software configuration with the following setup:

md0 190 mb FAT /boot/efi (Formatted during installation)
md1 20gb /SWAP (Formatted during installation)
md2 30gb EXT4 / (Formatted during installation)
md3 1.7TB EXT4 /home

The installation runs perfectly until the installation of the bootloader where I get the following error.

##Using ‘/boot/efi/efi.SuSE’
##filter ‘etc/elilo.conf’ to ‘/boot/efi/efi/SuSE/elilo.conf.tmp’
> unlink( /boot/efi/efi/SuSE/elilo.conf)
>rename( /boot/efi/efi/SuSE/elilo.conf.tmp, /boot/efi/efi/SuSE/elilo.conf)
##remove old files from ‘/boot/efi/efi/SuSE’
> rm /boot/efi/efi/SuSE/initrd-3.1.0-1.2-desktop
> rm /boot/efi/efi/SuSE/vmlinuz-3.1.0-1.2-desktop
##copy new files to ‘/boot/efi/efi/SuSE’
> cp --preserve=timestamps /usr/lib64/efi/elilo.efi /boot/efi/efi/SuSE
> cp --preserve=timestamps /boot/vmlinuz-3.1.0-1.2-desktop /boot/efi/efi/SuSE
> cp --preserve=timestamps /boot/initrd-3.1.0-1.2-desktop /boot/efi/efi/SuSE
could not open disk /dev/md: Is a directory

I have attempted to search google for this error and have not found anything thus far. I have also ensured the installation dvd is ok and this is actually the 4th DVD I have tried (over several weeks) downloading the software again each time. (Just in case). Also carried out the media check each time to ensure DVD is not corrupt.

Could someone shed some light on this please :slight_smile:

Thanks

On 2012-04-07 09:06, latinlyrics wrote:

> ##Using ‘/boot/efi/efi.SuSE’
> ##filter ‘etc/elilo.conf’ to ‘/boot/efi/efi/SuSE/elilo.conf.tmp’
>> unlink( /boot/efi/efi/SuSE/elilo.conf)

I don’t know about your problem, but please post computer text like that
using code tags. It is in the advanced editor, # button. It makes it much
more readable.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

efi is involved please tell more about your hardware. Also I assume a Software RAID also not a dual boot with Windows

What I don’t understand is why 11.2 worked with an EFI BIOS???

If this is not dual boot turn EFI off i n the BIOS
Also would help to see fdisk - l output exactly.

Thanks for your reply gogalthorp.

Sorry I have taken so long to get back to you. I dont believe my 11.2 was an efi install. I have done some research following your post and it seems my HP Compaq 6200 Pro Multitower has some bios issues when it comes to EFI. Firstly the hard drives do not appear under the EFI devices and secondly I am not able to disable EFI. I have found a few posts on HP formus highlighting this as an ongoing issue, which HP seem to fail to address. I will therefore log a call (along with the 1000s that have been logged already buy others) and hope that they will eventually deal with it.

I am also not using dual boot just a “straight forward” 12.1 install.

In the meantime perhaps there could be a solution to my problem?

The output for fdisk -l is as follows:


WARNING: GPI (GUID Partition Table) detected on '/dev.sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes 
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device         Boot          Start               End             Blocks     Id      System   
/dev/sda1                          1          224909            112454+   ee     GPT
/dev/sda2      *          224911       42170625         20972857+   82     Linux swap / Solaris
/dev/sda3      *       42170626      105081165        31455270     83     Linux
/dev/sda4             105081166     3906124425     1900521630     83     Linux  

WARNING: GPI (GUID Partition Table) detected on '/dev.sdb'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes 
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device         Boot          Start               End             Blocks     Id      System   
/dev/sdb1                          1          224909            112454+   ee     GPT
/dev/sdb2                  224911       42170625         20972857+   82     Linux swap / Solaris
/dev/sdb3      *       42170626      105081165        31455270     83     Linux
/dev/sdb4             105081166     3906124425     1900521630     83     Linux 

Thanks again for your Help.

On 2012-04-09 12:36, latinlyrics wrote:

> Code:
> --------------------
>
> WARNING: GPI (GUID Partition Table) detected on ‘/dev.sda’! The util fdisk doesn’t support GPT. Use GNU Parted.
>
>
> --------------------

Your disk is not that big, I don’t know why you use GPT. I think you could
reformat your entire HD new as plain traditional partitioning.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Thanks Carlos

I also only noticed this now. This must have happened when I created the partitions and raid setup while installing opensuse 11.2.

I will take a backup of my data and reformat all then redo raid and partitioning.

Thanks

On 2012-04-09 15:06, latinlyrics wrote:
>
> Thanks Carlos
>
> I also only noticed this now. This must have happened when I created
> the partitions and raid setup while installing opensuse 11.2.
>
> I will take a backup of my data and reformat all then redo raid and
> partitioning.

But wait for more comments before going that route :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

These are hybrid MBRs. It’s and old bug in openSUSE installer, still not fixed in 12.1. See here: Booting openSUSE on UEFI BIOS with ELILO and Grub2 under “Issues and solutions”. There is nothing wrong (well, not sure) in using hybrid MBRs, but there is no advantage either. Only Apple bootcamp does that. You should either use true MBR partitionning and boot with Grub or true GPT (with protective MBR, not hybrid) and boot with Elilo or Grub2.

Thanks a mil for the info

I have had a look at the links… They are very helpful and have decided to backup my data and start again from scratch using the advice privided in these links.
Thanks Again .