Error: No active Partition

Alright, so I had openSUSE on my computer and it was working fine. I decided to install crunchbang (through unetbootin), and when It was installing it said that /dev/media/cdrom could not be unmounted.

I tried umounting it, didn’t work, so I did “sudo umount -l /dev/media/cdrom”. I tried installing it again, and it said that installation to /dev/sda1 failed. I then turned my computer off, and we I tried booting again it said “No active partition”.

I then tried booting my many linux distros, booting from the openSUSE live CD failed. Kubuntu and Ubuntu also failed. Puppy gave me a limited shell, so I tried remounting dev/media/cdrom, where it said it didn’t support the ect/fstab or whatever.

Dban also failed.

Any help?



Try here
HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

Nope, nothing. It wont even boot from the CD. I just get a little flicking cursur thing for 5 minutes before the cd stops spinning and I get the “Error No Active Partition”

Are you saying you can’t boot from any live linux cd?

Looks like a reformatted empty hard drive. Could it be crunchbang did a nasty thing on your hard disk partitions.

I tried crunch in a VM recently and noticed nothing unusual.
A live cd should boot regardless. Grab Parted Magic and try it. You should be able to boot that and get a clear view of your Partition Table. If it’s OK, you can repair grub from there too.
Downloads - Parted Magic

Use the ROXTerm in Parted Magic: You must now find the partition containing openSUSE bootloader. Then you reinstall Grub with a pointer to that partition.
First find the openSUSE installation:
You enter this ---------------- grub
Computer returns like this ---- grub>
You enter this ---------------- find /boot/grub/menu.lst
Computer returns like this ---- (hd0,4)
Here, (hd0,4) is Grub’s pointer to my openSUSE installation. Your pointer may be different, so from my example (hd0,4). Substitute your correct values if necessary, for my example (hd0,4). Now that you have your pointer, proceed like this:
You enter this ---------------- root (hd0,4)
Computer returns like this ---- Filesystem type is ext2fs, partition type 0x83
You enter this ---------------- setup (hd0)
You see 4-5 lines like this — Checking if /boot/grub/stage1 exists … yes
Computer finally returns this-- Succeeded…Done
You enter this ---------------- quit
You enter this ---------------- reboot

One way that a CD will not boot is if the BIOS is unable to get
through the hard drive startup. If you disconnect the data cable from
your disk, will it boot CD’s?

Just wanted to say that that link helped me. I was in Windows, used a partition manager there to increase size of the partition, and when I rebooted, I got “Error no active partition”. It was this option “Reinstall Grub in the Master Boot Record and link it to the existing Grub menu in openSUSE” that I needed. Great help, thanks.

You’re not booting from a live CD. You’re just booting with a CD inserted but your HDD has boot priority (you should changed this in BIOS setup). You don’t need an active partition to boot from a live CD, not even a hard disk. If everything is still there but you don’t have an active partition (for some reason) , here’s how you can solve this problem:

  • Call BIOS setup with DEL, DEL, DEL, etc and change boot priority so that it will booted from the CD
  • Boot from openSUSE live CD
  • Either install updatedgrub or dowload findgrub and run **findgrub -a **

$ su -l
# zypper ar [noparse][/noparse] PTA
# zypper refresh -r PTA
# zypper in updategrub
# findgrub -a


$ su -l 
# cd /tmp
# wget
# tar -xvzf findgrub-4.0.tgz
# chmod 755 findgrub
# ./findgrub -a

If Grub stage1 is found in one of the 4 primary partitions, this partition will be set active. Otherwise reinstall Grub as explained earlier.

on the first HDD!

Didn’t notice that this thread was started in 2009.