error messages during boot

   33.171882] fuse: init (API version 7.31)
   47.935091] show_signal_msg**: 42 callbacks suppressed**
   47.935094] single[2762]: segfault at 10 ip 00007f686888da0c sp 00007f685ca04fb0 error 4 in libexiv2.so.26.0.0[7f6868678000+2d9000]
   47.935102] Code: 0f 87 af 03 00 00 48 39 dd 0f 87 15 ff ff ff 0f 1f 80 00 00 00 00 48 8d 05 71 53 31 00 4c 8b 74 24 48 4c 8b 6c 24 40 48 8b 00 <48> 8b 68 10 48 8d 58 08 48 89 44 24 18 48 89 5c 24 10 48 85 ed 75
   85.904953] tracker-miner-f[2524]: segfault at ffffffff ip 00007fe0ecaf6a38 sp 00007ffdd2f64030 error 4 in libglib-2.0.so.0.6200.5[7fe0ecaa8000+122000]
   85.904959] Code: 00 00 48 8b 7d 20 48 8b 33 e8 24 ff ff ff 48 8b 5b 08 48 85 db 75 eb 48 8b 45 58 48 8b 58 18 48 85 db 74 24 66 0f 1f 44 00 00 <48> 8b 33 48 8b 7d 20 e8 fc fe ff ff 48 8b 5b 08 48 85 db 75 eb 48
 1187.688153] nouveau 0000:01:00.0**: Direct firmware load for nouveau/nve7_fuc084 failed with error **-2
 1187.688165] nouveau 0000:01:00.0**: Direct firmware load for nouveau/nve7_fuc084d failed with error **-2
 1187.688167] nouveau 0000:01:00.0: msvld: unable to load firmware data
 1187.688168] nouveau 0000:01:00.0: msvld: init failed, -19

I have no idea why libexiv2 is being loaded. lsof tells me it’s fuse that is doing that. In my previous boot, I was getting that message every few seconds. This time, just the one time. This is a fresh “upgrade” from 15.0. The nouveau driver doesn’t look happy either. Those nouveau messages repeated 20 seconds later but has been quiet for the past 90 minutes.

You seem to have something called tracker-miner-fs (which I believe is part of Gnome’s Tracker functionality) running around the time of the segfaults and I’m guessing that this (tracker-miner-fs) file indexer has come across some fuse mount point(s) and its an error with trying to access the fuse mount point that causes the segfaults.

Your options are:

a) try to ensure the fuse mount points are always available

b) Exclude the fuse mount points from being indexed by following the instructions here: https://wiki.gnome.org/SamThursfield/Drafts/Tracker/FAQ#How_can_I_control_what_Tracker_indexes.3F

From the GNOME system menu, click the settings icon. Select ‘Search’ and click the ‘:gear:’ button. In this dialog you can choose what locations are indexed by Tracker.

c) Disable Gnome Tracker: https://wiki.gnome.org/SamThursfield/Drafts/Tracker/FAQ#How_can_I_disable_Tracker.3F