error message when trying to compile mp3splitter

When trying to compile mp3splitter and after typing ./compile I get towards the end of all the usual messages the following error:

“checking for X… configure: error: Can’t find X includes. Please check your installation and add the correct paths!”

I have no idea what and where X is.Any ideas are much appreciated.
I’m running SuSE 10.3 with KDE.

X is the X-windows system. Maybe you need xorg-x11-devel.

Hope this helps.

Thanks, that took me one step further. Now I’m getting the following message:

“configure: WARNING: libjpeg not found. disable JPEG support.
checking for Qt… configure: error: Qt (>= Qt 3.0.3) (headers and libraries) not found. Please check your installation!”

btw, I’ve been with Linux for a couple of months now, but I’m still a noob when it comes to compiling.

When it comes to compiling otherones software it is easy to become a noob. You depend more on his assumptions about yourr system than on your knowledge of compiling :frowning:

When you write your own programs (for compiling, not scripting languages) you will learn what you are doing and why.

While typing this my YaST > Software > Software Management has loaded. I looked for libjpeg. It i there and instaalled on my system. Check for yours.

And apropo Qt: again hedaers etc. not found. That means you need the develop part of it, So install qt3-devel.

BTW I am on 10.3. You did not bother to tell us anythiig about yoyr level, etc. So I hope I am talking no nonsense.

Thanks that worked. And again I’m getting another error message:

“checking for KDE… configure: error:
in the prefix, you’ve chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!”

I’m running Suse 10.3 32bit with KDE.

try ./configure --prefix=/opt/kde3

also make sure you have the kdelibs3-devel package and kdebase3-devel

It is like PingPong isn’t it :slight_smile:

Glad that I am not the only one to give you clues. Thanks microchip8!

Anyway, nobody knows of an alternative program that can (losslessly, I suppose) split MP3s?
If we are talking about, looks like the program isn’t updated since 2004, doesn’t support VBR and you can’t even split by time if you don’t buy the full version.

Thanks guys! That did the trick! :slight_smile:

@RedDwarf: I used to use mp3splitter in, ahem, Windows and it used to do the trick. Granted, the Linux Version doesn’t have time split, but since I’m only ever splitting large audiobook files, that particular function doesn’t really matter to me. Although the prog is old, but it worked fine when I tried it, and I haven’t yet found a better mp3-splitting alternative (with a GUI).