Error message when booting 12.2

When I boot up my 12.2 RC2 machine I get an error message immediately, before anything else has happened, which is then quickly overwritten by the menu of OSs. The machine was cleaned up as part of the 12.2 install, so I assume it has something to do with 12.2.

The error message says “Error” then says something about /boot/grub (or etc/grub2?) but goes too fast for me to read it.

Is there some way of retrieving it or sending it to a file?

Yes, I get that too. But it disappears too quickly to be able to read it.

Since it does not cause any problems, I am ignoring it.

The message seems to be reporting a missing file, but I haven’t been able to read the file name. My guess is that it looks for a file in “/boot/grub”, fails to find it, displays the message, then looks in “/boot/grub2” where it finds the file. But I am only guessing.

This is what the error message is saying.

You can open up a terminal session and run this command:

sudo cp /boot/grub2/locale/ /boot/grub2/locale/

Just using the UK file instead of the missing one. This is likely a bug which should be reported.

This is what it said after I copied the file over and created the one Grub 2 is looking for.

Thank You,

Thanks, James, but I don’t seem to have a locale directory at all in grub2.

So I guess I don’t know how you installed openSUSE 12.2. I have two openSUSE 12.2 RC2 copies running. One in a VM (which I was able to slow down to read the error message) and on a real PC installed as the primary openSUSE. In both cases, this locale folder does exist. Both are the result of a clean install from the DVD and have the latest version of Grub 2, 2.00 which only recently was released. Here is a picture of the folders:

You can see the locale folder in the picture above. Perhaps on the final installation you will see this problem corrected.

Thank You,

So I guess I don’t know how you installed openSUSE 12.2.

I downloaded the .iso, burned a disk and booted the clean machine from that. Is there any other way?

I only have a “themes” directory in grub2. I suppose that comes of downloading a release candidate.

Here’s what I have, after installing from the RC2 64 bit DVD image.

-rw------- 1 root root  123 Aug 23 11:55
-rw-r--r-- 1 root root  122 Aug 23 11:37
drwxr-xr-x 2 root root 1024 Aug 23 11:38 fonts
-rw------- 1 root root 5557 Aug 23 11:55 grub.cfg
-rw-r--r-- 1 root root 1024 Aug 23 11:38 grubenv
drwxr-xr-x 2 root root 8192 Aug 23 11:55 i386-pc
drwxr-xr-x 2 root root 1024 Aug 23 11:38 locale
drwxr-xr-x 3 root root 1024 Aug 23 11:40 themes

I then check another system, installed from the 32bit DVD image for RC2. It has the same files, directories in “/boot/grub2”, though the time stamps are different.

Thanks, that copy seems to have fixed it for me on 12.2 RC2, but I also applied all the recent updates so I can’t confirm if locale was/wasn’t there.

So when the openSUSE 12.2 GM comes out in just a few days, I will load a fresh copy in a VM and see what it does. I just did a zypper up and then zypper dup on my one real install of openSUSE 12.2 RC2, which then got hundreds of updates, but I later saw no change in the grub 2 folders or files. Grub 2 works just fine because I had already done my suggested copy as well. I will just have to wait for the real thing to be released to know for sure I guess.

Thank You,

I just received the latest batch of updates, rebooted and I didn’t get the error message!

And now I do :frowning: I’d swear it went away, but no reason why I shouldn’t have seen it.

The strange thing is that I have a directory called grub2-efi, that contains locale, font and x86_64-efi directories. I copied the file within the locale directory, as suggested above, then copied the contents of grub2-efi into the grub2 directory, without any effect on the message.

Quote****You can open up a terminal session and run this command:

sudo cp /boot/grub2/locale/ /boot/grub2/locale/


That worked for me - thanks for the tip.

I should have posted: since I received the mass of updates at the time of the release of 12.2 I haven’t had this “problem”.

The problem with this fix is that the English commentary are translated to Ukrainian. I need the English commentary to come back.
The “” file IS NOT United Kingdom but the Ukrainian translation.

Follow Up

I removed the file and tried it several days later and the error message still appears. I’m creating a bug report with Bugzilla.

English is default in GRUB2 anyway; message is mostly cosmetic. Do you mean you do not get English?

Thank you.

I didn’t find this thread when I did a search for the error a couple of days ago – had only found James’ blog post mentioning it: GNU Grub2 Command Help/Config Editor - Version: 1.85 - Blogs - openSUSE Forums

Anyway, I installed a new grub2 update today, but it did not resolve the problem (boo hiss boo)

The error message is indeed only cosmetic, though, even if it does come and go in a flash, it is annoying! rotfl!

I’d imagine that Romanator meant that he wants the English commentary file to come back so as to prevent this annoying error from being generated, as opposed to him not having grub in English (which, as you mention, seems to be the default language)

There is upstream bug report with proposed fix, there is openSUSE bug report with proposed fix, openSUSE grub2 maintainer is aware of this problem.

Zypper dup gave me a grub2 update today. It has changed all the **.mo files except, which is the one I copied from I am now getting the countdown message (under the grub2 startup window) in foreign characters (presumably Ukranian).