Error message libstdc++.so.6:

error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

this is an Error message I am receiving through my SSH protocol while attempting to Execute a File on my Linux Server.

The file(s) im trying to execute are:

ts3server_linux_x86
ts3server_minimal_runscript.sh
ts3server_startscript.sh

How can I solve this problem with my OpenSUSE Server?

Extra’s

Server is hosted by Server4You
SSH Protocol: PuTTY
FTP client: WinSCP

ticklemehballlz wrote:

>
>> error while loading shared libraries: libstdc++.so.6: cannot open shared
>> object file: No such file or directory
>
What is the output of


rpm -qa 'libstdc++*'

when you run it on the server?
Which version of openSUSE are you using there?


PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
| 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
ION | 3GB Ram

libstdc++45-4.5.1_20101208-9.8.x86_64
libstdc+±3.3.3-43.31.i586

openSUSE 11.4 - LAMP

ticklemehballlz wrote:

>
>> libstdc++45-4.5.1_20101208-9.8.x86_64
>> libstdc+±3.3.3-43.31.i586
>>
>
> openSUSE 11.4 - LAMP
>
The first of this libraries contains the file libstdc++.so.6, the only thing
which comes to my mind is that the appliaction you try to start needs the
32bit version which is in the package libstdc++45-32bit and which you can
install in addition with


su -c "zypper in libstdc++45-32bit"

but this is just guessing now.


PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
| 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
ION | 3GB Ram

THANK YOU!

That worked perfectly :D! Really I am proper chuffed to finally get this up and running!

Please help me

I get the following error
error while loading shared libraries** libstdc++.so.5**: cannot open shared object file : no such file or directory

when I use rpm -qa ‘libstdc++*’ … I get libstdc++45-4.5.1_20101208-9.8.i586
when I use su -c “zypper in libstdc++45-32bit”
I get
Loading repository data…
Reading installed packages…
Package ‘libstdc++45-32bit’ not found.
Resolving package dependencies…