Error loading operating system - SUSE 12.3 Installation

Dear All, I Installed 12.3 SuSE, the installation went smooth, it restarted, but when restated it gave error- “Error loading operating system”
I tried 3 times, but the problem is same. How to make my machine boot from hard disk? No other OS is installed, I tried to install linux in a fresh unpartitioned disk. Please Suggest. Thanks!!


On 08/12/2013 07:36 AM, dineshdawadi wrote:
> “Error loading operating system”

at the first openSUSE screen there usually is presented to you a
choice of booting normally or failsafe, what happens if you select

> I tried 3 times,

tried what? installed three times or booted three times?

please answer these:

-Was it installed from media downloaded from,
or some other place? Where?

-Did you md5 or sha1 check the .iso prior to burning the install disk
or making the install USB device? (which did you use: disk or USB stick)

-Did you do this before install attempt?
(if not, please, boot from the install media, do it now and report



>at the first openSUSE screen there usually is presented to you a
>choice of booting normally or failsafe, what happens if you select

I mean when it finished the installing and restarted, it simply couldn’t boot from HDD, it dispalyed the erro in a black screen- error loading operating system.

I tried reinstalling 3 times. The .iso was okay, I got the disk checked. It was downloaded from

During my fourth time installation, I choosed “Create Partition Setup” and “Custom Partitioning” and created own partition with the help of following link

and got the work done!!

On 08/12/2013 11:06 AM, dineshdawadi wrote:
> got the work done!!

am happy you solved the problem…looking to the future i’d suggest
that if you do the same thing three times you should expect the
same results!

now, i know that there is another operating system which is so flaky
that you might install it three times and if work one time…or, all
three installs might be broken slightly in different ways…

it is not usual for suck flaky, unstable, unpredictable behavior to
be present in Linux.

now, if you didn’t pay attention the first install and didn’t make
the decisions you should have made…and, then did the same two more
times and finally found some guidance to follow that was correct,
then BINGO the decisions you made during install four worked…and,
it would have also worked during the first install.

“It is far easier to read, understand and follow the instructions
than to undo the problems caused by not.” so wrote dd on 23 Jan 11

Thx for ur suggestion.
True!! :wink:

Im not a linux geek. Although, im trying to shift to a new box from a 8 yrs old linux box because I’m afraid of the potential crash of the old one. Old box is openSuSE 10.1, I’ve just installed 12.3 in a new machine. My problem is that I want to sync or whatever you say, make the new server exactly similar to the old one, files, permissions, databases everything. So that when I disconnect the two n/w cabes connected to the old machine and and connect to the two NIC cards in the new machine, it should work fine without any problem.

Is it possible friend??

Please help.


On 08/12/2013 01:46 PM, dineshdawadi wrote:
> Is it possible friend??

well…the underlying system in 10.1 is VASTLY different from that of
12.3, you might be in for a very rocky road…i don’t know what kind
of “files, permissions, databases” and what all you have…maybe some
scripts to do certain things at certain times…maybe some required
services you start with . . .

well, lots and lots of stuff…

tell me you have not been running that 10.1 with NO security patches
since 31 May 2008, have you??? are you crazy?

if you want a system to be available online for FIVE years you are
using the wrong system! use the Enterprise version instead…and
moving SUSE Linux 10.1 to SUSE Linux Server 11 SP 3 should be pretty
easy…the two systems are very similar…AND SLES 11 is supported
for many years more…but, openSUSE 12.3 wil go end of life in about
one year, and you can then go through all the system change, again!

look into the Enterprise version at, it is a free
download with 60 days startup support and then the continuing updates
are not so much…

good luck with bringing the new server online…but KEEP it updated,
the script kiddies are learning how to knock over unpatched Linux


On 2013-08-12 13:46, dineshdawadi wrote:
> Is it possible friend??

With a lot of work… yep.

Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))