Error in YaST2:cannot create package object

Hi all -

I’m a newbie so this may sound silly. I am using SUSE Enterprise 10.2 on a 64-bit server. I tried adding an installation source in YaST2:
Index of /pub/Linux/openSUSE/distribution/openSUSE-stable/repo/oss/suse

This worked. But then when I go to ‘Software Management’ to install new software, YaST2 gave this error message:
There was an error in installation source initialization. Cannot create package object

The same happened when I tried the opensuse repo:
Index of /distribution/openSUSE-stable/repo/oss/suse

Can anybody tell me how to resolve this? I googled and some forum suggested that this means the opensuse repo is broken. Is this true? Should I just wait a few days for things to resolve itself? Is there any way to get around this?


If your infact using SLES 10 SP2 (please confirm with
cat /etc//SuSE-release) then your going to break your system! SLES 10
SP2 != openSUSE 11.3.

Do you not have an active subscription if running SLES and what
software are you trying to install?

Again if you are using SLES, then you need to post over in as these are for openSUSE.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 3:59, 2 users, load average: 0.05, 0.05, 0.00
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.21

First: You are in the wrong forum
Second: SLE is not openSUSE and it probably not good to use openSUSE repos in SLE

Go here: SUSE Linux Enterprise Server (SLES)

Sorry! Like I said, I’m a newbie to SUSE. Thanks for the info!