error in installing gcc 4.5.0

i tried to install gcc-4.5.0 on opensuse 11.2
I gave
./configure
but it gave the error
couldn’t find the c compiler…
the message was
checking build system type… i686-pc-linux-gnu
checking host system type… i686-pc-linux-gnu
checking target system type… i686-pc-linux-gnu
checking for a BSD-compatible install… /usr/bin/install -c
checking whether ln works… yes
checking for gcc… no
checking for cc… no
checking for cl… no
configure: error: in /gcc-4.5.0': configure: error: no acceptable C compiler found in $PATH See config.log’ for more details.

Can somebody please help me?

sandeshsd wrote:

i tried to install gcc-4.5.0 on opensuse 11.2
I gave
./configure
but it gave the error
couldn’t find the c compiler…
the message was
checking build system type… i686-pc-linux-gnu
checking host system type… i686-pc-linux-gnu
checking target system type… i686-pc-linux-gnu
checking for a BSD-compatible install… /usr/bin/install -c
checking whether ln works… yes
checking for gcc… no
checking for cc… no
checking for cl… no
configure: error: in /gcc-4.5.0': configure: error: no acceptable C compiler found in $PATH See config.log’ for more details.

Can somebody please help me?
So are you trying to install gcc-4.5.0 from a source file? I base that on the command ./configure you are showing. Normally, you install or try to install new applications from the YaST / Software Management program in openSUSE. The “configure” compile method can fail because this is not the way this application is installed, your not in the right folder yet, maybe you did not get the source code files or because you don’t yet have the right tools installed on your computer. Why not go in to Software Management, search for gcc and check if gcc45 is installed, if not then check it, other things may also be installed with it if required.

Thank You,

For opensuse 11.2 you find the gcc 4.5 in the build service

http://tinyurl.com/2v2mh8s

it will add the devele:gcc repository
http://download.opensuse.org/repositories/devel:/gcc/openSUSE_11.2


openSUSE 11.2 64 bit | Intel Core2 Quad Q8300@2.50GHz | Gnome 2.28 | GeForce
9600 GT | 4GB Ram
openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | Gnome 2.30 | Quadro
FX 3600M | 4GB Ram