Error compiling program

hello every1,
i tried to install dropbox on my openSUSE 11.1(KDE 4.0) from a tar.bz2. After i extracted it to a folder Dropbox in Desktop. I got this error trying to compile.
Please help!!

…/Desktop/Dropbox> ./configure
checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for a thread-safe mkdir -p… /bin/mkdir -p
checking for gawk… gawk
checking whether make sets $(MAKE)… no
checking for gcc… no
checking for cc… no
checking for cl.exe… no
configure: error: no acceptable C compiler found in $PATH
See `config.log’ for more details.

You need to install gcc and make from the repo’s

I use gnome in openSuse because of my dropbox subscription…is there an easy way to get it working in KDE? I’d love to go back to KDE…thanks !!

search for it

why shouldn’t it work in kde? I don’t use it myself but I do use kde.

well, it’s integrated with nautilus and with Fedora KDE I read that there is a workaround, but you lose something of the notification functionality in the sys tray I think…I remember it being funky so I just went to gnome. I’ll look into it again, it’s been a while…but I was hoping for something wiz bang here as I’m new to this distro. thanks for the reply.

I use linux in a work environment btw.

Like I say I don’t use dropbox.
I did see a thread recently about it, but all the users were gnome

Probably using gnome out of necessity like me :slight_smile: I’ll keep searching…keeping my files sync’d between laptops is essential for me…

DropBox works fine in KDE, but if you want the GUI warm and fuzzy you
must use Nautilus…which we know is a Gnome app that runs fine in
KDE if you have the Gnome basics installed…i run DropBox and it
shows in my systray/taskbar without being at all “funky”…

i click on the icon and up pops Nautilus showing all the stuff i have
in the box…

as i recall i found (via google, or in these fora) a link to “Dropbox
without Gnome” and followed the directions carefully…try:


thanks…I’ll read that one…might tempt me to go back to KDE

by ‘funky’ I meant not running nautilus, losing some gui functionality although it syncs. Whether or not running nautilus in KDE is funky, I don’t know :wink:

I use Dropbox in KDE and I don’t have it integrated. It just runs in the system tray, just as it does with Windows. I have not tried intergrating it although I do use Nautilus in KDE. I simply have not seen the need for it.

The one click install at worked well. I did not let it keep the repositories after the install. I unchecked that box.

thanks…maybe I’ll move back to KDE…I’ve always been a KDE freak, but moved to gnome out of what I thought was necessity as I work from this machine. ah, maybe I’m just lazy…lol

I’ve switched to KDE4 now…good to be back :slight_smile: I’ve got dropbox running fine without nautilus/gnome stuff…seems to be working great…got the file from this thread:

(1/12) - Latest Stable Build - 0.7.100 « Dropbox Forums](

then did this:

Dropbox in KDE (Linux) - Agnostic God

I’ve got all the systray info I had in gnome…only difference is the file folders in Dolphin aren’t ‘tagged’ but who cares about that…very please with this.

fwiw for posterity…