error compiling dlink driver

I downloaded the Dlink wireless G dwa-110 usb driver but I’m getting “rt73.ko failed to build. make[module]error 1” when compiling it.
I have installed the kernel-source and kernel-syms but I still get the same error. What am I doing wrong?

I’m running openSuSE 11.2 64 bit.

Look for your device here
HCL/Network Adapters (Wireless) - openSUSE

Will it not basically work out of the box?

On 11/29/2009 12:06 AM, caf4926 wrote:
> Look for your device here
> ‘HCL/Network Adapters (Wireless) - openSUSE’
> (
> Will it not basically work out of the box?

If it doesn’t, then use compat-wireless. Messing around with vendor
drivers is usually an exercise in futility.

Thanks caf4926

I realized that openSuSE 11.2 already had the driver and I configured the device but I still have no luck connecting to the internet. On one occasion it managed to connect but was extremely slow.
I downloaded Mandriva powerpack 2010 which also had the rt73 driver but still couldn’t connect to the internet. In both cases the device connects to the wireless network and is assigned an ip address but I can’t connect to the internet and I can’t ping. Only irc chat shows some sign of working.

It’s often easier to get hardware selectively - making sure it works flawlessly in Linux. Not always easy I know, but if you are serious about Linux, it’s a logical step.