Error code: 5 Installing Tumbleweed

Hey I tried to install tumbleweed twice but I have this error. Error code: 5 and when I start my computer and select boot from hard disk now it prints Booting from local disk… and hangs there nothing happens. is there a way I can fix this without reinstalling? like with the boot menu? or with a live cd? preferably with the boot menu. Or should I just reinstall without the UEFI option or whatever on my system? I could try that if you want. Thanks for your time and patience.

It is hard to be helpful when you have provided so little information.

Where did you see this “Error code: 5”? Was that during the install, or was that when trying to boot after the install?

This happened right after the installation was almost complete I think it said the command sh_shim or something doesn’t exist I don’t remember completely what the command was. It had something to do with installing grub I think.

I don’t think the boot loader installed. But the live cd runs repair and mounts stuff so I can do that but I don’t know how to fix this issue. If you want I can try installing it with cd rw without the online repos and see if it works. If I get the same error this time i can write it down. Anything you want me to do at this point just let me know.

If you used the DVD installer or the NET installer, you should be able to boot that to the rescue system.

If you are able to do that, then the output from:

fdisk -l

might be useful.

I can’t copy and paste it but there are sda up to sda7. Is this at all helpful?

Disk model: ST250DM000-1BD14
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optical): 4096 bytes / 4096 bytes
Disk label type: dos
Disk identifier: 0x897659a8

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1 Linux
/dev/sda2 Linux swap/Solaris
/dev/sda3 Hidden NTFS WinRE
/dev/sda4 W95 Ext'd (LBA)
/dev/sda5 EFI (FAT-12/16/32)
/dev/sda6 Linux
/dev/sda7 Linux swap / Solaris

Partition table entries are not in disk order.

and there's more its just alot to write. heh. I can't copy paste.
like /dev/zram0 and /dev/loop0 and a few others

This is highly questionable.

UEFI specification talks about primary partitions only. Media device paths in UEFI are explicitly defined as

Valid partition numbers for a MBR partition are [1, 4].

Having ESP on a logical partition may work, but is not required to work. And efibootmgr that is used to actually create UEFI boot entry also fails for extended partition.

The question is how this configuration was created. If this is something installer did on its own - this is a bug and must be reported.

As for the OP problem - I do not know what all these partitions are for, but if intention was to install in partitions 6 and 7, then the only solution is to install in legacy BIOS boot mode (and educated guess is that BIOS tries and fails to boot in UEFI mode, falls back to legacy BIOS mode and stops because there is no meaningful code in MBR).

Or wipe out disk partition table so that installation in UEFI mode can create new GPT layout.

Yes it is something the installer did on it’s own I am going to make my own partitions this time and delete everything and then see if i get the error. If i do i will write it down exactly this time.

Ok update, I didn’t get the error this time and here’s exactly what I did, I installed without adding online repositories, I actually made a 2gb FAT partition and mounted it /boot then i made a 17 GB swap partition and then I made the rest of my hard drive a partition that mounts /. I got a different error this time about a file that couldn’t be found and I skipped that error and it installed anyways. I’m using a dvd iso install cd from the openSUSE website. Seems everything installed great I just got one message on my desktop about that same file that didn’t install I will post it from the other computer. Thanks for your patience.

Software Updates gave me this error when I auto logged in.
Update Error
File ‘./repodata/c8b749256c8405221d167fbc190cfdf721f4521281fa061b00cc677206a35ef5-primary.xml.gz’ not found on medium ‘

Also I really like the plasma gui so far.

When you want a separate partition for /boot, that is OK, but the file system on it should NOT be VAT, but a Linux file system (e.g. ext4).

Maybe you are confused with a EFI partition?

IMHO you should explain much, much more to help the not mind reading people here to grasp your situation, like:
Is there anything on that disk that you want to keep (like another operating system, MS Windows or Linux)?
Can your system use UEFI and when yes, do you want to use it?

When you want to use EFI, then boot the installation medium also in EFI mode.
When you want to use the whole disk for your openSUSE, then either say so during installation (there is somewhere during partitioning questions an item to use the :whole disk", either direct, or after you choose “expert” somewhere).
Another thing you can do to force whole disk usage is overwrite the partition table with zeros.

Yea it was allowing me to duel boot that’s why all the other partitions wer there. Also the default option for my boot partition was FAT so that is why I chose FAT for that partition. It booted fine and everything is working tho accept for System Updates.

Update Error
repository unknown

I think it may have to do with the fact that either that file didn’t install or because I chose not to use online repositories. Originally I wanted to duel boot but since it didn’t work the first time I wiped everything might be nice for duel boot to install grub on mbr somehow instead of in the extended partition.

Lastly, I am not getting email notifications and i think it has something to do with me changing email address on my account. I am subscribed to this forum but I do not receive emails.

Again, saying you did something does not help people to understand what exactly you did. You have to say what steps you took when you want other people to comment on that.

On the main page of these forums, somewhere near the top at right, there is under Security Info

Need to change your password or email address? Instructions are in our FAQ

Did you follow that?

In fact I think the best is to use the Conatct us item at the bottom left of almost every page of the forums.

But we have still no answers to several questions. And in fact we have more questions now.

Do you want dual boot with something that is already on the dis, and when yes, what is that?

And is the system doing legal BIOS or UEFI?

Do you really want a separate /boot? Maybe explain why you want that.

As long as we (including you) do not know what is on the disk and what you want to do with that, it is difficult to plan what we are going to advice.

You fdisk list suggest a MSDOS (thus not GPT) partitioned disk with two Linux systems and an EFI partition (in the extended partition). Which is a strange combination.

I guess you made some progress while I was asleep.

That particular error message possibly suggests a network problem. That was a failure to access the online repo. It might be a temporary problem.

Can you now provide the output from:

efibootmgr -v
ls /boot/grub2

You need root for the first of those commands, and the output might be an error message. This will tell us a little more about how booting is now setup.

Maybe also the output of

fdisk -l

and this time you should be able to use copy/paste (though the pencil and paper method can also work).

Here is output, of those commands.

localhost:/home/Errigour/Downloads # efibootmgr -v
EFI variables are not supported on this system.
localhost:/home/Errigour/Downloads # ls /boot/grub2  fonts  grub.cfg  grubenv  i386-pc  locale  themes
localhost:/home/Errigour/Downloads # fdisk -l
Disk /dev/sda: 232.89 GiB, 250059350016 bytes, 488397168 sectors
Disk model: ST250DM000-1BD14
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x897659a8

Device     Boot    Start       End   Sectors   Size Id Type
/dev/sda1  *        2048   4196351   4194304     2G ef EFI (FAT-12/16/32)
/dev/sda2        4196352  39847935  35651584    17G 82 Linux swap / Solaris
/dev/sda3       39847936 488397167 448549232 213.9G 83 Linux
localhost:/home/Errigour/Downloads #

Actually originally yes i did want dual boot but then i changed my mind.

IDK what the system is doing.

I do want a seperate boot and the reason is cause that is how i have installed it in the past.

The reason there was two linux partitions is probably cause i tried to install it twice and I think both times it dual boot so I had windows linux and that linux install.

Sorry for the confusion.

Based on that output, you are using BIOS/MBR booting. You are not using UEFI booting.

This can indicate merely that the current boot is a legacy boot, rather than a UEFI boot would be impossible.

Device     Boot    Start       End   Sectors   Size Id Type
/dev/sda1  *        2048   4196351   4194304     2G ef EFI (FAT-12/16/32)
/dev/sda2        4196352  39847935  35651584    17G 82 Linux swap / Solaris
/dev/sda3       39847936 488397167 448549232 213.9G 83 Linux

This strongly suggest an installation done in UEFI mode. I suggest to enter BIOS and disable legacy/MBR booting. This might result in boot success in UEFI mode, or failure to find a boot device.

If failure ensues, re-enable legacy boot in BIOS, then boot in rescue mode however you can, and capture /etc/fstab from the installed system to paste here, along with output from lsblk -f.

How do I copy paste in rescue mode to this forum?