error code 127 when i run smplayer


I am installed smplayer, but when i run, it is given this error.
pl. guide me in this regards


error summary:

/usr/bin/mplayer -noquiet -nofs -sub-fuzziness 1 -identify -slave -vo xv, -zoom -nokeepaspect -framedrop -input conf=/usr//share/smplayer/input.conf -stop-xscreensaver -wid 52428812 -monitorpixelaspect 1 -subfont-autoscale 1 -subfont-text-scale 5 -subcp ISO-8859-1 -subpos 100 -contrast 0 -brightness 0 -hue 0 -saturation 0 -dvd-device /windows/C/King of California -dvdangle 1 -nocache -osdlevel 0 -vf-add screenshot -channels 2 dvd://1

/usr/bin/mplayer: error while loading shared libraries: cannot open shared object file: No such file or directory

Dependency checking should have sorted this, but it does not hurt to check, do you have “arts” installed? (it provides Type:
rpm -q arts

And to prove what I stated, type:
rpm -qR arts
and it should list

Another possibility is you did something to mess up your path. A reboot will solve that.

Thanks for your replay,

I could not able to found arts in my system. and i’ve remove smplayer and mplayer from system. Please guide me how to install it properly. (I’ve installed opensuse 11 GNOME)

After doing 1 hour R & D, i could able to play DVD movies in Kaffeine it is working fine, but when i tried to play VCD it start and stop immediately.

thanks & regards


thanks to oldcpu,

I’ve installed smplayer,mplayer,realplayer. by reading this thread.

openSuse 11.0 realplayer no audio output - openSUSE Forums

smplayer: PackMan :: Informationen zum Paket smplayer
mplayer: PackMan :: Informationen zum Paket MPlayer
mplayerplug-in: PackMan :: Informationen zum Paket mplayerplug-in
w32codec: PackMan :: Informationen zum Paket Win32-Codecs

thanks & regards

suresh menon
Mumbai - India.