Error (cant provide file )

Hello All
I have a problem when down loading a error comes up ( cant provide file / suse/x86-64 terminfo - base -5.6-83 .1 x86-64rpm from repository open suse-dvd 11.0 any help would be apprecitied thanks ( newbie)

At a first advice it seems your install media is corrupted. Deg you performed a media check at the beginning of the installation? Have you wrote the downloaded iso image at the lowest write speed possible?

Hi bcirciotti

the install was from a new disc of suse in to a clean hard drive it loaded with out problems .this all started when trying to play a dvd error came up dvd source plugin needs install after this the (cant provide file) error came when down loading codec.the rest of suse works well.

What makes me think about a dvd writing error is the message “can’t provide *** from resository Opensuse dvd”. Anyway if your problem are missing multimedia codecs they are available via yast single click install. Tomorrow i’ll post the url from which you can install all the necessary

Hi. as promised this is the link from which you can install multimedia codecs: Multimedia - openSUSE-Community
I hope this helps because from your informations i cannot figure very well what’s going on

thanks for the replay have downloaded restricted multimeder formats (gnome ) but stall have the same problem
when trying to play a DVD in totem the error comes up (The playback of this movie requires a DVD source plugin which is not installed.
if you have any other ideas please let me know thanks for your help

Playing a dvd video is a matter of installing libdvdcss and libdvdnav. Those are available in the packman resository so add this source to yast. I do prefere xine to play dvd so try to install it and upgrade libxine trought yast. Try those steps and report again your experiences. It’s not a pain nowadays to play dvd video in linux


have installed libdvdcss and libdvdnav to yast but having a problem with xine on install can you run me through it, how you did it or any help thanks

No problem. Xine has to be installed via yast. Did you add the packman resository? Search Xine and mark it for install/upgrade and mark also Xine-gui libxine and the other decoding plugins. Simply in yast perform the search for Xine and you will get all this stuff

sorry about the late feedback (work) still having problems with totem after taking your advice.I have a error coming up now which i have reported.
reading other threads about Mplayer i decided to try it out, almost worked, if you can help with this error (or anybody else ) it would make my day !
error comes up (initializing the selected video-out (-vo) device)?
what does this mean and how do i fix it thanks

Hi. Is this error generated by mplayer? Try to change it’s video driver. Open mplayer and right click on it. Choose settings and in the video tab choose another driver. Usually the x11 performs fine. Close mplayer and start it again. But i would advice that in viewing dvds Xine is better, with full support to menus. Now i cannot access my linux box, but tomorrow i will make a list of everything i installed to make Xine works. Anyway post the message Xine gives to you if different in respect of the one you posted here

So here we are. I checked mine configuration. I installed :
Now i would suggest to che the video driver settings in the xine control panel. Mine is checked to “auto”, bu users report that xshm would be a better choice. Try different ones, since i could not understand what is exactly the error xine reports to you. I also found this : It provides the file unity_gnome_kde_opensuse_10.3.tar.gz that claims to provide everything needed to enable full multimedia support on suse10.3.
Let me know is something happens

this problem happens in totem and mplayer with different error codes the end result is the same no dvd playing at all.
the only code missing was libxinew32dll- i down loaded the one which seemed close to it ,but would not be excepted. Running suse 11 i dont no if this makes a difference.
at the moment have had a my fill of mplayer and will be looking at it later when i have more time thanks very much for your help have a nice day in rome godwit

I have the same architecture as the OP (x86_64) and I’ve successfully installed the “Restricted Multimedia Formats (MP3, MPEG-4, etc.)” per this page
However I still get this message when trying to play a dvd:

An error occured

The playback of this movie requires a DVD source plugin which is not installed.

xine is installed

linux-9e9z:/home/rl # zypper install xine
Reading installed packages…
‘libxine1’ providing ‘xine’ is already installed.
Nothing to do.

Is there any hope of getting movies to play?