Error applications using libpango (gimp, chromium, firefox, etc...)

After last week update I have issues running applications with using libpango.

Every application related to libpango returns Error:

# chromium
/usr/lib64/chromium/chromium: symbol lookup error: /usr/lib64/ undefined symbol: g_log_structured_standard
# gimp
gimp: symbol lookup error: /usr/lib64/ undefined symbol: g_log_structured_standard
# firefox
XPCOMGlueLoad error for file /usr/lib64/firefox/
/usr/lib64/ undefined symbol: g_log_structured_standard
Couldn't load XPCOM.


Information for package libpango-1_0-0:
Repository     : OpenSUSE-Tumbleweed-Oss                  
Name           : libpango-1_0-0                           
Version        : 1.42.0-1.1                               
Arch           : x86_64                                   
Vendor         : openSUSE                                 
Installed Size : 605.4 KiB                                
Installed      : Yes                                      
Status         : up-to-date                               
Source package : pango-1.42.0-1.1.src                     
Summary        : Library for Layout and Rendering of Text

My system is:

# cat /etc/os-release
NAME="openSUSE Tumbleweed"
# VERSION="20180316"
PRETTY_NAME="openSUSE Tumbleweed"


# kde4-config -v
Qt: 4.8.7
KDE: 4.14.38
kde4-config: 1.0

Also now I can’t login to GNOME shell - after a sec back to login screen…

Information for package gnome-shell:
Repository     : OpenSUSE-Tumbleweed-Oss    
Name           : gnome-shell                
Version        : 3.28.0-1.1                 
Arch           : x86_64                     
Vendor         : openSUSE                   
Installed Size : 8.1 MiB                    
Installed      : Yes                        
Status         : up-to-date                 
Source package : gnome-shell-3.28.0-1.1.src
Summary        : GNOME Shell

same to me!
any help???

Run “sudo zypper dup” (not “zypper up” or anything else), to make sure your system is really fully up-to-date.
In case of conflicts please post the exact message.

If that doesn’t help, please post your repo list:

zypper lr -d

I’m having the same problem since 2018-03-17 when libpango was updated.

$ sudo zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
10 Problems:
Problem: problem with installed package libQtWebKit4-4.8.7+2.3.4-4.1.x86_64
Problem: problem with installed package libQtWebKit-devel-4.8.7+2.3.4-4.1.x86_64
Problem: problem with installed package qt3-3.3.8c-141.1.x86_64
Problem: problem with installed package libmjpegutils-2_0-0-2.0.0-26.1.x86_64
Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
Problem: problem with installed package mjpegtools-2.0.0-26.1.x86_64
Problem: nothing provides typelib-1_0-WebKit-3_0 needed by gufw-16.04.0-1.8.noarch
Problem: libopenssl-1_0_0-devel-1.0.2n-2.1.x86_64 conflicts with libopenssl-devel > 1.0.2n provided by libopenssl-devel-1.1.0g-2.1.noarch
Problem: SuSEfirewall2-3.6.378-2.1.noarch conflicts with firewalld provided by firewalld-0.5.1-1.1.noarch

Problem: problem with installed package libQtWebKit4-4.8.7+2.3.4-4.1.x86_64
 Solution 1: install libQtWebKit4-4.8.7+2.3.4-2.48.x86_64 (with vendor change)
  openSUSE  -->
 Solution 2: keep obsolete libQtWebKit4-4.8.7+2.3.4-4.1.x86_64

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c):

$ zypper lr -d
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias                               | Name                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                    | Service
1 | | home:bosim:suse-prime      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | |        
2 | kernel-repo                         | kernel-repo                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                       |        
3 | nvidia-tumbleweed                   | nvidia-tumbleweed          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                        |        
4 | packman                             | packman                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                    |        
5 | repo-debug                          | openSUSE-Tumbleweed-Debug  | No      | ----      | ----    |   99     | NONE   |                                |        
6 | repo-oss                            | openSUSE-Tumbleweed-Oss    | Yes     | (r ) Yes  | Yes     |   99     | yast2  |                                      |        
7 | repo-source                         | openSUSE-Tumbleweed-Source | No      | ----      | ----    |   99     | NONE   |                               |        
8 | repo-update                         | openSUSE-Tumbleweed-Update | No      | ----      | ----    |   99     | rpm-md |                                        |

Solution 1?

Exactly this.

And you should allow the vendor change for the other problematic packages as well to unblock the upgrade.

Qt3 and libQtWebKit4 have been dropped from openSUSE because they are unmaintained since years (and even considered a security risk), Packman does still provides them for packages (on Packman) that need them.
OTOH, libmpeg2 and mjpegutils (with MPEG2 support) are not available on Packman anymore because they are part of the distribution now as the patents expired.

You should remove libopenssl-1_0_0-devel, as it conflicts with libopenssl-1_1 that you seem to have installed as well.
And SuSEfirewall2 has been replaced with firewalld recently. You currently have to choose one or the other and cannot have both (because there were indications that having both could cause problems), but that should be “fixed” soon by removing that conflict again (although you shouldn’t have both running).
No idea about gufw, but that apparently needs some package that is not available (typelib-1_0-WebKit-3_0), so better uninstall it as well.

And after some digging in other sites
libglib-2_0-0 was not updated
We need version 2.56.0-1.1
On my system was 2.54.2-4.2 because of related package gio-branding-openSUSE-42.1-9.1
Force update to version 2.56 libglib-2 was successful. Application back. :slight_smile:

Information for package libglib-2_0-0:
Repository     : OpenSUSE-Tumbleweed-Oss                  
Name           : libglib-2_0-0                           
Version        : 2.56.0-1.1                              
Arch           : x86_64                                   
Vendor         : openSUSE                                 
Installed Size : 1,5 MiB 
Installed      : Yes                                      
Status         : out-of-date (version 2.54.2-4.2 installed)
Source package : glib2-2.56.0-1.1.src                     
Summary        : General-Purpose Utility Library

Thanks for help.

On Tumbleweed only

zypper dup

does Udate the System, all other things like

zypper up

or the Plasmoid does not work properly.

But this is only for Tumbleweed, not for Leap.

Right, Tumbleweed currently has gio-branding-openSUSE-42.1-3.1 which is lower version, but only “zypper dup” downgrades packages so the outdated one was being kept (which also prevented glib2 from being updated because of package dependencies).

The -9.1 package seems to come from Leap 42.3 though. So it seems you either never properly upgraded to Tumbleweed in the first place (with “zypper dup”), or you still have the 42.3 repo(s) in your repo list (which you shouldn’t).
Please check the latter, or you may run into problems again eventually.

If in doubt, please post your repo list (“zypper lr -d”) so others can check.

Thanks @Sauerland and @wolfi323! Solving conflicts in zypper dup did the trick. :slight_smile:

I must say, I didn’t expect the problem to go away after that, since there were no conflicts with libpango.