Error al actualizar/instalar Tumbleweed en el pc

Hola. Tengo un viejo pc (AMD-A10) que uso ocasionalmente y en la ultima actualizacion me salio esta pantalla al reiniciar.


Si entraba a un snapshot anterior a Gnome 46 me funcionaba bien. Como el pc llevaba sin actualizar 2 meses y estaba por medio el backdoor de xz intente hacer una instalacion limpia y el resultado tanto con Gnome como con Plasma es esa pantalla.
Me queda por probar xfce o algun otro entorno disponible.
Las dudas son, ¿para instalar otro entorno de escritorio diferente a los tres predeterminados, en el instalador de Yast habria que especificar primero sistema base y luego en software elegir el escritorio?
Aunque sea por curiosidad voy a intentar en cuanto pueda saber los motivos, pq le he instalado Fedora 40 y funciona bien con Gnome 46.
Estos son los avisos que me dabe el journal ctl

Saludos

Hola:
A ver si arreglamos ese Tumbleweed.
Lo primero mira si en el BIOS tienes la opción :
AMD CBS > NBIO Common Options > SMU Common Options

CPPC (Auto / Enabled / Disabled): Enabled
CPPC Preferred Cores: Enabled

Si no la tienes , tendremos que hacerle trampa al solitario.

Cuando instales Tumbleweed y llegues a la última pantalla , antes de darle a instalar , haces click en la zona de grub y en parámetros del kernel pones :
acpi=on

El problema es que el kernel de openSUSE no trae activado por defecto el amd_pstate , se lo deja al firmware del BIOS y en este caso o está desactivado ( me imagino que no , no tendrás esa opción) entonces hay que decirle al kernel que lo active.

Puede ser con acpi=on o también con amd_pstate=guided

Será cuestión de probar.

Saludos.

2 Likes

Buenas. He probado el ultimo snapshot con Gnome 46.1 y ya me va bien, hace la instalacion sin problema. Lo unico que he cambiado en la BIOS ha sido que he activado secureboot, el resto de las opciones que me comentas (y he visto) estaban activadas.
Gracias por tu ayuda. Mi pc vuelve a estar comodo con Tumbleweed :wink:
Saludos