error after update to mesa 10

After updating Mesa and X from “http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_13.1/”, when I try to run an openGL application I get an error saying: “libGL error: dlopen /usr/lib64/dri/updates/i965_dri.so failed (/usr/lib64/dri/updates/i965_dri.so: cannot open shared object file: No such file or directory)”, though the application still runs.
However when trying to use bumblebee it fails:

> $OPTIMUS_PREFIX glxspheres64
  243.857493] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA: Use the -ignoreABI option to override this check.

  243.857567] [ERROR]Aborting because fallback start is disabled.
# bumblebeed 
 2007.236656] [INFO]bumblebeed 3.2.1 started
 2011.194550] [ERROR][XORG] (EE) NVIDIA: Use the -ignoreABI option to override this check.
 2011.194572] [ERROR][XORG] (EE) Failed to load module "nvidia" (module requirement mismatch, 0)
 2011.194578] [ERROR][XORG] (EE) No drivers available.
 2011.194581] [ERROR][XORG] (EE) 
 2011.194585] [ERROR][XORG] (EE) no screens found(EE) 
 2011.194588] [ERROR][XORG] (EE) 
 2011.194592] [ERROR][XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
 2011.194595] [ERROR][XORG] (EE) 
 2011.194600] [ERROR][XORG] (EE) Server terminated with error (1). Closing log file.
 2011.194604] [ERROR]X did not start properly

/var/log/Xorg.8.log:

  2011.176] 
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.
  2011.176] 
X.Org X Server 1.15.99.901 (1.16.0 RC 1)
Release Date: 2014-02-24
  2011.176] X Protocol Version 11, Revision 0
  2011.176] Build Operating System: openSUSE SUSE LINUX
  2011.176] Current Operating System: Linux svabba.kvasta 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64                                                                                                           
  2011.176] Kernel command line: root=/dev/disk/by-id/ata-ST9500325AS_6VEMM7ZS-part4 resume=/dev/disk/by-id/ata-ST9500325AS_6VEMM7ZS-part3 splash=silent quiet vga=0x314
  2011.176] Build Date: 24 March 2014  06:42:46PM
  2011.176]  
  2011.176] Current version of pixman: 0.32.4
  2011.176]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
  2011.176] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
  2011.176] (==) Log file: "/var/log/Xorg.8.log", Time: Sun Mar 30 22:38:07 2014
  2011.176] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
  2011.176] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
  2011.176] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
  2011.177] (==) ServerLayout "Layout0"
  2011.177] (==) No screen section available. Using defaults.
  2011.177] (**) |-->Screen "Default Screen Section" (0)
  2011.177] (**) |   |-->Monitor "<default monitor>"
  2011.177] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
  2011.177] (**) |   |-->Device "DiscreteNvidia"
  2011.177] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
  2011.177] (**) Option "AutoAddDevices" "false"
  2011.177] (**) Option "AutoAddGPU" "false"
  2011.177] (**) Not automatically adding devices
  2011.177] (==) Automatically enabling devices
  2011.177] (**) Not automatically adding GPU devices
  2011.177] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
  2011.177]    Entry deleted from font path.
  2011.177] (==) FontPath set to:
        /usr/share/fonts/misc:unscaled,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi:unscaled,
        /usr/share/fonts/75dpi:unscaled,
        /usr/share/fonts/ghostscript/,
        /usr/share/fonts/cyrillic:unscaled,
        /usr/share/fonts/truetype/,
        built-ins
  2011.177] (++) ModulePath set to "/usr/lib64/nvidia/xorg/,/usr/lib64/xorg/modules"
  2011.177] (==) |-->Input Device "<default pointer>"
  2011.177] (==) |-->Input Device "<default keyboard>"
  2011.177] (==) The core pointer device wasn't specified explicitly in the layout.
        Using the default mouse configuration.
  2011.177] (==) The core keyboard device wasn't specified explicitly in the layout.
        Using the default keyboard configuration.
  2011.177] (II) Loader magic: 0x80ec60
  2011.177] (II) Module ABI versions:
  2011.177]    X.Org ANSI C Emulation: 0.4
  2011.177]    X.Org Video Driver: 16.0
  2011.177]    X.Org XInput driver : 21.0
  2011.177]    X.Org Server Extension : 8.0
  2011.177] (II) xfree86: Adding drm device (/dev/dri/card0)
  2011.178] (II) xfree86: Adding drm device (/dev/dri/card1)
  2011.178] setversion 1.4 failed: Permission denied
  2011.179] (--) PCI:*(0:1:0:0) 10de:0df4:1043:15e2 rev 161, Mem @ 0xdb000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
  2011.179] Initializing built-in extension Generic Event Extension
  2011.179] Initializing built-in extension SHAPE
  2011.179] Initializing built-in extension MIT-SHM
  2011.179] Initializing built-in extension XInputExtension
  2011.179] Initializing built-in extension XTEST
  2011.179] Initializing built-in extension BIG-REQUESTS
  2011.179] Initializing built-in extension SYNC
  2011.179] Initializing built-in extension XKEYBOARD
  2011.179] Initializing built-in extension XC-MISC
  2011.179] Initializing built-in extension SECURITY
  2011.179] Initializing built-in extension XINERAMA
  2011.179] Initializing built-in extension XFIXES
  2011.179] Initializing built-in extension RENDER
  2011.179] Initializing built-in extension RANDR
  2011.179] Initializing built-in extension COMPOSITE
  2011.179] Initializing built-in extension DAMAGE
  2011.179] Initializing built-in extension MIT-SCREEN-SAVER
  2011.179] Initializing built-in extension DOUBLE-BUFFER
  2011.179] Initializing built-in extension RECORD
  2011.179] Initializing built-in extension DPMS
  2011.179] Initializing built-in extension Present
  2011.179] Initializing built-in extension DRI3
  2011.179] Initializing built-in extension X-Resource
  2011.179] Initializing built-in extension XVideo
  2011.179] Initializing built-in extension XVideo-MotionCompensation
  2011.179] Initializing built-in extension XFree86-VidModeExtension
  2011.179] Initializing built-in extension XFree86-DGA
  2011.179] Initializing built-in extension XFree86-DRI
  2011.179] Initializing built-in extension DRI2
  2011.179] (II) LoadModule: "glx"
  2011.179] (II) Loading /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
  2011.190] (II) Module glx: vendor="NVIDIA Corporation"
  2011.190]    compiled for 4.0.2, module version = 1.0.0
  2011.190]    Module class: X.Org Server Extension
  2011.190] (II) NVIDIA GLX Module  331.49  Wed Feb 12 20:17:10 PST 2014
  2011.190] Loading extension GLX
  2011.190] (II) LoadModule: "nvidia"
  2011.190] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
  2011.191] (II) Module nvidia: vendor="NVIDIA Corporation"
  2011.191]    compiled for 4.0.2, module version = 1.0.0
  2011.191]    Module class: X.Org Video Driver
  2011.191] ================ WARNING WARNING WARNING WARNING ================
  2011.191] This server has a video driver ABI version of 16.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
  2011.191] =================================================================
  2011.191] (EE) NVIDIA: Use the -ignoreABI option to override this check.
  2011.191] (II) UnloadModule: "nvidia"
  2011.191] (II) Unloading nvidia
  2011.191] (EE) Failed to load module "nvidia" (module requirement mismatch, 0)
  2011.191] (II) LoadModule: "mouse"
  2011.191] (II) Loading /usr/lib64/xorg/modules/input/mouse_drv.so
  2011.191] (II) Module mouse: vendor="X.Org Foundation"
  2011.191]    compiled for 1.15.99.901, module version = 1.9.0
  2011.191]    Module class: X.Org XInput Driver
  2011.191]    ABI class: X.Org XInput driver, version 21.0
  2011.191] (II) LoadModule: "kbd"
  2011.191] (II) Loading /usr/lib64/xorg/modules/input/kbd_drv.so
  2011.191] (II) Module kbd: vendor="X.Org Foundation"
  2011.191]    compiled for 1.15.99.901, module version = 1.8.0
  2011.191]    Module class: X.Org XInput Driver
  2011.191]    ABI class: X.Org XInput driver, version 21.0
  2011.191] (EE) No drivers available.
  2011.191] (EE) 
Fatal server error:
  2011.191] (EE) no screens found(EE) 
  2011.191] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
  2011.191] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
  2011.191] (EE)

There seems to be an ABI version mismatch, is it possible to use just Mesa from the Xorg repo and X from the default repo?

These lines are very clear:

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.

and now your suggesting to mix X packages from different repos. IMHO not the way to go if a stable system is what you actually want.

It thought so, so is there a repo with Mesa 10 and stable Xorg?

How about the repo for openSUSE 12.2?

12.2 is past end of life

http://en.opensuse.org/Lifetime

Bumblebee seems to work if you use the IgnoreABI option.

If you check the stock release you will find those very same lines …

and now your suggesting to mix X packages from different repos.
To be pedantic, that is NOT what they were suggesting; Again:

is it possible to use just Mesa from the Xorg repo and X from the default repo?
And the actual answer to that question is yes … but you will have to manually cherry pick what you need/want. … however, if I you don’t know what you’re doing, then this all leads into Knurpht’s later point:
IMHO not the way to go if a stable system is what you actually want.

check on OBS (I haven’t looked, but maybe someone has separate repos for Mesa)

I did check the software search but I’d rather not add home repos that I don’t know if i can trust. However this is not a problem anymore since the Nvidia driver worked with “IgnoreABI”. I’m still wondering about the “/usr/lib64/dri/updates/i965_dri.so” thing though.