Error 22: No such partition (YaST2 - GRUB)

Salute Experts and new bees,

I experienced an error which i can not rationalize in my mind:

during the installation on a Vista installed 150 GB disk, at the phase:

>> Finishing Basic Installation
>>> Install boot manager
(Saving bootloader configuration)

An error Windows appear!

,YaST2 says “Error occurred while installing GRUB.”

 ' [Minimal BASH-like line editing is supported. For the
    first word, TAB lists possible command completions.
    Anywhere else TAB lists the possible completions of a
    device/filename. ]
   grub>setup --stage2=/boot/grub/stage2 --force-lba (hdO,1)
        Checking if "/boot/grub/stage1" exists... yes
        Checking if "/boot/grub/stage2" exists... yes
        Checking if "/boot/grub/jfs_stage1_5" exists... yes

        Running "embed /boot/grub/jfs_stage1_5 (hdO,1)"...
        failed (this is not fatal)
        Running "embed /boot/grub/jfs_stage1_5 (hdO,5)"...
        failed (this is not fatal)
        Running "install --force-lba --stage2=/boot/grub/stage2 /boot/grub/stage1 (hdO,1) /boot/grub/stage2 p /boot/grub/menu.lst "...failed

Error 22: No such partition

OK ?

This is what i get (I format for JFS and have only one encrpted partition which is at the end and not mounted. my partitions are as follows : sda sda1 /windows/C sda2 /extended sda5 /swap sda6 / sda7 /home /sda8 not mounted .

thanks in advance…

“Peace at home, peace at World.” M.K. Atatürk

A quick jump up over this problem wa to re-partition the harddisk for a “/boot” folder. Then It succesfully installed and opened the GNOME screen, but when i re-start I get a screen that says “starting form the local disk …” but unfortunatelly can not! a cursor blinks but nothing appears. What i conclude now is i successfully installed the softeware but MBR is damaged or it can not point to GRUB ?

Any idea for probing is appreciated.

Sincerely from Istanbul.


I use suse 11.1 on a Vista Laptop. Grub is to the MBR.
I never bother with the /boot partition method.

During Install you need to CHECK the bootloader is checked to MBR

So the important thing is to click for the MBR and leaving others empty ?

I assume so and install now, I wonder what will happen and will share with you soon…

but anyway this straight forward installation shouldnt be so tricky, i got a day to understand the difference of MBR!

on the road again .


i saved the Bootloader to MBR and i did installed both of them…

But later i will write for the variations.


Thanks caf4926 for your suggestion. I also did check MBR and leave the rest blank and it worked great! :slight_smile:

For other guys there, I’ve installed my new arrived Studio 15 (1537) Dell laptop preinstalled with Windows Vista with openSuse 11.1.

The first time I’ve begun my installation from Windows Vista. The loader then rebooted the PC and begun with the installation. After looking for some similar issues here, I’ve decided to reinstall Windows Vista with the delivered DVD.

After the installation was completed, I’ve install openSuse, now without running it from Vista, but booting from the DVD.

As the error grub 22 partition error appeared I’ve just followed the suggestion caf4926 wrote, UNCKECKING ‘boot from extended partition’ and checking ‘boot from master boot record’ and it worked!! rotfl!

Hope this helps somebody outhere. Let us know. Best regards.


I don’t want to throw a spanner in here, but I recently found sp1 for vista will not install on my laptop and I think it may be related to having grub take over the MBR.
But it matters not to me. I just never use vista.
But see how you get on, depends if you have a sp1 dvd, but it may prove a problem for the next sp?
But I shouldn’t worry about it.

Thank you for this answer. Worked perfectly! I’m now dual booting into 11.1 and Vista on a Toshiba Satellite. Everything works like a charm!