Error 17 on GRUB, please help!

I’m dual booting Windows 7 and openSUSE. I attempted to start up my computer, and got ERROR 17 on the GRUB loading page. I am assuming this is related to me disabling the openSUSE uninstaller on startup in Windows… Sorry if this was noobish, the uninstaller seemed completely superfluous.

How did you install openSUSE? I mean did you run the installer from windows?

Yeah, I ran the installer from a DVD on Windows.

Extremely bad move and NOT a recommended procedure.
Do you have a windows DVD?

As it is I am not entirely sure what you have done, but you could try this:
Re-Install Grub Quickly with Parted Magic

But you must get the Parted Magic from the guide, this one

Technically, what you have done is a disaster but not beyond repair. So don’t panic. But you do need some experience here, we can’t literally hold your hand, but we’ll do our best.
You may need to restore the windows MBR, but let’s see… Try the above and see what happens
If you don’t understand anything, ask.

To be honest, I didn’t have anything of too much personal intrinsic value, so if there’s anyway to temporarily get rid of openSUSE on my second hard drive or get past GRUB, that’d be fine.

I just need to print out my bibliography for my extended essay…

I can fix things soon, I just need a way to bypass some Linux **** for the moment. Possible?

Let’s just clarify. Did you install openSUSE to a 2nd HD? if yes, what happens if you pull the power on that HD and boot without it?

Yes; lemme try that.

Well, after removal of the hard drive, my GRUB is giving me an ERROR 21.

You have 2 choices.

1.As I quoted at the start. But you need to plug the other HD back in. Make sure it’s still in the same boot order in the BIOS.

  1. Download this: Download Windows 7 System Recovery Discs — The NeoSmart Files
    You still didn’t say if you have a windows install DVD (I don’t mean some crummy recovery dvd)
    Use it to repair the MBR (You don’t need the 2nd HD connected for this)

I have never used this tool myself, but many have. The normal repair method from a windows dvd is:

Select to “Repair your computer”
Select/put the radio button/dot next to “Use recovery tools that can help fix problems” → Next
Select “command prompt”
enter this command: Bootrec.exe /FixBoot
enter this command: Bootrec.exe /FixMbr
enter this command: exit
Click to Restart

I tried using the suggested program, but it didn’t really make sense. However, in finding it I also found SuperGrubDisk, which let me boot my Windows.

So, my problems were solved for now. Thank you very much, and I’ll definitely use your method for fixing my Linux. Impressive how much one noob can mess stuff up. :slight_smile:

Much gratitude,

Actually the suggestion was to fix a Windows Boot. Those instruction would not help any Linux. They fix the MBR to boot to Windows.

On 2011-04-04 05:06, caf4926 wrote:
> carterdj95;2317441 Wrote:
>> Yeah, I ran the installer from a DVD on Windows.
> Extremely bad move and NOT a recommended procedure.

I don’t think that is the problem here. Forget how it was installed, as it
apparently worked for some time. It is rather one of the many problems
people have with grub.

The errors are documented:

17 : Cannot mount selected partition
This error is returned if the partition requested exists, but the
filesystem type cannot be recognized by GRUB.

21 : Selected disk does not exist
This error is returned if the device part of a device- or full
file name refers to a disk or BIOS device that is not present or
not recognized by the BIOS in the system.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)