Error 15 upgrading openSUSE 11.2 to 11.3 via zypper dup

Hi,

I just upgraded from 11.2 to 11.3 via zypper dup. However, when Grub menu appears I cannot boot into either 11.3 desktop & failsafe options, or 11.2 desktop & failsafe options either. In each case, the reason is “Error 15: file not found”.

Please help me! Thanks a lot!

:’(

Why would you have an option to boot 11.2 or 11.3 if all you did was ‘dup’ to 11.3?

Hi caf4926,

First I zypper dup as root without changing the repositories to those of 11.3. Perhaps this is a serious mistake. Then because I did not see 11.3 (still boot into 11.2 OK), I changed the repositories from 11.2 to 11.3 before zypper dup as shown via a google search. Now I see the blueish splash screen of 11.3 and all 4 options but cannot boot into any of them because of Error 15: File not found.

I suggest you boot a live CD and examine the /boot/grub/menu.lst
Do you understand such information and are you able to establish if the information there is correct?
And then can you establish if the kernel image it points to is in place?

Hello, i’m Ari and i still newbie…

I have some problem,

i got the tutorial from How To Upgrade From openSUSE 11.2 To openSUSE 11.3 Quickly | Liberian Geek

i change the repo and cant login in boot in every option…

if i choose 11.3, it will go to console (not gui) and i cant run “startx”

any advice?
if i reinstall with cd, my data will lost… (confused)

I followed the same tutorial!

Can you actually login at the CLI? Forget X for now…

I had this problem when I decided to reboot after doing all of the above with zypper dup, but I was kind of prepared to have issues…

The old grub had 11.2, 11.2 Failsafe, Windows. The new one had added to the top 11.3, 11.3 Failsafe with the previous 3 below. I couldn’t use any of the four top ones as the file in /boot/grub/menu.lst was point to all the wrong drive locations. Hence not being able to find the file.

You will get it going, but you need to edit the menu.lst file to point to correct location of the kernel image.

(In my case the 11.3 was pointing to (hd0,1) when it should have been pointing to (hd1,1))

So going back to what caf4926 said it’s probably down to the menu.lst file in similar cases.

  1. Get a live CD or USB stick (or any other method that works) with a bootable live linux distro on it. (I had a bootable USB stick handy with Ubuntu 10.04 on it)
  2. Locate the menu.lst file found at [your_opensuse_drive_partition_location]/boot/grub/menu.lst
  3. Look at it and determine which location it is pointing to (hd0,0) (hd0,1) (hd1,1) etc. (I used gparted to view the order of drives and the order of the partitions (the first drive or partition being 0, second 1, etc.))
  4. Look at the HDD(s) contents and determine which location is the one with openSUSE 11.3 (/boot/vmlinuz-2.6.34-12-desktop)
  5. Edit menu.lst to point to the correct location of the kernel.
  6. Reboot and the edited entries (if pointing to the correct locations) will boot up as intended.

If this sounds too complicated, come back and ask.

Hello caf4926 & macplaxton,

I tried using an openSUSE Live CD but it took too long to boot. GParted Live CD shows that openSUSE 11.2 root was in (hd1,5). GRUB menu shows 11.3 root is in (hd0,5). I solved the problem by editting GRUB menu directly to put 11.3 root in (hd1,5). Once 11.3 boots, I went to YAST to edit /boot/grub/menu.lst such that 11.3 desktop and 11.3 failsafe both have root (hd(1,5)) and delete openSUSE 11.2 entries.

Thank you both for your help.

How on earth you ever managed to get this to happen in the first place is beyond me!
But well done sorting it.

I had a similar problem following the same tutorial. I think the problem was complicated by an encrypted ext4 on a raid 5 array… after manually editing the item in grub to boot I get segmentation faults on boot. I’m starting a new install now.

On 2010-07-22 23:36, caf4926 wrote:
>
> taytong888;2194353 Wrote:
>> Hello caf4926 & macplaxton,
>>
>> I tried using an openSUSE Live CD but it took too long to boot.
>> GParted Live CD shows that openSUSE 11.2 root was in (hd1,5). GRUB menu
>> shows 11.3 root is in (hd0,5). I solved the problem by editting GRUB
>> menu directly to put 11.3 root in (hd1,5). Once 11.3 boots, I went to
>> YAST to edit /boot/grub/menu.lst such that 11.3 desktop and 11.3
>> failsafe both have root (hd(1,5)) and delete openSUSE 11.2 entries.

Exactly, that’s the procedure.

>>
>> Thank you both for your help.
> How on earth you ever managed to get this to happen in the first place
> is beyond me!

I have it seen happen before. In fact, it just happened to me on a different upgrade (11.0 to 11.2).
Typical.

Not user error, but YaST error. A bug in the installer.

In fact, the “bug” that leaves the previous kernel in grub menu is what allowed him to see easily
what the problem was and solve it. >:-)

> But well done sorting it.

Yes :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

On 2010-07-22 07:06, caf4926 wrote:
>
> Why would you have an option to boot 11.2 or 11.3 if all you did was
> ‘dup’ to 11.3?

It is typical, no user error there.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

On 2010-07-22 10:36, prazze wrote:
>
> Hello, i’m Ari and i still newbie…
>
> I have some problem,
>
> i got the tutorial from ‘How To Upgrade From openSUSE 11.2 To openSUSE
> 11.3 Quickly | Liberian Geek’ (http://tinyurl.com/2cw2yzv)
>
> i change the repo and cant login in boot in every option…
>
> if i choose 11.3, it will go to console (not gui) and i cant run
> “startx”
>
> any advice?
> if i reinstall with cd, my data will lost… (confused)

Your problem is video related, and nothing to do with the subject of this thread.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))

I had a very similar problem as the OP but mine wasn’t upgrading from 11.2 to 11.3. I just got done installing 11.3 today, opened up YaST, click online update, let it run, and then was prompted to reboot due to a kernel update yadda yadda. Reboot and suddenly I’m getting the Error 15 when trying to start openSUSE or the recovery from grub. Booted up GParted and saw in menu.lst that it was still referencing the original kernel. I changed it to the new kernel which is 2.6.34.7-0.5 and it’s working properly again. The really weird thing was that the update reinstalled Grub apparently, because it installed improperly during the initial setup and I had to go in and change two entries in menu.lst as well as remove two unneeded entries, but after the update the menu.lst reference were back to the way they were before I fixed it (with a butt-ton of help from please_try_again). Either way, got it straightened out with the help of this thread.