Error 15 After Update - Now What?

I’m having a *&^%% of a time getting SUSE 11 to install and run. I tried a Linux Format magazine DVD, a Novell promo DVD that I got at a Linux conference, and finally downloaded the DVD from the web site before I could get the install to work. Then, after I downloaded a software update, I couldn’t boot anymore, but got an immediate error 15: file not found. Now what; do I have to reinstall (again)? Forgive my frustration, but if I do, will I have this same problem again?

I’m running an ECS 945GCT-M mobo, Intel 2180 Core 2 Duo, 2 GB of RAM, 160/500GB HD’s, and a GeForce 7600 GS. I’m not totally new to Linux, and have run several versions of Ubuntu over the last year or so. I loaded SUSE at the recommendation of a friend, but is my experience typical for SUSE?

Thanks for any suggestions,

  • Michael B. in Cincinnati

ugg… Thats an ugly error to have. I’ve had it before with ubuntu and for me, the solution was to reinstall and add the all_generic_ide option to the boot options, which is likely to not work for you, and its probably overkill anyhow.

There is a linux cd called Super Grub Boot which is sometimes helpful when dealing with grub errors, and I would try that before I tried a full reinstall which would likely produce the same error again.

Another option which might work (it does in some distros) is make like you are going to install, select custom partitioning from the partioning menu, set your mount points but don’t format anything. On the next step, click cancel or back, which should hopefully give you a menu of installation steps. If it doesn’t you cant use this method, but if it does, jump ahead to the “add grub” menu option, and try running it. Hopefully, it works.

You might also look in your bios, which could be protecting your MBR from being written to. This is sometimes called “Virus Protection” You need that to be off or you cant write to your Master Boot Record.

Other possible boot options that might help are noapic nolapic, acpi=off, pnpbios=no, and irqpoll.

Ohh, and no, OpenSUSE, generally, is a real kickass Operating System. Especially for people who don’t like the command line, but no OS is perfect, and you might want to try another flavor of linux. Can I ask, Why did you switch from ubuntu? Were you having troubles, or did you just want to try something new?

Sorry, I reread your post and now I think you probably got an updated kernel when you did your updates. There are some known issues with the more recent kernels. My Dell Inspiron 1100 was killed in a simular fashion by a kernel update. I had to downgrade that one to Ubuntu 6.06 and then not update the kernel, but eventually, I just swapped the hd of that one and this generic laptop, and now I’ve got no errors on either. When (if) you reinstall, try to not update to a newer kernel. Try that Super Grub Boot disk first though. You might be able to rescue what you’ve got. Good Luck.

Also, if you cant seem to find a problem, check that your power supply is putting out what it should. Lots of Computer problems are due to weak power supplies.

It depends how much playing around you want to do.

Error 15: File not found
This error is returned if the specified file name cannot be found, but everything else (like the disk/partition info) is OK.

Boot from a live cd and then go to /boot/grub on your hdd. Open menu.lst for editing and find the offending line in the grub boot menu and then give it the correct name corresponding to the one in /boot.

You can also try the ‘recover installed system’ option when booting from suse installation dvd. Leave out the checking files option.

Thanks for the suggestions!

To answer your last question, simple curiosity. A friend of mine who is running SUSE 10.3 recommended that I try it. I specifically put a second HD in my system that I could partition and try some other distros. I was particularly curious about KDE 4.0; I’ve been running the default Gnome on my Ubuntu installs, and have been pretty happy with that. I’ll try some of these suggestions just to learn something and see.

You will find this of some help - error 15 sounds like grub can’t find a file. I would follow the guide to reinstall the bootloader and make sure it has the correct location for the kernel

GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.