erratic installation

Hi there,

I have installed and reinstalled opensuse 11.1 always with different outcomes. I’m puzzled. Allow me to explain more: The first time I installed opensuse 11.1 I had audio problems with pulse audio. I got skipping, stuttering and interference playback with banshee and especially when mixing from different sources (flash, banshee, pidgin, etc).

After trying to solve the problem, I decided it was best to reinstall.

When I was booting the system again, after I plugged in my usb key on my computer it displayed a BUG buddy crash report (thus suse wasn’t able to open up my usb key’s folder automatically and the same happened with CDs and DVDs).

I reinstalled again and I got rid of both the audio problems and the BUG buddy crash report. But I was stuck with a loud sound when playing flash on firefox (but this is a problem I’ve always had with opensuse 11.1).

So since I had some time on my hands I decided to reinstall and guess what? my first pulseaudio problems are back…I’ve tried everything and it doesn’t work…I tried removing pulse and installing esd back, but the result was similar or worse.

On top of that the bug report again…

I find this soooo absurd…how can installing linux in general be so erratic?’s not just opensuse 11.1. The same has happened to me with Ubuntu 8.10 (but the problems I get are different).

I’ve checked my iso files. I’ve matched their md5 and I have done a media check using yast’s utility and everything checks out ok…

Could someone please explain what on earth is going on?

When you run the install from the dvd, the installer probes your system and hardware and if you use automatic configuration (default) the installer will do it’s best to install the correct hardware drivers, however - you may need to do some tweaking after install.

The issues you report should all be solvable with help via the forum. All this re-installing is unnecessary.

Solvable with the help of the forums?

I don’t think so. I have many posts with my issues concerning audio playback with pulse and audio playback in flash. But, so far this issue remains unsolved… I’ve even posted in bugzilla among other people.

Oh and I didn’t click on the box that said ‘automatic configuration’ at the beginning of the installation process.

Now that you have removed pulse, I don’t think I can help. But reference your pulse audio problems, sometimes, if one keeps pulse, there is a work around that helps some. The PulseAudio sound server was written to use timer-based audio scheduling instead of the traditional interrupt-driven approach. This is the approach that is taken by other systems such as Apples CoreAudio and the Windows Vista audio subsystem and has a number of advantages, not the least in reduced power consumption, minimization of drop-outs and flexible adjustment of the latency to the needs of the application. However, timer-based scheduling may expose issues in some Alsa drivers. To turn timer-based scheduling off, replace the line

load-module module-hal-detect

in /etc/pulse/ by

 load-module module-hal-detect tsched=0

Reference: SDB:AudioTroubleshooting - openSUSE

Hi there,

Yes, I had tried removing pulse, but I currently have it running on my system. I’ll try your suggestion, but if I got what you said correctly, then the problem might be my alsa driver?

I’ve done this:

speaker-test -c2 -l5 -twav

and it works fine (but then again, that is not mixing!!). So when I posted this in bugzilla, my bug was removed, because they claimed the problem was in pulse, but I don’t buy this, based on this following experience I had.

By people’s suggestions I installed opensuse 11.1 kde 4.1 which can be rid off (completely!) of pulseaudio (while in gnome you can’t really remove it all, without a bunch of dependency problems). But the starting sound when booting sometimes didn’t sound or got cut off and a message was displayed saying that there was something wrong with my device.

My device is:

$ lspci -v
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
	Subsystem: Hewlett-Packard Company Device 30a4
	Flags: bus master, 66MHz, slow devsel, latency 64, IRQ 17
	Memory at c0003400 (32-bit, non-prefetchable) [size=256]
	Capabilities: [40] Message Signalled Interrupts: Mask- 64bit- Count=1/1 Enable-
	Kernel driver in use: ATI IXP AC97 controller
	Kernel modules: snd-atiixp

$ cat /proc/asound/cards
 0 [IXP            ]: ATIIXP - ATI IXP
                      ATI IXP rev 2 with unknown codec at 0xc0003400, irq 17
 1 [Modem          ]: ATIIXP-MODEM - ATI IXP Modem
                      ATI IXP Modem rev 2 at 0xc0003800, irq 17

I find that ‘unknown codec’ line rather funky. The developer in bugzilla told me that was irrelevant.

Another problem I have, is that if I’m playing music on banshee and I open up openoffice’s calc and start working heavily with it, I get stuttering too!..[/size]

Thats a different problem/bug. :slight_smile:

I believe a number of users have reported this. There are a more than a fewthreads here, where users have posted solutions that worked for them:

returning to the issue with pulseaudio, I tried what you suggested but it didn’t work. I still get interference between different audio sources (example, gmail, youtube and banshee). I thought that was pulse’s purpose! to allow mixing…so it’s obviously broken in my system.

I confess I do not know what you are referring to.

I gave advice to try fix this:

But the starting sound when booting sometimes didn't sound or got cut off and a message was displayed saying that there was something wrong with my device

Now you are talking about a new problem?

yes, but before that, you told me I could do some changes to the file under /etc/pulse/ by removing the timer-base that pulse uses

that didn’t work

ok … that was to help the skipping/stuttering … as reported here:

Many users would get skipping/stuttering from one source or more.

Reference interference from different sources, just what are you trying to do? Play multiple sources at once? Are you saying it works ok if you play only one multimedia app at a time?


yes, that is correct. If I play sounds from different sources I get interference and bad audio (but from a single source everything works fine, except for an occasional horrible brief distortion sound when I play a youtube video with audio, for example). I run into this situation a lot: assume I’m listening to some music using banshee but I have firefox running and I open gmail and one of my friends sends me a message (which comes with a characteristic ‘bing’ sound, then I get interference…I hear distortion in my music, which doesn’t happen using other OSs.

OK, … fair enough …

It was just an effort to help … I think I qualified it as best possible. … I quote from my effort:

sometimes, if one keeps pulse, there is a work around that helps some.
and indeed it has helped some. It helped me.

But it doesn’t help everyone.

All one can do is try.

I’ve been reinstalling a bunch of packages, but my problem remains. I’ve done quite a bit of testing different apps. I’ve tried playing music in banshee and at the same time doing:

aplay test.wav

and it works fine. I’ve also done the same combination of aplay but with a youtube video and it works well.

In the pulseaudio website It was suggested I did this:

> pulseaudio -vvvv
D: main.c: Started as real root: no, suid root: no
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
D: main.c: Can realtime: no, can high-priority: no
W: ltdl-bind-now.c: Failed to find original dlopen loader.
I: main.c: This is PulseAudio 0.9.12
D: main.c: Compilation host: i686-suse-linux-gnu
D: main.c: Compilation CFLAGS: -march=i586 -mtune=i686 -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -fno-strict-aliasing -Wall -W -Wextra -pedantic -pipe -Wno-long-long -Wvla -Wno-overlength-strings -Wconversion -Wundef -Wformat -Wlogical-op -Wpacked -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Wno-unused-parameter -ffast-math
D: main.c: Running on host: Linux i686 #1 SMP 2009-02-25 15:40:44 +0100
I: main.c: Page size is 4096 bytes
D: main.c: Compiled with Valgrind support: no
D: main.c: Optimized build: yes
I: main.c: Machine ID is 518805c27a5f7df2e18505e749aa1d10.
I: main.c: Using runtime directory /home/candres/.pulse/518805c27a5f7df2e18505e749aa1d10:runtime.
I: main.c: Using state directory /home/candres/.pulse.
I: main.c: Running in system mode: no
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.

and check for suspicious output…so, is any of the output suspicious?

It seems I’ve finally found the problem… but I have no clue how to solve it…

grep -i pulse /var/log/messages:
Mar  1 00:54:17 suse-linux pulseaudio[8998]: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
Mar  1 00:54:17 suse-linux pulseaudio[8998]: core-util.c: setpriority(): Permission denied
Mar  1 00:54:17 suse-linux pulseaudio[8998]: ltdl-bind-now.c: Failed to find original dlopen loader.Mar  1 01:47:18 suse-linux pulseaudio[3452]: module-alsa-sink.c: Increasing wakeup watermark to 36.75 ms
Mar  1 01:52:08 suse-linux pulseaudio[3452]: module-alsa-sink.c: Increasing wakeup watermark to 34.00 ms
Mar  1 01:54:47 suse-linux pulseaudio[3452]: module-alsa-sink.c: Increasing wakeup watermark to 68.00 ms
Mar  1 02:13:09 suse-linux pulseaudio[3452]: module-alsa-sink.c: Increasing wakeup watermark to 136.00 ms
Mar  1 02:24:58 suse-linux pulseaudio[3452]: module-alsa-source.c: Your kernel driver is broken: it reports a volume range from 18.00 dB to 18.00 dB which makes no sense.

The last line is the one that particularly interests me. It seems my alsa-driver is screwing up

Any help?