Epson XP-225 not using colors (while in windows does) een if they are set to

Hello I’m using openSUSE 13.2 (harlequin) in kde, I’m using an Epson XP-225 and this is settings in cups :

http://i58.tinypic.com/10r1mc2.png

While in windows in can use and print in colors,in openSUSE it only prints in black&white, even if before printing i check the options and is set to use colors.
If i scan a colored document it prints them as it should,but if i try to print any image or documet from the hard disk it won’t use them.
I’m using the drivers found in this page:
http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=IT&CN2=&DSCMI=35219&DSCCHK=c20e9652961899aae7a3e8c75284fcde4c029995
I just can’t figure out how to check/see what could be the problem.

This is the options window from before printing and from yast

http://i60.tinypic.com/2rer1c9.png

http://i57.tinypic.com/2r2byg7.png

Any suggestion on how to solve this please ?
Thanks in advance

If i scan a colored document it prints them as it should,but if i try to print any image or documet from the hard disk it won’t use them.
I’m using the drivers found in this page:
http://download.ebz.epson.net/dsc/du…84fcde4c029995

When you print from a scanned document, what application are you printing from? If you do a test print from CUPS (web interface), do you get a coloured print?

For scanning I just click on the button in the printer (putting a colored page/document on it) and print it directly.
As for CUPS is still in B&W.

Thanks for clarifying. Locate the .ppd file in the /etc/cups/ppd/ directory and upload to http://paste.opensuse.org/
then post the URL it generates here so it can be inspected.

It’s late here, so I won’t be able to check it until the morning, but maybe someone else can.

Thx for replying.
Here is the link:

http://paste.opensuse.org/43126467

As you describe it, I think that is local copying on the printer. Not scanning an image to the computer.

Yes …that was my reply to the question of how I do the scanning (but that doesn’t give any trouble as it works and prints the colors).
The problem is when printing something from the hard disk (Local Printing),as it prints only in black and white when it should be colored instead.
While if I scan it and print directly it works (using the direct button on the printer,not any program from either openSUSE or windows),meaning the colors are there and are used.
To check this I select a pic (tried many different one’s and they are from my camera) from okular or gnview and print it and instead of being colored as the original they are B&W.
Even tried the default pics of the openSUSE desktop wallpaper.

The default options in the .ppd file checked out ok. Do yo have ~/.cups/lpoptions present? It contains local default printing options if it exists. You can also check the user options set there with

lpoptions -l

You could try printing a PDF via the command-line with

lpr -P <printer-name> <file>

For example, printing a .jpg file (located in my Downloads directory) to my Brother laser printer

lpr Brother_DCP-7055 ~/Downloads/trees.jpg

Does it behave any differently for you?

Thanks for your reply. I’m not on that pc right now (isn’t mine) but later I’ll be going there and I’ll check and post the results.
Just to be clear, you want me to try to print a pdf doc ?

Yes, and try printing a colour JPG too. I just want to check if lpr printing behaves differently than printing from an application.

It’s worth checking that the OS is fully updated too.

Sorry for the delay, but his hard disk broke so I had to reinstall both OS’s and only now I had time to do it.
Here are the results of the commands you wanted me to check:

lpoptions -l
MediaType/Media Type: PLAIN_HIGH *PLAIN_NORMAL PMMATT_HIGH PMMATT_NORMAL PLATINA_HIGH PLATINA_NORMAL PMPHOTO_HIGH PMPHOTO_NORMAL PMPHOTO_DRAFT PSGLOS_HIGH PSGLOS_NORMAL PSGLOS_DRAFT ENV_HIGH ENV_NORMAL
Ink/Grayscale: *COLOR MONO
PageSize/Media Size: *A4 TA4 4X6FULL T4X6FULL 2L T2L A6 A5 B5 L TL INDEX5 8x10 T8x10 4X7 T4X7 ENV10 ENVC6 Letter TLetter Legal


As for printing with the direct command (lpr -p ) prints with colors so it does work. While opening the image with okular and then select print doesn’t.
So at least I know it can be done, but i would like a fix for it so I (and him ) can print directly.
Thanks

Update and correction:

The images were opened using gwenview while the documents with Okular.
I’ve checked if there was a setting I could change in Gwenview (that could interfere or was set to print in B/W) but didn’t find anything about it.

Hello
I’m having the same problem with a Epson Workforce BX630FW and Opensuse 13.2 in both a recent install and an older install that previously worked very well.
Whaterver configs you input on yast2/printerconfig or just before print it will print only in grayscale and instead shrink or maintain the proportions it will split the page in 2, it can’t also print a test page fro yast2 only from cups but comes grayscale and splited.
I’ve already tried all drivers avaliable for this device.

A bug report might be required here

but perhaps worth trying this first

zypper install --force cups-filters-ghostscript
systemctl restart cups

https://en.opensuse.org/openSUSE:Most_annoying_bugs_13.2#Printing

For me it’s working!
Thanks

Good to know. It will be interesting to see whether this will resolve the OP’s printing issue too.

Sorry for the late reply (again) as I’m not always there, they gave up.
I tried to give them a legal alternative to what they have (do I need to explain ? :smiley: ) while I’m here in a holiday, but after the printing issue, the fact you have to put a password whenever they have to install something and/or access the ntfs partition and a few other things they didn’t like they went back to what they had before (I made a dual boot).
While some could be fixed with a workaround and other’s were trivial can’t do much if they don’t like it.
Thanks everyone for the effort anyway (I appreciate it).
Have a nice day.

Thanks to the update. As long as those you were helping are happy, that’s all that counts.

Update 2:

I’ve asked them to let me check it on my own notebook (that has the same openSUSE 13.2, but at my home I use a Canon and never had that problem on either the PC or this notebook) and it was doing the same.
Then after doing

zypper install --force cups-filters-ghostscript

as you suggested, it fixed it so it can print in color now.
Thanks again (I’ve learned something new too :smiley: )