EPSON Workforce WF2810 not recognized or available

Dear friends,

i have massive problems getting my EPSON WorkForce WF2810DWF to work under openSUSE. I have this problem ONLY on openSUSE. Linux Mint recognizes my printer right from the getgo. Even a raw Debian only needs “sudo apt install cups” and everything works perfectly.

BTW, i do not use cables. I dont even have the needed ones. I only work via WIFI. My Printer is connected to my home wifi and all other devices communicate with it via WIFI.

On openSUSE i am desperating. I tried YaST Printer. Here I chose the device (my printer) and I even installed the very specific WF2810 drivers from EPSONs website. So far so good. Yet nothing seems to change. When i openany file and click on print, the only options I get are “print to document” or “generic printer”.

Cups is installed and the latest version.

What did Debian do differently? Why is openSUSE having such a trouble?

Any help is apreciated.

Hi McMoneysack91,

Welcome to openSUSE and this forum.

I have to say I’m not always lucky setting up my printers. However, if you have it working in Mint and Debian, you can find out the exact URI of the printer.
With that you can go to YaST - printers - search for the “add printer” button and go the the assistant (don’t know the exact name in English, it’s top right next to “find more”. (Of course, you can try that one first.)
There’s a variety of options to add printers, find the “enter specific (?) URI”. There you can enter it and add the printer model. Since you have installed the Epson driver it might work that way.

I’m not the one to explain how and why - it was trial and error for me. Others can give better advice if mine fails.

Have a lot of fun!


It seems like I actually already have found the URI via YaST and “added” that printer with the fitting drivers. My problem is, that still no document can find my printer when I click “print”. I will keep going and trying to find a way. I assume that I am pretty close to the answer.


I assume, when checking printer configuration in YaST - edit printer the options “accept print jobs” and “activate print function” are activated (?).

You may check this post:


lpstat -p

The problem has been solved!And the problem was, that the YaST firewall blocked anycommunication between printer and PC. Therefore, after I deactivated the firewall testwise, openSUSE recognized my printer right from the get go without ANY proprietary stuff or any further action.

The firewall blocks remote access. Printer is:

karl@erlangen:~/Downloads> LANG=C lpstat -t 
scheduler is running 
system default destination: HLL2350DW 
device for HLL2350DW: lpd://BRW1CBFC0D1EA86/BINARY_P1 
HLL2350DW accepting requests since Tue Jul 20 06:03:13 2021 
printer HLL2350DW is idle.  enabled since Tue Jul 20 06:03:13 2021 

Open access by adding ipp service permanently:

**erlangen:~ #** firewall-cmd --add-service=ipp --permanent  
**erlangen:~ #** firewall-cmd --list-services  
dhcpv6-client http https **ipp** mdns minidlna plex 
**erlangen:~ #**