Epson wf7510 not working at all

So basically, every preceding linux distro hasn’t had many issues, or none at all, with my printer. HOWEVER, opensuse tumbleweed on kde plasma is having very many issues. Trying to discover it in CUPS or kde printers just doesn’t work, kde printers saying it’s “forbidden”. I tried using an ipp but I clearly have no idea how to use it, and it says “The printer configuration is incorrect or the printer no longer exists.”. I’ve asked for help in the discord, an nobody could figure the issue out. So I’m asking you guys, how can I get my printer to work?

How is the printer connected? Maybe the openSUSE firewall is active and preventing discovery (assuring a network connected printer). You can stop the firewall temporarily if needed.

With the CUPS web management interface, you use the root credentials when prompted.

It is a network printer, and I did use root credentials.

You never mentioned it the firewall is running and if you disabled it.

Also, you can find where @deano_ferrari assisted this person in another thread with the same printer

Hi, I have no idea how to check whether the firewall is running or how to disable it, and in that thread I saw that I needed to install a package, which I did with rpm -i, but I have no idea what I’m meant to do after that.

It’s also worth noting that when I open kde printers it exactly says “Failed to get a list of devices: ‘Forbidden’”

Will just answer to that:
systemctl status firewalld checks whether the firewall is running
sudo systemctl stop firewalld stops the firewall just for this session
sudo systemctl disable firewalld disables the firewall for future boots (not the current one)
sudo systemctl disable --now firewalld disables the firewall for current and future boots
sudo systemctl enable firewalld enables the firewall for future boots (with --now for including the current boot)

Okay I stopped it and it didn’t change anything. It was indeed running.

That was just to assist with discovery if needed. (We can adjust the firewall to cater for this later if desired.)

Many modern printers support driverless printing. No additional drivers needed in this case. When that is the case the printer should appear, provided it is discovered via DNS-SD and using the IPP protocol for communication (between CUPS and the printer).

What is returned by the following commands?

sudo /usr/sbin/lpinfo -v
lpstat -t

If drivers are required, we can assist with that next.

This is the output. The 5 printers were fails to make it work.

Best to copy paste the output here using the preformatted text button ( refer to the </> button in the forum editor).

Looks like you have multiple (incorrect) definitions for the same printer, including when you had it connected via USB cable.

Are you sure that you configured it using the correct IP address? Normally, I would expect the first IP address (sometimes the last) to be pertaining to your router gateway. Anyway, open a terminal and run the following commands to provide your PCs current IP configuration

ip a
ip route

I suggest you refer to your printer’s user guide and check the network configuration from the front panel first…

What do I look at there? I know for a fact that it works for other computers.

You overlooked @deano_ferrari 's request for two command line outputs - might read that reply again :+1:

---- QUOTE ----
Anyway, open a terminal and run the following commands to provide your PCs current IP configuration

ip a

ip route

A post was split to a new topic: Canon Printer and CUPS Support Request

Well whoops!

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 34:7d:f6:4f:66:04 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlp0s20f3
       valid_lft 172749sec preferred_lft 172749sec
    inet6 2601:49:100:2b50::d377/128 scope global dynamic noprefixroute 
       valid_lft 604750sec preferred_lft 604750sec
    inet6 2601:49:100:2b50:989a:ec4c:8b7c:d964/64 scope global temporary dynamic 
       valid_lft 191786sec preferred_lft 85786sec
    inet6 2601:49:100:2b50:2ae6:bf06:b2da:73c9/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 191786sec preferred_lft 191786sec
    inet6 fe80::59c4:3a4b:2a70:6063/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
wolf@localhost:~> ip route
default via dev wlp0s20f3 proto dhcp src metric 600 dev wlp0s20f3 proto kernel scope link src metric 600 

So, are you clear on what you need to do next with respect to the printer network connectivity?

Uh, maybe? I need to check the network settings on the printer, yes? What am I looking for in the network settings?

I had similar issues with setting up my printer in TW KDE.

I had to log into KDE as root and install the system-config-printer package as well as add mdns service to be allowed on the firewall.

sudo zypper in system-config-printer
sudo firewall-cmd --add-service=mdns
sudo firewall-cmd --add-service=mdns --permanent

Hope this helps.

Sorry… let me clarify my post above.

Installing the package and configuring the firewall your can do with your personal account.

However when you go to add the printer in KDE you need to log into KDE as root for it to be successful.