Epson V500 scanner works . . . kind of

My wife would like me to report this took two hours to get this far . . . >:)

The Epson V500 works. The avasys bulletin board seem to indicate they got it working sometime between 16 March 2008 and 11 April 2008. I didn’t find it listed in the YaST module’s scanner database (oddly, the Epson Perfection V10, V100, V200, V350, V700, and V750 were all listed) so I installed the driver from avasys instead.

YaST and the frontends (xsane, iscan, etc) now report the V500 as

Epson GT-X770 at epkowa:interpreter:003:002

(after seeing that, a little googling indicates that yes, V500==GT-X770)

sane-find-scanner reports it as

(vendor=0x04b8 [EPSON], product=0x0130 [EPSON Scanner]) at libusb:003:002

The V500 worked in xsane and iscan for root, but only for root. So I changed the owner and group for the device file

# chgrp users /dev/bus/usb/003/002
# chgrp niels /dev/bus/usb/003/002

Now it works for me and root, but it presumably wouldn’t work for anyone else.

I have tried adding a udev rules to




and reloading udev (

# udevadm control --reload_rules

)but those didn’t help.

Xsane works except I get a non-fatal error during start up

Error during CMS conversion: Could not open scanner ICM profile:

iscan from avasys is a fairly limited utility, but it works.

skanlite serves a vertically compressed preview image making it’s other features essentially useless

Kooka still doesn’t find the scanner.

  1. To whomever maintains the Epson scanner drivers . . . perhaps it’s time to revisit the Epson Perfection V500 (aka GT-X770)?

  2. How do I configure the system so the scanner works for regular users without having to change the device file permissions?

  3. I’d also like to be able to manage the scans from my laptop over the wireless network, any suggestions on how to do that?

  4. Any word on getting the infrared “digital ICE” channel working for dust removal?

  5. How to fix skanlite?

  6. How to fix Kooka (does it only run in KDE 3?)

See this Scanner driver problem - openSUSE Forums .

That thread says “use the avasys driver”. Yes, I know. I said in my post that I was using the avasys driver already. One of the questions I put at the bottom was that someone from SuSE should update their iscan with this newly released V500 driver from avasys.

But if you have any other suggestions for the remaining five issues, I’d really appreciate it.

thanks niels; in a sense reassuring that someone with your expertise was unable to

configure the system so the scanner works for regular users without having to change the device file permissions?**

we have only succeeded (by chance I believe) to have this happen with KDE on 10.3; each other version of Suse runs only as root;

I have taken to regard it as a perverse querk of Suse;

like you, I investigated adding udev rules; I did not succeed;

I did make a post to the 11.1 forum, in its development stages; asking for scanners and non-root running to be considered;

I am not sure how one brings these issues to the Suse developers …

our scanner is usb; I do a lsusb and then a chmod a+rw when we wish to use it;

then xsane works fine;

The easy fix is to add the users to the lp group, just check the
ownership of the device file.

would you like to expand on your advice on

just check the ownership of the device file.

Think he means:

dean@linux:~> ls -l /dev/lp*
crw-rw---- 1 root lp 6, 0 2008-06-07 07:39 /dev/lp0
dean@linux:~> ls -l /dev/ttyUSB*
crw-rw---- 1 root uucp 188, 0 2009-01-03 15:06 /dev/ttyUSB0
crw-rw---- 1 root uucp 188, 1 2009-01-03 15:06 /dev/ttyUSB1

So, for a parallel port device the user needs to be a member of lp group, while for a usb device, add the user to uucp group.

thanks deano;

if I issue that command

ls -l /dev/ttyUSB*

on 11.0, I get

cannot access /dev/ttyUSB: No such file or directory*

and on our older 10.2 system, where I had the scanner connected this afternoon, I get the same;

I sort of remember some discussion about changing permissions, and it said ?? maybe not good to give everyone access to USB … as things like the keyboard were USB, and so keyloggers could follow … would that be so?

if I make each user a member of uucp, am I doing that?

when I do make myself a member of the uucp group, I still cannot get xsane to recognise the scanner; (even after rebooting)

if I issue the command

ls -l /dev/bus/usb*

I get for Bus 006

drwxr-xr-x 2 root root 60 2009-01-03 20:48 006

but if I leave the scanner in the same port, will be Bus and Device number always be the same?

if I issue that command

ls -l /dev/ttyUSB*
on 11.0, I get

cannot access /dev/ttyUSB*: No such file or directory

Thats strange. If you have usb ports and correct modules loaded, I would have thought these device nodes would exist. Maybe someone else can illuminate further…

Anyway, significant differences exist between 10.2 and 11 versions, where permissions are concerned. (A trawl through /etc/udev/rules.d/… reveals the group owndership of various ports). It is possible to write a custom udev rule specific to your scanner, which could then be owned by a custom group, as explained here.



as user (then as root if not detected as user).

After installation of the original iscan under openSuSE 11.0 there is a file /etc/udev/rules.d/55-iscan.rules, which remains after upgrade via:

zypper in iscan-2.19.2-1.c2.i386.rpm
zypper in iscan-plugin-gt-x770-2.1.1-1.c2.i386.rpm

from Download*Scanner [AVASYS CORPORATION]](

Modify for V500 group “video” permissions:

— 55-iscan.rules.orig 2009-05-28 15:40:33.000000000 +0200
+++ 55-iscan.rules 2009-05-28 15:56:18.000000000 +0200
@@ -14,6 +14,7 @@

For Linux >= 2.6.22 without CONFIG_USB_DEVICE_CLASS=y

If the following rule does not exist on your system yet, uncomment it

ENV{DEVTYPE}==“usb_device”, NAME=“bus/usb/$env{BUSNUM}/$env{DEVNUM}”, MODE=“0664”, OWNER=“root”, GROUP=“root”

+SYSFS{idVendor}==“04b8”, SYSFS{idProduct}==“0130”, MODE=“0664”, GROUP=“video”, ENV{iscan_matched}=“yes”

Kernel < 2.6.22 jumps here


Execute ‘udevcontrol --reload_rules’ as root. Group “video” may now access the scanner. Voilá.

If someone is able to provide a proper solution involving resmgr, don’t hesitate to post.

Kind regards.

After installation of the original iscan under openSuSE 11.0 there is a file /etc/udev/rules.d/55-iscan.rules, which remains after upgrade via:

I have earlier version of iscan package with openSUSE 11.0:

rpm -qa |grep iscan
linux:/home/dean # uname -r

The udev entries look like this

SYSFS{idVendor}==“04b8”, SYSFS{idProduct}==“083f”, MODE=“0664”, GROUP=“lp”, ENV{libsane_matched}=“yes”

I guess it doesn’t matter which group you assign, but lp group is usual group for printers and scanners.