Epson SX600FW Landscape Layout Wrong

Having selected ‘Landscape’, when printing using ‘File|Print’ in KWrite, the text is presented in landscape but formatted to a size of approximately 105mm x 590mm (bottom half of a landscape page and stretched to twice the width, printing only the left hand side). I have a similar issue with some other programs too, but not Open Office.

Having configured ‘cupsd.conf’ to log in debug mode it would seem that the problem I’m getting may be to do with applications that output in ‘application/pdf’ format, because in the CUPS log for Job 57 line 479 seems to indicate that KWrite has output a PDF file:

[Job 57] File of type application/pdf queued by "root".

Then at line 490 there’s a line that seems to indicate no landscape, even though this was selected through the user interface of KWrite (and works in Open Office)!:

[Job 57] argv[5]="document-name=4b69b8710002c media=A4 nolandscape job-uuid=urn:uuid:5c6fae2f-ad2f-3364-5f04-bb5500d1eabc"

I would have attached the various ‘log’ and ‘conf’ files but I’m new to this and I just can’t find a way to get attachments enabled for my login!

I’ve spent hours on this, if anyone can give me any pointers I would be most grateful, however I am no Linux system administrator I’m afraid.

Current system: openSUSE 11.2 x64, Kernel, CUPS 1.3.11, gutenprint 5.2.4, KWrite 4.3.1 release 6, KDE

Old system (that worked with this printer): openSUSE 11.1 x32, gutenprint 5.2.2

Having done some more investigations I have found that the following actions seem to ‘resolve’ the layout problem:

  • stop cups with
/etc/init.d/cups stop
  • try to print from KWrite, which will then crashes (I need to checkout if this needs logging)
  • reload KWrite and try to print again, and this time the print dialog has a very long ‘Type’ field 'Epson_SX600FW@hostname, Aliases: Epson SX600FW with driver Epson Stylus Office SX600FW - CUPS+Gutenprint(Openprinting LSB 3.2) v5.2.4’
    , at this point ‘Cancel’ (just for clarity, I am not referring to the printer ‘Name’ dropdown here)
  • The above ‘Type’ field always shows as 'Epson - Epson Stylus Office SX600FW’
    on any other occasion and never prints correctly in landscape, but does in portrait!. - start cups with
/etc/init.d/cups start
  • then use KWrite to print, selecting landscape, and it all works!

So, this looks as if KWrite (KDE generally?) is not getting the appropriate printer settings correctly from CUPS, but manages to find the correct settings by some other means when CUPS is not running and subsequently retains these settings for the rest of the user session. However, this ‘work-around’ is not really very convenient:)
Can anyone provide any pointers as to why KDE should not be getting the correct printer configurations from CUPS?

Many thanks in anticipation

Hi Dear,
I really appreciate to your post.When i was purchased Epson printer same problem with me.But when i used your given tips, i resolved this problem.

V Very Thanks…

Hi Nathan, I’m glad it helped you! I’m still not sorted with 11.2:( I have now performed a complete re-install of openSUSE 11.1 and gone back to my old version but this time 64bit, installed the gutenprint 5.2.4 package, and guess what - I have no problems with landscape printing from KWrite! So, it looks as if something is definitely broken in 11.2 in this regard and I think it is the KDE ‘kprinter’ libs not CUPS. I intend to install Virtualbox and create a 11.2 install as an application, then have another go at tracing the issue, but for the moment I’m not ‘upgrading’ to 11.2, although 11.2 itself might prove to be OK, but not ‘kprinter’ in KDE 4.3.1. We will see!