Epson Scanner detected but not recognized in 12.1

I’ve looked at posts of Nov. and Dec. 2011 with similar problem, but I still unable to make my 12.1 recognize my scanner, even though it is detected correctly.
I downloaded and installed with YAST2 a data package and a core package from AVASYS for my WorkForce 635 all-in-one device. I then used “sane-find-scanner” with the result “found usb scanner (vendor=0x04b8,product-0x085d at libusb:008:002)”.
Used command “scanimage -L” with result “No scanners were identified”.
Used command “lsusb” with result “Bus 008 Device 002: ID 04b8:085d Seiko Epson Corp”
Looked for epkowa.conf file in directory /etc/sane.d it did not exist, so I created this file with one line “usb 0x04b8 0x085d” in the directory.
I made all users member of the “lp” group.
I ran command “iscan” which the system could NOT find.
Ran YAST2 scanner with the result: Driver: “epkowa” Scanner: “No scanner recognized by this driver”, then attempted to add Epson WorkForce 610 series with result “(Package sane-backends) This scanner is not supported by the driver Epson2. (USB-ID 0x04b8:0x0855) supported by the epkowa backend plus non-free interpreter} Model Not Supported by the Driver epson2.”
I considered using command “zypper install” as in the posts of Nov. and Dec., but I do not know which files and from what directory.
What I’m I missing? Any assistance would be greatly appreciated.
Alvin Eshe

Please post:

zypper se -si iscan

You mentioned that you had to manually create the /etc/sane.d/epkowa.conf file. That is part of the Avasys iscan package, so that suggests this is not installed IMHO.

  1. I’ve found from experience that the yast scanner config utility is not required. Make sure you have the iscan and iscan-data packages installed first.

  2. Have a look at /etc/sane.d/dll.conf, and make sure you have an uncommented entry for ‘epkowa’ present.

Thank you for the suggestion of using the command “zypper se -si iscan”. The result was: S=i, Name=iscan-data, Type=package, Version=1.13.0-1, Arch=noarch, Repository=(System Packages). Unfortunately this did not change any results. NO scanner detected with all four frontend programs.

You have only iscan-data installed, you must install the iscan.rpm

Thank you for your two suggestion. The second one first: An uncommented ‘epkowa’ was and is present in the file /etc/sane.d/dll.conf. The first suggestion: I am unable to tell you if both packages have been successfully installed. I did a find command of ‘iscan*’ with the results of iscan-data found in /var/lib/, /usr/share/, and /usr/lib/ with all three being read only. Also the file iscan-data-1.13.0 was found in /usr/share/doc/ and it is read only. The core package (iscan.2.28.1-3.ltdl7.x86_64rpm) was not found so I downloaded and installed it again from AVASYS using “appear”. Using the find command again for ‘iscan*’ gave the additional results of:‘iscan-2.28 … rpm’ found in /tmp/ and ‘iscan-2.28… rpm.desktop’ found in /home/“user”/.kde4/share/apps/RecentDocuments/ and these are read only. Since the core package does not look like it has been installed to me, I tried “zypper install /tmp/iscan-2.28 … rmp”. zypper came back with error messages “Specified local path does not exist or is not accessible. and No valid arguments specified” amongst others. This was all done as superuser. I tried all four frontend software packages and all four returned the message that “no scanner is detected”.
How do I install AVASYS “core package”?
Thank you,

The command:

zypper se -si iscan

search for installed programms with iscan in the name and give a detailed overview.


man zypper
zypper help
zypper se -h

So we see, that the core packkage isn´t installed.

Go to the download folder where the iscanxxxxx.rpm is and install it with

zypper in /path/to/the/downloaded/iscanxxxxx.rpm

When you download iscan with a browser, it should normally stored somewhere in your /home/name/ directory.

Please post next time the output and the command in Code-Tags.

You’ll get me to the desired result yet! I downloaded and installed with ‘appear’ from AVASYS core package “iscan-2.28.2-3.ltdl7.x86_64.rpm” once more. Used 'chmod 777 “iscan*” and then used ‘zypper se -si iscan-2.28 … .rpm’ once more with result: Loading repository packages …, Reading installed packages …, No packages found.
Some more specific guidance is needed, please.

I used the download in /tmp/ because the one in the home directory is only 164 bytes long as well as having additional extension of “.desktop”. I’m not familiar with the term “Code-Tags”. Here is the result for 'zypper": ‘zypper in /tmp/iscan-2.28.1-3.ltdl7.x86_64.rpm’ ; Results: Loading repository data …, Reading installed packages…, ‘tmpRPMcache:iscan=’ not found in package names, Trying capabilities. No provider of ‘iscan = 0:2.28.1-3.ltd7’ found. Resolving package dependencies…, Nothing to do.
I think you almost have me there.

RPM 64bit package

RPM 64bit package [libltdl7] (for Fedora 11 or later)

You have to download the 64bit package without ltdl7 in the name and install it with

zypper in /tmp/iscan

as root.

After installation you can see if it is installed with:

zypper se -si iscan



This is the result of using zypper on the AVASYS file ‘iscan-2.28.1-3.x86_64.rpm’:


linux-uo6o:/tmp # zypper install iscan
Loading repository data…
Reading installed packages…
‘iscan’ not found in package names. Trying capabilities.
No provider of ‘iscan’ found.
Resolving package dependencies…

Nothing to do.

I also did zypper on the AVASYS file ‘iscan-2.29.1-3.ltdl7.x86_64.rpm’:

linux-uo6o:/tmp # zypper install iscan
Loading repository data…
Reading installed packages…
‘iscan’ not found in package names. Trying capabilities.
No provider of ‘iscan’ found.
Resolving package dependencies…

Nothing to do.

I included the latter file because either my system has a problem with both files or may be I am not including some option in the ‘zypper’ command. Also the latter file (with the “ltdl7”) is the one recommended for openSUSE 11.1 and >, and also Fedora 11 or >. I see two problems in the zypper install: 1. “iscan not found in the package names”. and 2. “No provider of ‘iscan’ found.” Neither of these do I know how to rectify. Any thoughts about resolving this?
Thank you,

You need to be explicit with the path and filename (of the downloaded file), otherwise zypper will not finde it, and attempt to locate from an online repository instead.

I don´t know, what you are doing.

When I donload a file, it will be stored in my /home/username (/~) Directory.
I have firefox configurated to download and store it in /home/username/Downloads (/~/Downloads) where username is my username.
So I can install it:

stephan@linux64:~> cd Downloads
stephan@linux64:~/Downloads> su
linux64:/home/stephan/Downloads # ls -l
insgesamt 8372
-rw-r--r--  1 stephan users 7557598 31. Dez 13:52 8MBGMSFX.SF2
-rwx------  1 stephan users  163671  6. Jun 22:19
-rw-r--r--  1 stephan users   12344  6. Jun 22:20 collectNWData.txt
-rw-r--r--  1 stephan users  544676 10. Jun 09:09 iscan-2.28.1-3.i386.rpm
-rw-r--r--  1 stephan users   37842 10. Jun 09:09 iscan-data-1.13.0-1.noarch.rpm
-rw-r--r--  1 stephan users   86271 14. Mai 20:16 Zypper-cheat-sheet-1.pdf
-rw-r--r--  1 stephan users   82401 14. Mai 20:16 Zypper-cheat-sheet-2.pdf
linux64:/home/stephan/Downloads # zypper in iscan-2.28.1-3.i386.rpm 
Datei '/repodata/repomd.xml' nicht auf dem Medium '' gefunden.

Abbrechen, wiederholen, ignorieren? [a/w/i/?] (a): i
Fehler beim Abrufen der Metadaten für 'Contrib':
SKIP request: User-requested skipping of a file
Achtung: Repository 'Contrib' wird aufgrund des obigen Fehlers deaktiviert.
Daten des Repositories laden ...
Installierte Pakete lesen ...
'iscan = 0:2.28.1-3' ist bereits installiert.
Kein Aktualisierungskandidat für 'iscan-2.28.1-3.i386'. Die neueste Version ist bereits installiert.
Paketabhängigkeiten auflösen ...

Keine auszuführenden Aktionen.

Its in German and the last means, that iscan-2.28.1-3.i386 is already installed.

Is your OpenSuse a 64-bit System?

uname -a


With your suggestion on the ‘zypper’ command, progress was made. There is still some type of problem as follows:

linux-uo6o:/ # zypper install /tmp/iscan-2.28.1-3.ltdl7.x86_64.rpm
Retrieving repository ‘Updates for openSUSE 12. 12.1-1.4’ metadata [done]
Building repository ‘Updates for openSUSE 12.1 12.1-1.4’ casche [done]
Retrieving repository ‘openSUSE-12.1-Update-Debug’ metadata [done]
Building repository ‘openSUSE-12.1-Update-Debug’ casche [done]
Loading repository data…
Reading installed packages…
tmpRPMcache:iscan=0:2.28.1-3.ltdl7’ not found in package names. Trying capabilities.
No provider of ‘iscan = 0:2.28.1-3.ltdl7’ found.
Resolving package dependencies…

Nothing to do.

I see at least two problems that I do not how to resolve: 1. ‘_tmpRPM…ltdl7’ not found in package names, and 2. No provider of ‘iscan…’ found.
I also tried the scanner with the different scanner software programs with the same result of “No scanner detected”.
We have moved forward, but something is still not correct.
Thank you,

Are you sure the files exist at the /tmp location?

ls- l /tmp |grep iscan

Download to your home directory as Sauerland suggested. Then, become root with

su -

Enter your root password when prompted.

Install iscan-data with

rpm -ivh iscan-data

*If installed already you’ll get a message, and can move on to installing iscan.

Install the iscan package with

rpm ivh iscan

With luck both will install without dependencies.

You should now be able to scan with the iscan app.

Deano and Sauerland,

After a few days hiatus from the computer, SUCCESS was achieved. I reloaded the AVASYS software, and installed with the RPM command. The data package was already installed and the core package (32-bit) was successfully installed. The (64-bit) core package had dependency problems so I tried the (32-bit) package and it was successful.

Thank you very much to you two for your patients with me. It was a learning experience with zypper, rpm, and code-tags. My wife also thanks you.


The (64-bit) core package had dependency problems so I tried the (32-bit) package and it was successful.

For this you should post the output of

uname -a

Then you (we) can see if it is a 32- or 64-bit Installation.

You made hard work of this, but hopefully you’ve learned a bit in the process. Anyway, I’m glad you’ve finished up with a working scanner.


Results on the AMD Athlon ™II X3 455 Processor is:

linux-uo6o:~ # uname -a
Linux linux-uo6o 3.1.10-1.9-desktop #1 SMP PREEMPT Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) i686 athlon i386 GNU/Linux

I shouldn’t be presumptuous, but with the “i386” in the result line I interpret this to mean that this is a 32-bit installation. Is this correct understanding?

Thank you,

Yes its a 32-bit Installation.

You can´t install any x86_64.rpm.