Epson Perfection 1260 does not work in 11.2

In OpenSuse 10.3 I was able to use my Epson scanner using the plustek-driver.

After upgrade to 11.2 I can not use it anymore.

sane-find-scanner recognized the scanner
found USB scanner (vendor=0x04b8 [EPSON], product=0x011d [EPSON Scanner], chip=LM9832/3) at libusb:006:002

scanimage -L does not see it

Increasing SANE_PLUSTEK_DEBUG gives

[plustek] next device is a USB device (autodetection)
[plustek] next device is an USB device
[plustek] ><
[plustek] >#<
[plustek] ># options for the previous USB entry<
[plustek] >#<
[plustek] ># switch lamp off after xxx secs, 0 disables the
… a lot more …
[plustek] gray Gamma : 1.00
[plustek] ---------------------
[plustek] drvopen()
[plustek] usbDev_open(/dev/usbscanner,)
[plustek] open failed: -1
[plustek] sane_get_devices (0xbfd7a618, 0)

Yast2 sees my scanner (libusb:006:002)
I seem to be able to add it. I can select the correct scanner (plustek-driver) but it stays Not Configured

I installed iscan-proprietary-drivers-

BTW: 10.3 was a 64-bits installation, now I use the 32-bit version

Strange, because I have the same scanner model and with openSUSE 11.2 32bit it works out of the box, as always.

The same scanner also works on my wife’s openSUSE-11.2 (32-bit). It works fine.

There was some “iscan” software that had to be installed … I can’t remember the exact packages. She has per PC running XP right now so I can’t check. Possible more than just iscan-proprietary-drivers (there is also iscan-firmware, and iscan-free … I don’t know which ones until she lets me at her PC. She has to work tomorrow (Christmas) morning, so maybe I can look then).

sane-find-scanner recognized the scanner

scanimage -L does not see it

I believe this is a permissions issue; I had this with all previous versions of Suse;

Try: in a terminal


If the scanner is for example attached to

Bus 004 Device 002

what worked on previous editions was to become root

chmod a+rw /dev/bus/usb/004/002

where you copy the bus and device number into the command line …

if you can now scan, the device is owned by root; I tried to change ownership but never succeeded as a permanent fix

I resorted to using the above; (and/or another distro whilst using that)

see also here

It can not be a privilege issue as I tried everything as root

Some bad news … my wife gave away our Epson Perfection 1260 scanner on Christmas Eve to a friend. The scanner works great, but our new HP Photosmart Premium C309a multifunction printer has a higher quality scanner on our home LAN and my wife could not see the point in having two scanners.

So my apologies, but I can not provide support based on my wife having the same scanner as that is no longer the case.

But I did log on to my wife’s PC and I noted she had the follow rpms installed to work with that Epson scanner:

  • iscan-firmware
  • yast2-scanner
  • iscan-proprietary-drivers
  • sane-backends-autoconfig
  • xsane
  • sane-backends
  • libksane0

she has no other “iscan” apps installed. Note her PC is a 32-bit and hence is running a 32-bit openSUSE-11.2.

Apologies, but that is the best that I can do on this.

Good Luck !

I installed the same RPM’s.
Does not work

Did you restart after any updates to ensure the appropriate modules were loaded? Also possibly cycle the power on your scanner in case its ‘hung’. Sometimes for a scanner it is necessary to add the user to group “lp” all I did not find that necessary for my wife’s scanner.

… anyway, some one else will need to chime in here as I no longer have access to this make scanner, which, by the way, worked perfectly on my wife’s 32-bit openSUSE-11.2 with KDE-4.3.4.

Are you certain thats the correct driver? Often in Linux if you install multiple drivers for a single device, that will break any access one might want to the device.

In addition to the iscan proprietary drivers package, you also need the iscan package available here:


This package seems to have been omitted from the non-oss repository, yet is not a valid bug: