Epson Artisan 810 driver

Ubuntu recognizes my Epson All in one, without a hitch, but am having a real time of it getting Suse 12.1 to find it.:\

Don’t see and edit function; forgot to say it’s wireless.

You haven’t provided much detail about what you have tried (re configuration), or what is not working for you, so we’re left to guess a bit.

  1. Did you try configuring via YaST or the CUPS http interface?

  2. Plug you printer in and open a terminal. Become root with the ‘su -’ command. Enter your root password when prompted.


What is reported (if anything)?

If not, then take a look at


and post output here.

  1. If your printer is enunciated, then proceed to firing up your favorite browser, and point it at


Click on ‘Add Printer’ and enter your root credentials when prompted. Follow the prompts given. You should see a local usb option available to select. When finished, select your printer (in CUPS web interface) >> Maintenance >> Print Test Page

Don’t see and edit function; forgot to say it’s wireless.

Ah… that makes a big difference. I was typing my initial reply as you typed this :slight_smile:

Do you know its IP address? Can you ping it successfully? You’ll only be able to proceed if the networking configuration is correct.

This may be useful:

[SOLVED] Epson Artisan 810 Printer Setup](;wap2)