Epson AcuLaser C900 vs CUPS

i’ve server (with openSUSE 10.3 on board, without X, just console, cups and nfs), and there are 2 printers (AcuLaser C900 & HP1018) connected to server. i can print from server any file i want.
also i’ve some clients with openSUSE 10.3, 11 or SLED 10. from all clients i can print on HP1018 without any problems.
but there are 2 clients that don’t print on epson, but other do!
first is machine with openSUSE 10.3 (however near i’ve some clients with 10.3 that do print!), here i’ve got error in CUPS “/usr/lib/cups/backend/ipp failed”
i’ve got some days earlier similar mistake but it was wrong printer URI. but in this case URI is absolutely right.
but on hp1018 this machine can print. very strange.

cups error log
I [17/Jul/2008:15:57:02 +0400] commptr=""
I [17/Jul/2008:15:57:02 +0400] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5711)
I [17/Jul/2008:15:57:06 +0400] commptr="?op=print-test-page"
I [17/Jul/2008:15:57:06 +0400] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=5712)
I [17/Jul/2008:15:57:06 +0400] Adding start banner page "none" to job 2122.
I [17/Jul/2008:15:57:06 +0400] Adding end banner page "none" to job 2122.
I [17/Jul/2008:15:57:06 +0400] Job 2122 queued on "alc900" by "root".
I [17/Jul/2008:15:57:06 +0400] Started filter /usr/lib/cups/filter/pstops (PID 5713) for job 2122.
I [17/Jul/2008:15:57:06 +0400] Started filter /usr/lib/cups/filter/foomatic-rip (PID 5714) for job 2122.
I [17/Jul/2008:15:57:06 +0400] Started backend /usr/lib/cups/backend/ipp (PID 5715) for job 2122.
E [17/Jul/2008:15:57:07 +0400] PID 5714 (/usr/lib/cups/filter/foomatic-rip) stopped with status 1!
I [17/Jul/2008:15:57:07 +0400] Hint: Try setting the LogLevel to "debug" to find out more.
E [17/Jul/2008:15:57:07 +0400] PID 5715 (/usr/lib/cups/backend/ipp) stopped with status 1!
I [17/Jul/2008:15:57:07 +0400] Hint: Try setting the LogLevel to "debug" to find out more.
I [17/Jul/2008:15:57:07 +0400] [Job 2122] Backend returned status 1 (failed)
I [17/Jul/2008:15:57:07 +0400] Saving printers.conf...
I [17/Jul/2008:15:57:08 +0400] commptr=""

and second machine is openSUSE 11. here is next mistake “/usr/lib/cups/filter/foomatic-rip failed”
foomatic-filter installed.
the best advice on this problem i’ve seen is:

try other mysterious mumbo-jumbo that magically fixes printing…

when i try to print from these machines i’ve got errors ant jobs stopped.

i tried to use cups config from working stations, but it was unsuccesfull, also i tried to reinstall cups, foomatic, gutenprint etc and it was unsuccesfull too.

any ideas how to fix this problem?

ps and just another one question
i haven’t X on server, but i need utilite to see cartridge condition on epson. i found one but it is on gtk. so how i can use it without installing X on server?