Epson 2580 scanner

Xsane doesn’t find my scanner.

Has anyone else had luck with theirs on SUSE 11.1 64 bit ?

for epson scanner go to :


and by the way…
use iscan with epson…

Thank you Roger.

The AVASYS website just ‘hangs’ - never responds… and tried ISCAN with same results as XSANE.

Turns out there is no 64 bit driver for this scanner even for Vista at the Epson site.

It may be time to buy a newer scanner. In the past 5 or 6 years since this one was purchased, costs have come down and resolutions have improved.

I tried the avasys site and it’s working fine.

On the 64bit question, the older scanners don’t seem to have epson 64bit drivers available. However you can still use your scanner (should you wish) by using the iscan program (downloadable from the suse repositories). You will need to add the 32bit compatible libs, and it will work fine.

You can also make use of the xsane 32bit packages. You will need to copy these from a 32bit system and possibly add a library or two.

Alternatively -

You should possibly have the choice of using the snapscan drivers to drive the epson. You need to edit /etc/sane.d/dll.conf and uncomment the scanpscan line. Restart the scanner and xsane/scanimage etc will detect the scanner. still hangs. Not sure why you can get to it and not me.

Tried iscan and several others yesterday afternoon. Tried iscan again just now and it cannot see my scanner. Tried scanner config after uncommenting snapscan line, still cannot see the scanner. Not sure what 32 bit libs you are referring to - the software install doesn’t show anything with ‘32 bit’ in it’s title… related to ISCAN unless that of course is implied.

Is Yast to be used to configure the scanner ? To assign a driver ?

Perhaps I need to find a procedure for beginners.

i dont know why you cant access their site on the net.
try this address and click for english (located at the top of the page) :
dont give up…

thanks for your assistance.

Not give up - but perhaps regroup and try a different angle. Seems to me some years ago I transferred the .dll from ‘another system’ and got it working on Ubuntu.

Of course - I’d much rather have a faster unit with better resolution… and they are SO cheap these days. I have a huge project waiting of scanning a sizeable collection of photos that are perhaps 25 - 30 years old and a faster unit would be a good thing.

Perhaps if I get tired enough of ‘hammering’ at this I’ll wander down to the local ‘big box’ store later today…

OK - I have the esfw41.bin driver but have a couple of questions: will it work with iscan or do I have to use sane - and where exactly does this module get placed ?

make shure you have CUPS installed (Common unix printing system) check under Yast/software (assuming you are running kde)

then try this site: http://localhost:631/admin
good luck

It looks like your scanner or MFD has basic support according to this page.

SANE: Supported Devices

I have a epson perfection 2450 and if I use scanimage -L it also fails but if I use the -d epson backend I am able to scan the image with the cli. I would try the following lines listed below, make sure you have sane installed, as well as the backend.

scanimage -d epson -L

That should be similar to scanimage -L, then use the -h option to see what command line options to use. What works well for me is this option for documents.

scanimage -d epson --mode gray --depth 12 --resolution 350 > epson_image.pnm

Then I use openoffice to import the file as a picture and export it as pdf this works for most documents. Now my model has a firewire port which I use, and if I remember correctly some bugs are know for epson scanners using usb, but cli should work but xsane or gimp will complain. Since the epson backend is not supported I would suggest if you can’t find a resolution then you could always buy a solution. I would give VueScan a shot if you can’t get sane working has a lot of reviews and supports your model. Also if you get a new scanner it will most likely support it as well.

VueScan Scanner Software

They also make a good windows version if that is any interest to you, at least they have a Linux solution which should work. Oh don’t forget if your new to the scanning you might want spend some time reading up on a good site like the one below.

Scanning Basics 101 - All about digital images

They have a lot of good material, and really a good resource for scanning tips.

i am sorry…just gave you the page for the printer, not the scanner… so disregard please.
as for the directory, look into usr/share
just confirm that in the Avasys home page you did not find the proper information for the Epson scanner?

You lost me - what’s this got to do with my scanner ?

Thanks to everyone that provided replies; I have upgraded to a new scanner. Have not tried it yet on SUSE but am sure it will work.