Epiphany Freezing on certain websites for 30 seconds, once per session.

With plugins disabled, epiphany freezes on a handful of websites (such as Google+) but not others for 15-20 seconds. After that, it runs smoothly and never freezes again in the same session. With the plugins enabled, Epiphany freezes on even more websites (still not all the websites) for 20-30 seconds. This happens only once per session as well.
Here’s a list of installed plugins: SUSE Paste

Does the freeze occurs when watching videos ?

The freeze occurs when the first poblematic page is still loading. Once the page loads, epiphany never freezes again so no it doesn’t freeze when watching videos.

With the plugins enabled, it also freezes on extensions.gnome.org

Try launching epiphany from terminal/konsole. Do you notice any errors when the freeze happens ?

No errors show up when the freeze happens. However, this error shows up randomly:

(epiphany:8430): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 1


Do you have openJDK installed ?
On my system epiphany is invoking openJDK whenever there is flash content on a website
It is also invoking openJDK on extensions.gnome.org


$epiphany 
java version "1.7.0_17"
OpenJDK Runtime Environment (IcedTea7 2.3.8) (suse-8.8.1-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

Yes, he has. IcedTea is the java browserplugin from openJDK.

On my system epiphany is invoking openJDK whenever there is **flash **content on a website

I don’t think so.
It would invoke openJDK whenever there is java content on a website.
If there is flash content, it would invoke flashplayer…

But maybe some pages use a java applet instead of flash, when the browser doesn’t support flash (i.e. no flash plugin installed)

Can’t help with the original problem though. Maybe epiphany freezes while it is loading the java/flash plugin. (could happen esp. if you are low on ram).
It could also be related to the iTunes plugin (but this is a wild guess).

But then, you said it also happens with all plugins disabled?
So maybe it’s about javascript? Could you try to disable that? (don’t know how you would do that in epiphany, though)

The problem can’t possibly be due to shortage of RAM since Firefox works almost flawlessly. I’ve got 4 GiB of RAM. Also, I don’t have the faintest idea on how to disable Javascript. Epiphany freezing without the plugins can be due to a different problem as well. With the plugins enabled, it freezes on extensions.gnome.org (so that could be due to the gnome integration plugin since the website doesn’t have any videos. It also freezes on youtube.com but I can’t see why it would use the gnome integration plugin on that website, so it’s probably due to flash or the itunes plugin (it doesn’t freeze on youtube with the plugins enabled). Same thing with Steampowered.com. My.jolidrive.com with doesn’t use neither flash nor the gnome integration plguin also freezes. The puzzling part is, once it freezes on ONE of these websites, it never freezes again during the same session. The only website I found it to freeze on without the plugins is Google+. In short: It is probably due to a plugin that is used on multiple websites, probably isn’t flash or gnome integration, but God knows which.

Ah, I don’t think you are short on RAM then…
But since it only happens once per session, it could be because epiphany is loading something (a plugin presumably).

Also, I don’t have the faintest idea on how to disable Javascript.

From https://help.gnome.org/users/epiphany/stable/ephy-customize.html.en:

10.1.3. Privacy Preferences
Epiphany allows you to configure a number of features which allow you to restrict what web pages can do:

  •                                 Select Allow popup windows if you want web pages                    to be able to launch content in new windows automatically. 
    
  •                                 Select Enable Java to allow pages to load Java                    applets - programs which run inside web pages. 
    
  •                                 Select Enable JavaScript to give web pages the                   capability to use the more advanced programming techniques of the                    JavaScript language. 
    
                             Disabling these features may cause some pages to display incorrectly or                 cause some loss of functionility. For Java to work, you need to install                  the Java plugin.               

You could also try to disable java…
Oh, and you didn’t specify your epiphany version. Apparently they removed that option in 3.7…:stuck_out_tongue:
https://trisquel.info/de/forum/epiphany-37-removes-option-disable-js

I’m using Epiphany 3.8. But now that you mention it, I remember having a similar problem in 3.6 due to the NSpluginwrapper. The terminal output would clearly show that it was NSpluginwrapper that’s freezing epiphany back then. The strange thing was that the pluginwrappper was causing problems due to not being installed. Once I installed it, Firefox started causing problems and epiphany’s problems persisted (but gave different error messages) so I removed it but as far as I know epiphany 3.8 doesn’t need the plugin wrapper anymore. Could this be the source of the problem? Also, I’d rather not disable Java since then I’d have to disable it from Firefox too.

NSpluginwrapper mostly was there for being able to use 32bit browser plugins on 64bit systems (without having to install a 32bit browser). Since this was mainly about the flash plugin, which now *is *available as 64bit version, you shouldn’t need it anymore… It was buggy as hell anyway.

About java: don’t know really. Do you still have that option to disable it in epiphany, or has this been removed as well? I only mentioned it, because it could be disabled easily in 3.6, so it would have been easy to try…
(for some reasons I would mostly suspect that iTunes plugin anyway, but the flash and java plugins do take a long time to load on my system…)

But sorry to say, I think I can’t help you really, because I haven’t had a look at epiphany for years. I’m mostly using konqueror…:wink:

i can understand freeze everytime but i cannot understand free once per session concept :expressionless:

It could be that epiphany takes a while to load a certain plugin (or plugins). Once it loads it (them), it can run without further hiccups.

Well, my thought was it freezes while loading a plugin. When the plugin is loaded it stays in RAM, so there are no freezes anymore (because no loading is necessary)…

@op- You seem to be using GNOME 3.8 on openSUSE 12.3 . 3.8 libs may be be fully supported in 12.3. Try switching to epiphany to 3.6.1 and check for any performance difference. DONT downgrade if YaST and zypper try to change too many dependencies.

I’m using Tumbleweed not 12.3. I had Epiphany 3.6.2 before and it very similar problems. With the plugins enabled, it would freeze and then crash. It would work well without the plugins tho. The terminal output would display several errors related to the NSpluginwrapper as mentioned earlier. Also, downgrading from 3.8 to 3.6 would require me to downgrade my entire GNOME desktop.

Well, I just tried Epiphany 3.6.1 and I didn’t experience those freezes. (although gnome.extensions.org did take a bit long to load…)

I compared your plugins with mine and the only ones you are using that I don’t have, are the iTunes and the PackageKit plugin.
So maybe you could try to deinstall those 2 and see if it helps… (Or rename them so that they can’t be found. They should be in the folder /usr/share/browser-plugins)

Thee wasn’t a folder called “browser-plugins” in the /usr/share/ folder, but whereis revealed that there is one in the usr/libs folder. Playing with the plugins there didn’t help. But that gave me an idea, I knew of a folder called plugins in /home/.mozilla . I deleted that since it had replicated and out of date plugins and epiphany now freezes for a mere 1-2 seconds instead of 30. It’s a big improvement and you’re mostly to thank for. I’ll try to eradicate the freeze completely but even if I couldn’t, I think it’s bearable now :slight_smile:

Oh sorry, that was a typo…

Glad to here that it’s better now, though. :slight_smile: