Enlightenment login entry issue

I use GNOME environment, but wanted to try installing Enlightenment DE by doing:

zypper in --no-recommends patterns-openSUSE-enlightenment

Seemingly worked, but in the gear icon right by the login button used to choose DE I noticed Enlightenment entry is twice. Both entries do exactly the same, so it must be kind of a bug…

Any ideas? How can it be solved and prevented?

I see the same thing.

Recommend you submit a bug to https://bugzilla.opensuse.org


That is interesting, sounds like a gdm bug. But just to confirm, you only have 1 enlightenment entry in /usr/share/xsessions/ and no entry in /usr/share/wayland-session/ (the latter probably shouldn’t exist on Leap 42.X

I don’t see the original problem as described by the @OP anymore.

So, it looks like the problem was “modified” sometime(see below. my guess is not actually fixed).

I’ve been running lightdm.
Enlightenment was installed as the original Desktop on this machine,


zypper se -it pattern
Loading repository data...
Reading installed packages...

Loading repository data...
Reading installed packages...

S  | Name          | Summary                    | Type   
i  | apparmor      | AppArmor                   | pattern
i  | base          | Base System                | pattern
i  | enhanced_base | Enhanced Base System       | pattern
i+ | enlightenment | Enlightment                | pattern
i  | fonts         | Fonts                      | pattern
i  | imaging       | Graphics                   | pattern
i  | multimedia    | Multimedia                 | pattern
i  | sw_management | Software Management        | pattern
i  | x11           | X Window System            | pattern
i  | yast2_basis   | YaST System Administration | pattern

ls  /usr/share/xsessions/


As you say, /usr/share/wayland-session/ does not exist.
I find it interesting that there is now a gnome desktop option but no gnome Desktop or subsystems are installed (see my installed patterns list). So, it looks like perhaps someone renamed the second Enlightenment Desktop option to Gnome Desktop(I don’t see that as a real fix to whatever caused the problem in the first place. Would be interesting to see what would have happened if I really did have Gnome installed).