Enlightenment (DR-16 and DR-17)

hi,

you can try this one:

  1. first you need to configure your wireless card with YAST (to ensure that card is supported). then
  2. open your terminal (xterm, urxvt, etc.) and type:

sudo zypper in wicd
sudo service wicd start
wicd-client -n

and set your wireless network with ‘wicd’.

regards,
sda

repos are updated. please, use this one:

Enlightenment-cvs-core-metapackage

to get the latest stable Enlightenment. the ‘SOAD’ repo soon will be closed.

changelog:

  1. use ‘wicd’ instead of ‘exalt’ for your network configuration

  2. make the backup of your ~/.e/ before the update and erase it ( rm -rf ~/.e ). there’re a lot of improvements in E and this step is optional, but highly recommended.

  3. to restore all your setings just copy the content of a ’ ~/.e/e/config/ ’ from the backup to the destination. then use ‘Profile’ management from ‘Settings’ panel to apply the changes.

as usual you’re welcome to email me or post here any issues.

regards,
sda

Hi, at first of all I want to say that I’m grateful for the hard work that you’ve been doing promoting E :), I wanted to meet it long time ago, but I didn’t want compile it by myself, two days ago I found it on webpin (my box runs opensuse 11) and I just install it, it’s like people say, amazing.

It was pretty nice, but when I tried setting Entrance to default graphic login (Enlightenment for openSUSE - openSUSE), it didn’t work, it keeps showing this:

Becoming entranced: entrance/etc/init.d/entrance: line 35: pam_getenv: command not found

So I type:

# /etc/init.d/xdm start

And I can use kdm, where I select E.

I google the pam_getenv issue, and I found this:

Enlightenment - Enlightenment LiveCD

Only one suggestion left: please, wait a bit till the new ‘release’.

That is a LiveCd’s release, so I wonder, what should I do to fix this if I don’t want install SOAD?

I also have installed entrance alone (because yast remove E17, when I choose it), from the same repository (Index of /repositories/home:/dmitry_serpokryl:/Enlightenment-cvs-core-metapackage/openSUSE_11.0) and it works! :O, obviously I don’t want to use entrance if I can’t join E, then I though it was an init script error, so I compared both scripts but they’re equals :|.

So I’m where I start.

Hope you can give me some hints about this.

Cheers

ok. it’s easy. you can install ‘Enlightenment_DR17-cvs-core-metapackage’ and it already contain ‘entrance’ or you can select ‘E17’ and ‘entrance’ (also recommend ‘e_modules’). ‘entrance’ is a kind of a unique ‘login manager’ and it require some attention. below is a link to the short instruction how to enable ‘entrance’ and disable any existing login manager.

Enlightenment (DR-16 and DR-17) - openSUSE Forums

also you can custonize ‘entrance’ via ‘entrance_edit’ command-line utility (require ‘root’ priviledges).

Thanks for your reply, I changed ‘Enlightenment_DR17-cvs-core-metapackage’ for ‘E17’+‘e_modules’+‘entrance’ and it ran !

But the pam message still is there, nevermind. Now the only little problem I’ve is that when I log in Kde4 or E, Knetworkmanager doesn’t work and I can’t shutdown directly, I took some screeshots

Using kdm:

http://imagefruity.com/images/a3ke98djiqx6o5ixbuxu_thumb.jpg](http://imagefruity.com/viewer.php?file=a3ke98djiqx6o5ixbuxu.jpg)
http://imagefruity.com/images/k6tbess8ygard8mdzqx_thumb.jpg](http://imagefruity.com/viewer.php?file=k6tbess8ygard8mdzqx.jpg)

Using entrance:

http://imagefruity.com/images/9iqz5j36f2kjfd45k34h_thumb.jpg](http://imagefruity.com/viewer.php?file=9iqz5j36f2kjfd45k34h.jpg)
http://imagefruity.com/images/ukujpyxnntd2wqzkreti_thumb.jpg](http://imagefruity.com/viewer.php?file=ukujpyxnntd2wqzkreti.jpg)

Thx in advance.

>> But the pam message still is there

it’s o’k and doesn’t matter much.

>> Now the only little problem I’ve is that when I log in Kde4 or E, Knetworkmanager doesn’t work and I can’t shutdown directly, I took some screeshots.

let’s first discuss E. you should be able to shutdown from menu (directly). if not - just edit the file (as ‘root’):

/etc/enlightenment/sysactions.conf

there you can set your custom commands for hibernate, sleep, reboot, shutdown and other system actions. syntax is straight forward and well explained, no issues should occur (post if any :)).

also it’s recommended to use ‘wicd’ instead of ‘NM’ because it can work without systray and allow direct scripting configuration for your network interfaces (works here just fine and available in the same repo of course. after installation service should be started manually or PC should be rebooted).


here goes KDE part. i’m not an expert in KDE so please beg your pardon if something is not as i think.

  1. KDE is quite complex and settings are… hmm… let’s say ‘awesome’. it has adopted XDG specs (at least kde4) and starts any… ‘.desktop’ file ‘Exec=’ entry from ‘XDG STARTUP’ - i.e. - /usr/share/autostart/ (according to the $XDG* variables)- without user notice (you need ‘root’ privileges to clean that trash). moreover, settings are so awesome that a small ‘tick’ somewhere inside settings of one software could lead to the autostart of another (those, who lazy to ‘click through the forest of options’ to guess wtf pulled the trigger this time, just remove boring package).

this time it’s clear that replacement of ‘kdm’ to the ‘entrance’ resulted in not started ‘NM’ daemon (guess that something else also could be missed, may be for good). imho - ‘NM daemon’ is started via ‘dbus’ and integrated with global system settings via YaST. only can advise to check YaST’s network settings, check that ‘dbus’ service is active (on) and running. if doesn’t help - nevermind (yep, exercise is funny so i just vote for ‘wicd’). you can login via ‘kdm’, install ‘htop’, open console, start ‘htop’ and see the exact command which starts ‘NM daemon’. the rest is easy - add this command to ’ /etc/profile.local ’ or to your ’ ~/.profile ’ and allow in YaST user manipulations with network interfaces via ‘NM’. (though actually it’d be better to get wtf this daemon is not started via ‘dbus’ with ‘entrance’ and why the hell ‘KNM’ see nothing instead of running daemon). another ‘bright’ idea is to look inside ‘/usr/share/autostart/’ and check launch of which ‘.desktop’ file will restore ‘KNM’.

  1. the case with ‘shutdown’ also a bit tricky. as we see KDE wants ‘kdm’ (may be it can even operate with ‘gdm’ - who knows…). only can advise set ‘sudo’ properly and add/create keyboard shortcuts to turn PC off (restart, etc.). shortcuts could be defined somewhere inside KDE settings and commands could look like this:

a) shutdown

 
sudo /sbin/shutdown now

b1) reboot

 
sudo /sbin/reboot

b2) reboot

 
sudo /sbin/shutdown -r now

etc. also you can prepare this commands in a separate files placed inside ’ $HOME/bin ’ and (hope you can) put them into KDE menu.

sorry, i’m not a KDE expert (and never will…)

Hi

let’s first discuss E. you should be able to shutdown from menu (directly). if not - just edit the file (as ‘root’):

Yep, as you said, I’m able to shutdown directly on E :), but the /etc/enlightenment/sysactions.conf file is interesting anyway.

About KNM I must say that now it works but only with root privileges, NM is working fine, it always did, sry for not mention it.

As later I fell in count, some settings were restored to default ones, wth!, I didn’t have sound, my language settings changed too, and so on.

So, I re-added me to sound, network, and others groups, restored others settings and everything was ok, but not knetworkmanager till I ran it with root privilegies.

I found this thread:

knetworkmanager on normal user - openSUSE Forums

And looks like this knetworkmanager issue is ‘normal’, I’m gonna wait a while to update to latest kde4 (that will fix the problem I guess), so what I’m gonna do now is use entrance and run knetworkmanager with root privileges (I tried wicd too, but it didn’t like me).

About the logout problem I added some keyboard shortcuts just as you said me and it goes pretty fine.

Thx for your time and may the E be with you :wink:

ecomorph on opensuse 11.1

hi. I have the latest enlightenment DR17 one click ymp package and updates and have installed ecomporph as per the instructions for 11.0 on the wiki. Ecomorph appearas as a login option and ecsm brings up a compiz like ccsm screen but none of the effects work. Compiz under kde3 works on the same machine so I don’t think it’s an X configuration issue. Are there any specific instructions available for 11.1 or anything I should do whilst inside e-ecomorph?

Thanks, Steve.

hi Steve,

for 11.1 the actions are almost the same. just to check you may see:

sudo zypper ar “http://download.opensuse.org/repositories/home:/dmitry_serpokryl:/Enlightenment-cvs-core-metapackage/openSUSE_11.1/” Enlightenment

sudo zypper ref

sudo zypper in ecomorph ecomp libecompconfig ecompconfig-python ecsm

then we may check if E17 is the latest one:

sudo zypper in E17 e_modules

and the last thing is the proper adjustment of your “/opt/ecomorph/bin/ecomorph.sh” launcher. what video card do you have on a PC with “Ecomorph”?

Hi Dimitry

I have an ati card one one box and an nvidia on another.

Thanks, Steve

This doesn’t look right:

sudo zypper in E17 e_modules
Loading repository data…
Reading installed packages…
‘e_modules’ is already installed.
Resolving package dependencies…

The following NEW packages are going to be installed:
E17 libecore0 libedbus0 libedje0 libeet1 libefreet0 libeina0 libembryo0 libesmart0
libevas0 libexml0

The following package is going to be REMOVED:
Enlightenment_DR17-cvs-core-metapackage

Overall download size: 4.4 M. After the operation, 12.5 M will be freed.
Continue? [Y/n/p/?]:

hi steve-ss!

my deepest apologizes for such a huge delay in response. was out of internet for a while. let me just start from the beginning.

  1. i updated Ecomorph wiki page:

Ecomorph

and hope that now you can manage all your issues easily.

  1. regarding the removal of “Enlightenment_DR17-cvs-core-metapackage” - everything is correct. “Enlightenment_DR17-cvs-core-metapackage” is made only if you just wish to get familiar with this Desktop Shell. It already contain all “e_modules” and other stuff for a proper work. But if you are interested and with to extend the list of EFL apps on your PC, most likely that the package will be substituted by a separate ones (that’s exactly what you see) - “E17”, “e_modules”, etc. If you type:

sudo zypper if Enlightenment_DR17-cvs-core-metapackage

then a long description will explain in details which packages are included into the “huge” core-metapackage. They’re all share the same source code and the case is done only for a convenience - you install a single package and doesn’t care about the rest.

Please report here in case of any difficulties.

Thanks,
regards

Hi Dmitry,

After the updates I received on Monday, entrance seems to have stopped working on my system.

The message I get in the /var/log/messages is :
entranced: X server failed: No such file or directory

Trying strace entranced I see
open("/root/.e/config.eet", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/ecore/system.eet", O_RDONLY) = -1 ENOENT (No such file or directory)

I’m running x64.
Any help would be appreciated.

Thx

The’re several “reasons” why “Entrance” could stop working properly. Some are pretty common, others are valid only in theory. Entrance is a pretty straight-forward tool without frills. Below is a brief “review”:

  1. you download and install entrance without dependencies - not the case if OBS repos are used (but it could happen though that “repo” is updated step-by-step and new EFL core could not match with the “old” “Entrance” - dunno if it ever possible, but just in theory - who knows…)

  2. any update of “xorg-x11” package turns “on” the “native” openSuSE login-manager solution (via YaST/xdm script) and break the launch of entrance. the cure is:

  • reboot and login at the 3-rd init-level (without X subsystem). it’s pretty easy. after reboot you’ll see a “gfxboot” grub menu. choose the line with your system/kernel and note in the bottom of the screen some parameters. press SPACE+“init”+SPACE+“3” (you’ll add a “init 3” to the end of the kernel boot parameters). at the command prompt login as ‘root’. type:

(check what’s going on)
> chkconfig -l | grep -i dm
earlyxdm 0:off 1:off 2:off 3:off 4:off 5:off 6:off
gdm 0:off 1:off 2:off 3:off 4:off 5:off 6:off
xdm 0:off 1:off 2:off 3:off 4:off 5:off 6:off

(turn’em all “off” as it shown above)
> chkconfig earlyxdm off
> chkconfig gdm off
> chkconfig xdm off

(turn “on”/check the “entrance”)
> chkconfig entrance on

(continue normal “boot”)
> init 5

  1. if you’ve installed ATI/NVIDIA drivers from source (not via zypper in DRIVER-PACKEGE) then updates of Mesa/Xorg will break “libGL.so” - reinstall drivers.

  2. check that all “Entrance” parameters are valid (they are managed from command-line as ‘root’ via “/usr/bin/entrance_edit” ). the defaults are below:


# entrance_edit
Entrance Daemon Settings
  attempts = 5
  xserver = "/usr/bin/X -quiet -br -nolisten tcp vt7"
Entrance Client Settings
  xsession = "/etc/X11/xdm/Xsession"
  auth = 1
  engine = 0
  reboot = 1
  halt = 1
  theme = "default.edj"
  background = ""
  pointer = "/usr/share/entrance/images/pointer.png"
  greeting-before = "Welcome to"
  greeting-after = ""
  date-format = "%A %B %e, %Y"
  time-format = "%l:%M:%S %p"
  autologin-mode = 0
  autologin-user = ""
  presel-mode = 1
  presel-prevuser = "USER"
  user-remember = 1
  user-remember-count = 5
  user-count = 1
  session-count = 2
  default-session = "default"
  default-session-title = "Default"
  default-session-icon = "default.png"

the common way to get if things are o’k is to login into the 3-rd init-level as ‘root’ and launch “Entrance” manually:

/usr/sbin/entranced

(all errors will be on screen if it fails)

hope it helps.

Dmitry Hi,

It did help.
The problem was here:
xserver = “/usr/X11R6/X -quiet -nolisten tcp vt7”
which did not exist so I changed it to

xserver = “/usr/bin/X -quiet -nolisten tcp vt7”
and now it is fine.

Could you also help me with these queries:
Since using the x64 I don’t seem to be able to change when the battery module warns about low battery. Could it be that the module is not up to date for x64?
Also when I lock the screen using the enlightenment lock, I cannot then unlock using my user password. Where can I set the password for the screen lock?

Excellent work btw for the live cd and the repo. Thanks a million for doing this :slight_smile:

ok, please note that you can add any “X-server side” parameters here also. example:

/usr/bin/entrance_edit -xserver="/usr/bin/X -quiet -nolisten tcp vt7 -dpi 96"

  1. check the “Settings” of the “Battery” module:

http://thumbnails7.imagebam.com/4992/373fad49912761.gif](http://www.imagebam.com/image/373fad49912761)

  1. it’s a known “issue” and i’d recommend to read the “Welcome.pdf”:
    http://sda.scwlab.com/Welcome.pdf

the last page contain some “hints” and one of them is about “screenlock” (it was discussed here some time ago).

thanks for your kind regards!
have fun!

Dmitry, let me take the oppportunity to thank you for the wonderful job you’re doing. I’ve already made some people very happy (they thought they needed new computers, but 11.1 with Enlightenment does run beautifully)

Unfortunately it appears to be some older version maybe.

http://www.split.gr/bat.jpg


Name: e_modules
Version: svn_20090914_r42487-3.3
Arch: x86_64
Vendor: openSUSE Build Service
Installed: Yes
Status: up-to-date
Installed Size: 7.2 M

>> Unfortunately it appears to be some older version maybe.

no :), just swith to the “system” default theme or to the “2be” theme, set the settings properly and then use the “Detour” :slight_smile:

That did the trick :slight_smile:

Many thanks again :slight_smile: