Enlightenment (DR-16 and DR-17)


just didn’t thought that so many people would rush to get the iso…

And in general - all acknowledgments go to the great Enlightenment Development Team:

Enlightenment Contact


Here is an instruction/how-to for proper installation of ‘Enlightenment LiveCD’ to other media (harddisks or flash/USB sticks):

Instruction for Enlightenment-LiveCD installation on harddisk and/or flash/USB_stick. How-to.

But if you like my LiveCD (http://sda.scwlab.com/), then just add missing repositories for your OpenSUSE and enjoy the same apps. It’s easy!

I just installed the e17 packages from your repo; let me say a big thank you! I used to compile this from CVS manually, this is a far easier process :slight_smile:

I have one pretty major problem though that’s preventing me from switching from KDE4: screen locking doesn’t work. I type in my password and hit enter, and it fails to let me back in. I did some googling, which turned up this mail from two years ago:

‘Re: [E-devel] e17 screen lock’ - MARC](http://marc.info/?l=enlightenment-devel&m=116631228029608&w=2)

It’s exactly the problem I’m having, and it does seem to be Suse specific. Can anyone else replicate this, and is there some workaround?

yep, 100% headshot. it works eventually, but not always unfortunately. here’s a way to avoid it:

  1. install the package ‘xlockmore’
  2. adjust your screenlock settings to use external locking tool:


as you see i’ve got enabled ‘Use custom screenlock’ option and screenlock command is:

> xlock -mode julia

you can explore the ‘modes’ of xlock and find yours


P.S. don’t forget that you can install .src.rpm files and rebuild EFL/E manually anytime you wish. here’s the EXAMPLE of a bash-script for it (the way i’m using right now)

cd /usr/src/packages/SPECS

export components="eet edb evas ecore embryo efreet edje epeg epsilon esmart emotion engrave ewl etk exml enhance imlib2_loaders imlib2_tools etk_extra e_dbus E17 eclair  emphasis entrance exhibit ephoto estickies elicit elitaire expedite emprint evfs exquisite edje_editor extrackt entropy rage e_modules itask-module E16 ethemes e16keyedit edox-data"

sudo mkdir -p ../RPMS/i586.old
sudo rm -rf ../BUILD/*
sudo cp -r ../RPMS/i586/* ../RPMS/i586.old/
sudo rm -rf ../RPMS/i586/*

for a1 in  $components ; do
rpmbuild -bb $a1.spec  || { echo "STOP! Look at the errors above!" && read a2 && exit 1 ; } 

if  "$a1" == "e_dbus" ] ; then
   sudo rpm -U --force ../RPMS/i586/*edbus*.rpm || { echo "STOP! Look at the errors above!" && read a2 && exit ; }
   sudo rpm -U --force ../RPMS/i586/*$a1*.rpm || { echo "STOP! Look at the errors above!" && read a2 && exit ; }


sh /home/sda/bin/rebuild_enlightenment_exalt.sh

last string starts the ‘exalt’ components upgrade

P.P.S. i’m working on solution to avoid locking issues, but no guarantees yet…

Thanks for the quick response Dmitri, I saw the option for the custom lock command but was hoping that the e17 lock worked :-/ if you need any help with testing that feel free to shoot me a message.

The src rpm thing is interesting, thanks for the little script :slight_smile: Everything is working for me right now though, so I probably won’t be updating until I have a good reason to.

Attention: it’s my fault (in general) but the last update of Enlightenment could be performed in a wrong way. i changed versions generation schema and an old packages may left on your PC. sorry.

Solution 1: reinstall all you have from the Enlightenment repo. if alias of this repo is ‘Enlightenment’ (just type ‘zypper lr’ in console to find it out) then the simple script below could help you to do the trick:

export a1="`sudo zypper se -r Enlightenment | grep i\  | awk -F\| '{ print $2 }' `"  && sudo zypper in -f -r Enlightenment $a1

Solution 2: reinstall only outdated and obsolete packages.

please ignore any messages that you’re ‘downgrading’ - they’re wrong. since now versions system won’t change any more (I hope so) and there should be no such issues any more.



recently we successfully transfered OBS Enlightenment repositories to the svn (from an old cvs) base, compiled new packages and released the new version of our Enlightenment LiveCD where all things are work “out from the box” (yes, you’re even welcome to open FF, go to the apple.com and watch brilliant ads to get the idea why only Apple is good enough. looks like we’d have something similar or at least learn the way of a building proper Public Relations/Propaganda routines).

you’re welcome to ‘digg’ our LiveCD if you wish:
Digg - openSUSE Enlightenment 17 Live

original Lizards post:
openSUSE Lizards » Enlightenment

download page:

the core info about our LiveCD is stated in the Welcome.pdf:

Think E, use OpenSUSE, be happy!

heh, congratulations to all. looks like we’ve reached the distrowatch…

DistroWatch.com: Put the fun back into computing. Use Linux, BSD.

Welcome to discuss our small contribution to the Wiki:

Enlightenment for openSUSE - openSUSE


P.S. please, if you wish to modify and article use the ‘Discussion’ page to offer Your improvements.

The repos are updated to the current svn. Changes:

  1. Exalt (Network Manager) is now split into the two packages - ‘exalt’ and ‘exalt_gui_etk’. Please remove all the old ones

  2. EFM (Enlightenment File Manager) now can drag’n’drop files on the Desktop and you can organize this files in the way you like (no strict align to grid).

  3. Huge improvements/optimizations for E17.

  4. 23Oz theme is improved (sliders are glowing now).

  5. A lot of minor improvements and adjustments.


P.S. Soon we’ll make an updated unofficial Enlightenment LiveCD and there gonna be hell of a lot improvements!

openSUSE Lizards » Enlightenment LiveCD


dmitry serpokryl wrote:

> ‘openSUSE Lizards » Enlightenment LiveCD’
> (http://lizards.opensuse.org/2008/09/29/enlightenment-livecd/)
> updated.
I would like to know about the 64-bit support in enlightenment.

what do you mean? did you look through this thread from the beginning? the first message:

Enlightenment (DR-16 and DR-17) - openSUSE Forums

is about to disclose the available repositories. packages are available for x86 and x86-64 (default OBS schema). if you’re asking about LiveCD - don’t see any reason to use x86-64 on a Desktop PC. still no Flash support for x86-64, weak support for dmo/dshow multimedia codecs and other disadvantages as well (x86-64 is nothing else but Marketing). i hope that soon we’ll make a package “Enlightenment LiveCD” and you can make your x86-64 with a single command.

Hi Dmitry,

Just wanted to say that I have been following your good efforts promoting Enlightenment. I am very curious to see & use the LiveCD.

Keep up the good work! :wink:


dmitry serpokryl wrote:

> what do you mean?
Pardon my ignorance. However, I found out that the latest stable release of
Enlightenment, i.e. v16 was released in 1999 when 64-bit systems were not
so commonplace as today. I looked up for bundled rpms and found that 32-bit
rpms are available. That’s why I asked about the support for 64-bit.

I found Enlightenment to be a good concept and would like to work on it.
However, first I just wanted to have a feel of the environment.

Thank you.

I tried your repository and got the following message.

There are no installable providers of Enlightenmnent_environment for pattern:Enlightenment-DR17 Desktop Shell Environment-.noarch[openSUSE_10.3_3]

Please suggest.

Thank you

Cross AM wrote:

> I tried your repository and got the following message.
> There are no installable providers of Enlightenmnent_environment for
> pattern:Enlightenment-DR17 Desktop Shell
> Environment-.noarch[openSUSE_10.3_3]
> Please suggest.
> Thank you
I have now successfully installed Enlightenment.

Sorry, was a kind of busy last week.

  1. I’d recommend to use this repo even if you’re running openSUSE-10.3:

Index of /repositories/home:/dmitry_serpokryl:/Enlightenment-cvs-core-metapackage

You will find there x86 and x86-64 packages for E16 and E17. Anyway please post here any questions.

  1. “There are no installable providers of Enlightenmnent_environment” - how did you get this warning? Did you install via “One-Click”? Which repo did you use?


Please, look through our modest Wiki page and advise if any additions are needed:

Enlightenment for openSUSE - openSUSE


During my “play with Linux for 2 weeks, then walk away from it for 6 months” period, which was a cycle for years, Enlightenment was always on my list of things to try. I’ve been out of that cycle for about a year and half, and am near 100% linux now – but I kinda forgot about Enlightenment until something today reminded me of it. I was happy to see your post here when I searched the forum!

So, I’ve installed E17 via the instructions on your wiki page, but when I log in to an Enlightenment session, my wirless card doesn’t connect, and I can’t figure out where or how to make it connect.

Could you give me a nudge?

5 minutes was enough to make me realize why screenshots of Enlightenment don’t do it justice. nice and unusual!

Thanks for any info!