Enlightenment (DR-16 and DR-17)

Hi guys!

Let me start this thread for all who wish to explore Enlightenment with OpenSUSE. Right now we’ve got several repos with compiled packages:

  1. A kind of ‘official’ one:

Index of /pub/opensuse/repositories/X11:/Enlightenment

unfortunately packages are quite outdated, but it’s nice to have them too.

  1. My repo for OpenSUSE-10.3:

Index of /repositories/home:/dmitry_serpokryl:/SOAD/openSUSE_10.3

Almost all packages are installed into non-standard location (/opt) and require a bit of attention (may be, may be not). The core benefit for you is that you’re NOT LIMITED to the content of this repo. Any time you can rebuild .spec file (or .src.rpm) and get a current cvs packed into .rpm and ready to install. Just read a description for each package.

  1. Another my repo originally designed for ‘Enlightenment_DR17-cvs-core-metapackage’ for OpenSUSE-10.2 - OpenSUSE-Factory. May be this repo will be merged with the second one, may be not. The only reason why this repos are not merged yet is a Rpmlint checks implemented into 11.0 - Factory. Working on it:

Index of /repositories/home:/dmitry_serpokryl:/Enlightenment-cvs-core-metapackage

The same benefits as in the second repo are here.

Why I not contributed to the ‘official’ repo? The answer is simple. Some packages/software are best when you get current cvs, svn, git etc. Like MPlayer, Enlightenment and so on. I don’t think that User should be limited to the ‘Packager’ will, good mood, spare time etc. If he wish to have a current cvs - he can rebuild .src.rpm. If he failed - he always has a repo with a ready to install packages. If this point of view is accepted - no problem to terminate my ‘home’ repos and transfer all packages to the ‘official’ one. I do understand that any duplicated package is not the way for OBS.

Another point is that I do wish to contribute to Enlightenment project. And I do believe that SuSE is the best GNU/Linux distro around (I’m using SuSE since 8.2 Pro). I do respect all the great job of SuSE dev team, but I don’t understand why ‘Pidgin’ require some parts of ‘Evolution’ as a dependency (I use ‘mutt’). Or why we have ‘JMeld’ in a base distribution when the original ‘meld’ works much better (though IMHO). And so on. That’s why was created SOAD (SuSE On Active Diet) repo.

If you’re interested to contribute to such project - you’re WELCOME. Any way! Even critics wich has sense are VALUABLE! But if you’re happy with your kde/gnome/xfce/etc and wish only to exhibit your supremacy - PLEASE, don’t post anything here.

I do believe that now and in the nearest future the only WM/Desktop Shelf which really bring valuable benefits to respective Users is Enlightenment. DR-16 or DR-17. It’s my IMHO. May be I’m wrong, but my experience with all WM’s/DE’s is stated clear.


Hi Dmitry,

I installed E17 from your link in the “desktop screenshots” thread, it installed OK but I don’t get an option to select E17 when I login.

Can you help me please?

Thanks :).

you will still have to go into yast and search for enlightenment and install the rest of the packages, i did all the packages except the devel ones then log out select enlightenment wala your in

Thanks Havoc, that fixed it :).

I can now login, but as soon as I click on anything it just freezes on me :(.

Any ideas where to look for the problem?

Let me just put a brief instruction here. If you’re new to Linux and interested only to take a look a Enlightenment-DR17, then PLEASE install ONLY a single rpm:


from the repo which suit your version of OpenSUSE:

Index of /repositories/home:/dmitry_serpokryl:/Enlightenment-cvs-core-metapackage

You’re welcome to use ‘One click install’. For 10.3 it would be:


For 11.0:


And please report your OpenSUSE version number incase of any issues.

About ‘freeze on click’… IMHO - that looks like you’ve installed some ‘duplicated’ components or enabled more than one repository for Enlightenment (and mixed some library versions). Please post to the pactebin.com the output of the following command (open your terminal <xterm, rxvt, konsole, etc> and type:

  1. zypper lr -e ./list_of_my_repos

This will create a file named ‘list_of_my_repos’ with all your repositories. But first of all I’d suggest you to remove all previously installed packages, install ‘Enlightenment_DR17-cvs-core-metapackage’ and log into E.

Thank you!

OK, I removed all the E17 packages, then used the 1-click link you provided above.

I’m using openSUSE 11.

Same thing as last time, no “enlightenment” option in the login menu thing.

I tried rebooting, still nothing.

Here are my repo lists as requested, I’m not sure how to use “pastebin”, and for some unknown reason I can’t attach a file to this post!

   | Alias                                                                                | Name                                                     | Enabled | Refresh
1  | home:netmax                                                                          | home:netmax                                              | Yes     | Yes    
2  | http://download.opensuse.org/repositories/games/openSUSE_11.0/                       | openSUSE BuildService - Games                            | Yes     | Yes    
3  | KDE:KDE4:UNSTABLE:Desktop                                                            | KDE:KDE4:UNSTABLE:Desktop                                | Yes     | Yes    
4  | http://download.nvidia.com/opensuse/11.0                                             | NVIDIA Repository                                        | Yes     | Yes    
5  | http://download.opensuse.org/repositories/GNOME:/Community/openSUSE_11.0/            | openSUSE BuildService - GNOME:Community                  | Yes     | Yes    
6  | http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0/ | openSUSE BuildService - KDE4:Factory:Desktop             | Yes     | Yes    
7  | http://download.opensuse.org/repositories/KDE:/Community/openSUSE_11.0/              | openSUSE BuildService - KDE:Community                    | Yes     | Yes    
8  | home:dmitry_serpokryl:Enlightenment-cvs-core-metapackage                             | home:dmitry_serpokryl:Enlightenment-cvs-core-metapackage | Yes     | Yes    
9  | http://ftp.skynet.be/pub/packman/suse/11.0/                                          | Packman Repository                                       | Yes     | Yes    
10 | repo-debug                                                                           | openSUSE-11.0-Debug                                      | No      | No     
11 | repo-oss                                                                             | openSUSE-11.0-Oss                                        | Yes     | Yes    
12 | KDE:Backports                                                                        | KDE:Backports                                            | Yes     | Yes    
13 | http://download.videolan.org/pub/videolan/vlc/SuSE/11.0/                             | VideoLan Repository                                      | Yes     | Yes    
14 | http://download.opensuse.org/repositories/KDE:/Backports/openSUSE_11.0/              | openSUSE BuildService - KDE:Backports                    | Yes     | Yes    
15 | home:MacSlow                                                                         | home:MacSlow                                             | Yes     | Yes    
16 | http://download.opensuse.org/repositories/Virtualization:/VirtualBox/openSUSE_11.0/  | openSUSE BuildService - Virtualization (VirtualBox)      | Yes     | Yes    
17 | KDE:KDE4:STABLE:Community                                                            | KDE:KDE4:STABLE:Community                                | Yes     | Yes    
18 | openSUSE-DVD 11.0                                                                    | openSUSE-DVD 11.0                                        | No      | No     
19 | repo-non-oss                                                                         | openSUSE-11.0-Non-Oss                                    | Yes     | Yes    
20 | GNOME:STABLE                                                                         | GNOME:STABLE                                             | Yes     | Yes    
21 | openSUSE-11.0-Updates                                                                | openSUSE-11.0-Updates                                    | Yes     | Yes    
22 | http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_11.0/               | openSUSE BuildService - GNOME:STABLE                     | Yes     | Yes    
23 | http://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.0/                    | openSUSE BuildService - X11:XGL                          | Yes     | Yes    
24 | games:tools                                                                          | games:tools                                              | Yes     | Yes    


Never mind, I removed the ‘Enlightenment_DR17-cvs-core-metapackage’ and simply installed ‘E17’ from Yast.

It works beautifully.

I even got Dmitry’s cool theme installed and working :D.

Man, I could get used to this desktop.

Speed, drop shadows, really nice looking, and fast as lightning!

It has a problem with minimising apps though, you have to use the minimise button otherwise they close (ie xchat and skype).

Plus network manager isn’t shown on the taskbar, I ran it manually from the menus, it connected me to the network, but still doesn’t show an icon.

Oh well, apart from that it is really nice, a refreshing change from the elephantile KDE4, and greedy Compiz.

Great. Am I correct that you’re running KDE4 and use ‘kdm’ as your login manager? Because I made a test with ‘gdm’ (it’s Gnome default login manager) and it works. I’d like to suggest to try ‘Entrance’ - it’s another login manager you already have installed with ‘E-metapackage’. You can make it with YAST, but it’d me much more simple just open your terminal, became ‘root’ (enter ‘su’ and root password) and type several commands.

  1. to begin with just check what you already have as enabled services (here’s the example from my box, you may receive a bit different output, but it’s ok):

chkconfig -l | grep dm

earlyxdm 0:off 1:off 2:off 3:off 4:off 5:off 6:off
gdm 0:off 1:off 2:off 3:off 4:off 5:off 6:off
mdadmd 0:off 1:off 2:off 3:off 4:off 5:off 6:off
xdm 0:off 1:off 2:off 3:off 4:off 5:off 6:off

‘mdadmd’ is not ineresting for us. See, that I turn all login managers ‘off’ (gdm, xdm and earlyxdm). May be you’ll see a line with ‘kdm’ also. We need to turn it also off.

  1. Disable all of this managers:

chkconfig earlyxdm off
chkconfig gdm off
chkconfig xdm off

may be you’ll also need to type

chkconfig kdm off

  1. And finally you’ll need to enable ‘Entrance’:

chkconfig entrance on
chkconfig entrance 35

  1. Just check the results:

chkconfig -l | grep entrance

entrance 0:off 1:off 2:off 3:on 4:off 5:on 6:off

That’s it. You need to reboot to activate the changes. If something goes wrong - don’t panic. Press Alt+Ctl+F1 (you’ll get the console login prompt, or Ctl+Alt+F2), login as ‘root’ and type (revert all back to defaults):

chkconfig earlyxdm on
chkconfig gdm on
chkconfig xdm on
chkconfig entrance off

(or may be you’ll type ‘chkconfig kdm on’). The idea is just to restore the case you had before.

Good luck! And thanks for your patience and comments!

Yep, that’s because we don’t have right now ‘systray’ function implemented into E17. Why? Because freedesktop specs sucks (if not to say more). I have a separate ‘systray’ package which works as a module for E17, but… just can’t recommend to install it (and it’s not available yet for ‘home:dmitry_serpokryl:Enlightenment-cvs-core-metapackage’ repository). You can use ‘trayer’, ‘stalonetray’ or any other external systray for it. You can read a bit about systray specs here:


scroll down to the message ‘Thursday, 2 February 2006 I hate systray icons’ or just search ‘systray’ as a keyword.

Thanks for all the help Dmitry.

You are right, I chose KDE4 when installing, and am using the kdm login manager.

I’ll give entrance a go later, thanks for the instructions.

Also a big thanks for making the packages, I’m really enjoying using E17, it runs so amazingly fast compared to KDE4.0/4.1and also KDE3 with any desktop effects enabled.

My laptop has an Nvidia 8400m GS video card, but KDE4 runs disappointingly slow, I use the driver from the repos.

The only desktop effect I really want is drop shadows, and E17 provides those as default with no messing around.

I find it is also rock solid when I play an openGL game, the KDEs gave me lockups/freezes/black screens when switching to/from full screen mode, or even when simply exiting a game! E17 works flawlessly :).

One question, is there a good volume control, which one works better with E17?

Thanks :).

Your 230z theme is awesome, well done.

Thanks! There’s a couple modules (‘mixer’ and ‘echo’) to control Master Volume/PCM in a package ‘e_modules’ (there’re a lot of funny stuff inside indeed). But for my OpenSUSE-11.0 seems that new ‘alsa’ require some patching. I’ll see this eve what I can do (though I’m not the developer, sorry). I guess that right now you’re welcome to use stand-alone apps for it (like ‘kmix’, ‘alsamixer’, ‘alsamixergui’ etc.)

Ok. Fixed. Was my fault. It’s nice to have a PC only for testing and not the one where you build all your stuff :). Grab ‘e_modules’ package, load ‘echo’ or ‘mixer’ and check others :).

Also added some EFL-based apps to the repo:

Index of /repositories/home:/dmitry_serpokryl:/Enlightenment-cvs-core-metapackage

Good stuff, thanks for those :).

Another question, you wouldn’t know how to enable openGL rendering would you?

I found an option (somewhere, forget where now though), to switch from software, to openGL rendering.

I tried it but it didn’t work, I was wondering if there was a special option I need to add to my xorg.conf, or if I can get an error report from somewhere.

I use the Nvidia driver provided by the openSUSE repos, openSUSE 11.

Thanks :).

Well, first of all I’d like to advise pay some attention to the command

> enlightenment_remote -h

It provide a bit more ‘extended’ configuration capabilities then GUI in EC (E Config Panel). Right now you can switch ‘engines’ from ‘software’ to ‘xrender’ BUT you won’t receive any benefits from it (only penalties, function is just for the developers). The ‘heart’ of E-DR17 is ‘evas’ - the canvas library. And you already have full OpenGL support compilled in as an engine. You can install ‘Expedite’ (complete test suite for E), open your terminal and type:

> expedite

It’ll show you a brief usage summary and give you an idea which engines are already compled into.

Right now the integration with OpenGL (and load of GPU instead of CPU for all windows manipulations if the acceleration exist) is a work in progress. You’re welcome to install Mac OS X if you need full-time OpenGL output right now :).

Thanks again for the extended info.

Unfortunately it’s a bit beyond me, I’m just an “average” user :D.

I’m happy to keep it as it is, it is so fast and reliable that I don’t want to disturb it.

We have a “global” update to the cvs-snapshot of July 09, 2008. Please remove ‘e_systray’ package, because it’ll breal your boot into E17 if installed and enabled.

Also we have a latest ‘E16’ packed along with ‘epplets’, ‘ethemes’ and ‘e16keyedit’ plus some extra themes from Nathan Baxter.


Yep, here it is:


it’s the second alpha release. Works nice, but still there’s a lot of space for improvements. CHECK md5sum and SIZE after download!

Brief Summary:


Login credentials:

User: linux
Pass: soad

User: root
Pass: soad

List of installed packages:


Total .iso size is about 455Mb today. A lot could be added, even OpenOffice… But… This LiveCD is not about OpenOffice.


Thanks Dmitry, downloading now :D.

You might want to consider using bittorrent for downloads, it will save your server being bogged down with downloads :).

I use torrentflux, it’s quite nice and easy to setup, and you can limit the upload speed.

Torrentflux-b4rt Home Page - A BitTorrent and Internet Transfer Web Control Application

Regards :).

This is a great thread. I’ve been playing with E and suse on and off since 10.3, and it’s rockin’ cool.