Enigmail + gnome-keyring + gpg-agent conflict

opensuse 42.1
enigmail 1.9.2
thunderbird 38.7.0
gpg-agent 2.0.24

Recently enigmail has been complaining about the gnome-keyring and gpg-agent.

GnuPG reported an error in the communication with gpg-agent (a component of GnuPG).
This is a system setup or configuration error that prevents Enigmail from working properly and cannot be fixed automatically.
We strongly recommend that you consult our support web site at https://enigmail.net/faq.

The enigmail site offered a set of challenges to resolving this issue:

  1. Getting past the bogus URL; it fails utterly without the “www.” sub-domain.
  2. Discovering which part of the FAQ was applicable since none of the above text was explicitly mentioned in the FAQ (first section, step 4; the rest is irrelevant).
  3. Deciding which non-opensuse method might be correct.

On page <https://wiki.gnupg.org/GnomeKeyring> it (weakly) recommends disabling gnome-keyring using “dpkg-divert.” No such command in opensuse.

Another page <http://blog.josefsson.org/2015/01/02/openpgp-smartcards-and-gnome/> suggested copying gnome-keyring to <~/.config/sutostart/>, and adding “hidden-true” to the end of the file. And that re-ordering the startup of gpg-agent and gnome-keyring might be a good idea, so that gpg-agent supersedes gnome-keyring. No hint as to how that might be accomplished, though.

None of the methods were appropriate. The brute force method of renaming the gnome-keyring-gpg.dsektop file by adding “-disable” to the end, then killing gnome-keyring-daemon, worked. I am not sanguine that is a desirable method.

Finally, my question: What is the opensuse way to start gnome-keyring and gpg-agent into a properly working arrangement?

Note that I normally use KDE, rather than Gnome. I am not having problems.

I think you installed “enigmail” from the “enigmail” site or maybe from mozilla.org.

I have installed it from the opensuse repo. My understanding is that there is some incompatibility unless you use the version from the opensuse repo. I ran into that a while ago (maybe with opensuse 13.1).

So, if I’m right about how you installed enigmail, then my suggestion is:

  • Uninstall the enigmail addon
  • Install the opensuse enigmail package.

I do not recall how Enigmail was installed into TB; probably, though, from the Mozilla add-on site. It is installed on my system from the repo.

How do I install an add-on without the usual XPI installation file?

For me, enigmail is automatically there once I install from the repo. It seems to be in “/usr/lib64/mozilla/extensions”. And apparently, Thunderbird knows to look there.

If you installed from the “.xpi” file, then that probably overrides the version from the repo.

Okay, I removed Enigmail, restarted TB. And Enigmail 1.8.2 magically appeared. (The latest version is 1.9.2.) It works; I will know for sure when I restart the computer in a couple of days after the weekly update.

Thank you.

I had occasion to log out/in. All is working as expected for Enigmail and other security services.

I’m glad it’s working.

And thanks for reporting back what happened.